fatkid lab 330

From: Cheong Kok Yong (kycheong@xxxxxxxxxxxxxx)
Date: Sun May 27 2001 - 01:11:42 GMT-3


   
Hi,

I achieved a weird outcome for the above lab, R1 is running ipx NLSP &
Eigrp, accrding to the diagram, R4 is no way of getting to know the network
of 505050 (which is running NLSP) without redistributing from NLSP to EIGRP,
but the net 505050 is appearing in R4 routing table even without any
redistribution configured at R1 with E 505050 [297756416/1] via
606060.0001.0001.0001, age 00:10:02,1u, Tu0.

Am I missing something ?

Thanks in advance.

Cheong

r1#sh run
hostname r1

ipx routing 0001.0001.0001
ipx internal-network 100
cns event-service server
!
interface Loopback0
 ip address 10.1.6.1 255.255.255.0
 no ip directed-broadcast
 ipx network AAAAAA
!
interface Tunnel0
 no ip address
 no ip directed-broadcast
 ipx network 606060
 tunnel source 10.1.6.1
 tunnel destination 10.1.5.4
!
interface Serial1/0
 ip address 10.1.2.1 255.255.255.0
 no ip directed-broadcast
 ipx network 505050
 ipx nlsp enable
 ipx nlsp rip off
 ipx nlsp sap off
 clockrate 64000
!
interface Serial1/1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!

router eigrp 1
 network 10.0.0.0
 no auto-summary
!
ipx router eigrp 1
 network 606060
!
ipx router nlsp
 area-address 0 0
 no redistribute rip
!
ipx router rip
 no network all
!
ipx sap 4 Server AAAAAA.0000.0000.5555 451 1
!
end

r1#sh ipx ro
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static

10 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

L 100 is the internal network
C 505050 (HDLC), Se1/0
C 606060 (TUNNEL), Tu0
C AAAAAA (UNKNOWN), Lo0
N 200 [40][06/01] via 200.0000.0000.0001, 539s, Se1/0
E 101010 [307100416/2] via 606060.0000.0000.4444, age 00:09:05,
                         7u, Tu0
E 202020 [297756416/1] via 606060.0000.0000.4444, age 00:09:05,
                         1u, Tu0
E 404040 [297270016/1] via 606060.0000.0000.4444, age 00:09:05,
                         1u, Tu0
E BBBBBB [297372416/1] via 606060.0000.0000.4444, age 00:09:05,
                         1u, Tu0
N CCCCCC [40][05/01] via 200.0000.0000.0001, 539s, Se1/0
r1#sh ipx ei to
IPX EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 100, 1 successors, FD is 45842176
         via Redistributed (45842176/0)
P 200, 0 successors, FD is Inaccessible
         via 606060.0000.0000.4444 (300060416/269312000), Tunnel0
P 101010, 1 successors, FD is 307100416
         via 606060.0000.0000.4444 (307100416/276352000), Tunnel0
P 202020, 1 successors, FD is 297756416
         via 606060.0000.0000.4444 (297756416/20512000), Tunnel0
P 404040, 1 successors, FD is 297270016
         via 606060.0000.0000.4444 (297270016/281600), Tunnel0
P 505050, 1 successors, FD is 20512000
         via Redistributed (20512000/0)
P 606060, 1 successors, FD is 297244416
         via Connected, Tunnel0
P AAAAAA, 1 successors, FD is 128256
         via Redistributed (128256/0)
P BBBBBB, 1 successors, FD is 297372416
         via 606060.0000.0000.4444 (297372416/128256), Tunnel0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P CCCCCC, 0 successors, FD is Inaccessible
         via 606060.0000.0000.4444 (300060416/269312000), Tunnel0
r4#sh run
hostname r4
!
ipx routing 0004.0004.0004
!
interface Loopback0
 ip address 10.1.5.4 255.255.255.0
 no ip directed-broadcast
 ipx network BBBBBB
!
interface Tunnel0
 mac-address 0000.0000.4444
 no ip address
 no ip directed-broadcast
 ipx network 606060
 tunnel source 10.1.5.4
 tunnel destination 10.1.6.1
!
interface Ethernet0/0
 mac-address 0000.0000.4444
 ip address 10.1.4.4 255.255.255.0
 no ip directed-broadcast
 ipx network 404040
 ipx gns-reply-disable
!
interface TokenRing0/0
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
!
interface Serial1/1
 ip address 192.19.15.2 255.255.255.0
 no ip directed-broadcast
 ipx input-sap-filter 1000
 ipx network 202020
!
router eigrp 1
 network 10.0.0.0
 no auto-summary
!
ip classless
!
access-list 1000 deny FFFFFFFF 112 HPPrinter
access-list 1000 permit FFFFFFFF
!
!
!
ipx router eigrp 1
 network 606060
!
!
ipx router rip
 no network 606060
!
!
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

r4# sh ipx ro
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static

10 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C 202020 (HDLC), Se1/1
C 404040 (NOVELL-ETHER), Et0/0
C 606060 (TUNNEL), Tu0
C BBBBBB (UNKNOWN), Lo0
E 100 [297372416/1] via 606060.0001.0001.0001, age 00:10:02,
                         1u, Tu0
R 200 [02/01] via 404040.0010.7b7e.f69f, 13s, Et0/0
R 101010 [07/01] via 202020.0007.0007.0007, 16s, Se1/1
E 505050 [297756416/1] via 606060.0001.0001.0001, age 00:10:02,
                         1u, Tu0
E AAAAAA [297372416/1] via 606060.0001.0001.0001, age 00:10:02,
                         12u, Tu0
R CCCCCC [02/01] via 404040.0010.7b7e.f69f, 13s, Et0/0
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:54 GMT-3