PIM sparse mode configuration w/IRB and ISL trunks

From: Tim (tschlos1@xxxxxxxxxxxxx)
Date: Tue May 22 2001 - 20:03:17 GMT-3


   
I am attempting to configure multicast routing on a 2600 running version
12.09. The router has a fast ethernet interface configured with multiple
VLAN's via ISL trunking. I am also running IRB (bridge group 45) on two
subinterfaces fa0/0.4 and fa0/0.5. My OSPF adjacensies are woring properly as
well as the BVI interface prior to enable multicast routing. After I enable
the multicast routing on the subinterface and turn on cgmp, my OSPF neighbor
adjacensies attached to the fa0/0.4 and fa0/0.5 subinterfaces disappear. I
ran several debugs (debug ip ospf adj and debug ip ospf events) but could find
nothing wrong. As soon as I take off the command ip pim sparse-mode and the
ip cgmp, the ospf adjacensies are formed.

Also, if I put the pim commands back into the router, the OSPF adjacensies
remain active. However, when I reload the router, the neighbor adjacencies
no longer form.

Any thoughts on what I may be doing wrong or if this could be a bug with the
IOS. I realize that I doing quite a few things with these interfaces, but you
never know what they may ask you in the lab.

Following is the config I was working with for the 2600 router:

!
memory-size iomem 10
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
ip dvmrp route-limit 20000
ipx routing 0007.0007.0007
bridge irb
!
dlsw local-peer peer-id 150.2.1.7
dlsw remote-peer 0 tcp 150.2.1.5
dlsw bridge-group 1
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
interface Loopback0
 ip address 150.2.1.7 255.255.255.255
 no ip directed-broadcast
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 192.168.0.3 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 ip pim sparse-mode
 ip cgmp
 bridge-group 45
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 150.1.2.7 255.255.255.128
 no ip redirects
 no ip directed-broadcast
 ip pim sparse-mode
 ip cgmp
 ipx encapsulation NOVELL-ETHER
 ipx network 272
!
interface FastEthernet0/0.3
 encapsulation isl 3
 ip address 150.1.3.7 255.255.255.128
 no ip redirects
 no ip directed-broadcast
 ip pim sparse-mode
 ip cgmp
!
interface FastEthernet0/0.4
 encapsulation isl 4
 ip address 150.1.4.7 255.255.255.192
 no ip redirects
 no ip directed-broadcast
 ip pim sparse-mode
 ip ospf cost 5
 ip cgmp
 no ip mroute-cache
 bridge-group 45
!
interface FastEthernet0/0.5
 encapsulation isl 5
 ip address 150.1.5.7 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 ip pim dense-mode
 ip cgmp
 bridge-group 45
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BVI45
 no ip address
 no ip directed-broadcast
 ipx network 45
!
router ospf 1
 network 150.1.2.0 0.0.0.127 area 0
 network 150.1.3.0 0.0.0.127 area 0
 network 150.1.4.0 0.0.0.63 area 2
 network 150.1.5.0 0.0.0.255 area 2
 network 150.2.1.7 0.0.0.0 area 0
 network 192.168.0.0 0.0.0.255 area 4
 log-adjacency-changes
!
ip classless
no ip http server
ip pim send-rp-announce FastEthernet0/0.4 scope 16
ip pim send-rp-announce FastEthernet0/0.5 scope 16
!
!
!
!
!
bridge 1 protocol ieee
bridge 45 protocol ieee
 bridge 45 route ipx
!

Thanks for an assistance,
Tim Schlosser
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:49 GMT-3