Re: Terminal Server for the first time !!! [7:5119]

From: emonk@xxxxxxx
Date: Tue May 22 2001 - 04:43:19 GMT-3


   
D.J.,

Here is a long winded quick and dirty terminal server
tutorial.

The line numbers you sent are like that in the 2600
series. Thats normal. Add 2000 plus the line number and
you got it. Which you did.

First of all you should be aware of the commands show
session, clear session, sh line, and clear line. Make
sure you understand what these are used for. Here is a
quick explaination.

Show line <-- if you have an asterisk to the left of
your line.

clear line <line #> Use this until it clears the
asterisk away from the left of the line number after you
list it by using "show line". Now your line is open.

Show session <-- this shows sessions that are open.
clear session <sess#> <-- clears specific sessions.

Usually you go through and use the host name on each
router shift-ctrl-6, then x. Open each session one after
the other until each router is open. Then only use your
session # to get to each router. You use the shift-ctrl-
6, x, then session # each time. If you open R1 first it
will session 1, then you would open R2 it would be
session 2. So now get to router 8 from router two. All
you would do is shift-ctrl-6, then 8. Its very quick and
efficient way to use your terminal server.

Things to check for:

1) Your line numbers are 2033-2040 for octal plug 1-8.
So Put your Octal plug in the top connector marked 0-7.
Double check this.

2) Check the numbering on your octal cable. First octal
number, which is always a one on a Cisco octal cable and
most others. But I have seen them start with 0. So if
you have a non-cisco octal cable double check the
numbering scheme.

Whatever number it starts with. I assume you have a
Cisco Octal. They start at 1. So the line numbers
correspond like this. 1 is 2033, 2 is 2034 and so on.
Make sure the router you want to console to has the
corresponding plug in the console port. in your case the
one marked with the 2 should be in the router you want
to get to. Make sure the router is powered up and
through the boot cycle. Just to make sure when you hit
enter you get the prompt right away.

2) Make sure your ip address 1.1.1.1 actually exists. I
usually put it on a loopback to make sure it is always
functional. Its a good practice. Why you ask? If you put
it on an interface in use and then shut it down what
would happen to your reverse telnet sessions?? Think
about that one.

3) Check your line 33 48 and make sure "transport input
all" command is there.

4) Optional stuff. Add under you line con 0. "no exec-
timeout 0 0" Keeps you from being logged out
automatically.

That should do it.
> I've seen many folks with problems with this as well as myself. I have a
> 2621 with a 16 port async mod and octal cable. My octal cable is plugged in
> the slot serving ports 0-7 and the slot serving port 8-15 is open. The only
> available async lines I have based on what the router tells me is:
>
> line 33 48.
>
> I'm still receving the error:
>
> Trying r2 (1.1.1.1, 2034)....Open
>
> but I never connect.
>
> Any suggestions..dj
>
> ----- Original Message -----
> From: <emonk@att.net>
> To: <ccielab@groupstudy.com>
> Cc: "CCIE" <ccielab@groupstudy.com>; "Jeongwoo Park" <jpark@wams.com>
> Sent: Monday, May 21, 2001 9:58 AM
> Subject: RE: Terminal Server for the first time !!! [7:5119]
>
>
> > Guys,
> >
> > The only command required under the lines is.
> > "Transport input all". Here is my output from my 2511
> > with comments at each type of line. I have also owned a
> > 2509 and it was exactly the same except I only had line
> > 1-8. Guaranteed this is correct.
> >
> > Needed for your PC console session.
> >
> > line con 0
> > exec-timeout 0 0 <-- Optional. The exec-timeout 0 0
> > keeps your session from timing out.
> > privilege level 15 <-- Optional. Puts you into
> > executive privilege mode without having to go through
> > the motions.
> >
> > **These are your lines that go to your test Routers with
> > the octopus cable. Yours on a 2509 will be "line 1 8".
> >
> > line 1 16
> > transport input all
> >
> > **No config needed here. Usually used for asynch backup
> > device. Like a modem. Probably should play with it.
> >
> > line aux 0
> >
> > **No config. needed here. Just for telnetting to
> > termserver. Should set it up and play with it. I
> > included my config statements so you had an example.
> >
> > line vty 0 4
> > privilege level 15
> > password xxxxx
> > login
> > transport input telnet
> > > Is it necessary to also add the command "no exec", that prevents the
> output
> > > of the routers you are reverse telnetting into from initiating a session
> > > with the terminal server? I had problems with my terminal server until I
> > > added this command.
> > >
> > > Bruce
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > > Chris Mott
> > > Sent: Sunday, May 20, 2001 11:53 AM
> > > To: CCIE; Jeongwoo Park
> > > Subject: RE: Terminal Server for the first time !!! [7:5119]
> > >
> > >
> > > Use these two commands alone on the "line vty 0 ?" section:
> > >
> > > no exec-timeout
> > > transport input all
> > >
> > > remove the rest, and continue working normally ... and don't confuse
> issues
> > > by adding too many commands! this will bite you in the lab ... do only
> what
> > > is required, with a minimal set of commands, and move on ... getting
> cute or
> > > tricky is not the goal of the lab ... most often, the more complicated
> > > questions have as an answer one or two commands, nothing more ...
> > >
> > > HTH
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > > Jeongwoo Park
> > > Sent: Sunday, May 20, 2001 4:40 AM
> > > To: Yongchul Yang; Ccielab@Groupstudy. Com
> > > Subject: RE: Terminal Server for the first time !!! [7:5119]
> > >
> > >
> > > Hi all
> > > I made some changes on config.
> > > Still didn't work.
> > >
> > > Here is new config:
> > >
> > >
> > > TermServer#sh run
> > > Building configuration...
> > >
> > > Current configuration:
> > > !
> > > version 12.0
> > > service timestamps debug uptime
> > > service timestamps log uptime
> > > no service password-encryption
> > > !
> > > hostname TermServer
> > > !
> > > enable password wams
> > > !
> > > ip subnet-zero
> > > no ip domain-lookup
> > > ip host r1 2001 1.1.1.1
> > > ip host r2 2002 1.1.1.1
> > > ip host r3 2003 1.1.1.1
> > > !
> > > !
> > > !
> > > interface Loopback0
> > > ip address 1.1.1.1 255.255.255.255
> > > no ip directed-broadcast
> > > !
> > > interface Ethernet0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > > !
> > > interface Serial0
> > > ip address 5.5.5.5 255.255.255.0
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > no fair-queue
> > > clockrate 64000
> > > !
> > > interface Serial1
> > > ip address 5.5.6.5 255.255.255.0
> > > no ip directed-broadcast
> > > !
> > > ip classless
> > > !
> > > !
> > > line con 0
> > > no exec
> > > transport input none
> > > line 1 8
> > > transport input all
> > > transport output none
> > > stopbits 1
> > > line aux 0
> > > line vty 0 4
> > > login
> > > !
> > > end
> > >
> > > Now I did "sh line"
> > >
> > > TermServer#sh line
> > > Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
> Int
> > > * 0 CTY - - - - - 15 0
> 0 -
> > > * 1 TTY 9600/9600 - - - - - 7 20
> /17 -
> > > * 2 TTY 9600/9600 - - - - - 7 0
> 0 -
> > > 3 TTY 9600/9600 - - - - - 1 0
> 0 -
> > > 4 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 5 TTY 9600/9600 - - - - - 0 323
> 9/539 -
> > > 6 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 7 TTY 9600/9600 - - - - - 0 15
> 9/356 -
> > > * 8 TTY 9600/9600 - - - - - 0 22
> /63 -
> > > 9 AUX 9600/9600 - - - - - 0 0
> 0 -
> > > 10 VTY - - - - - 0 0
> 0 -
> > > 11 VTY - - - - - 0 0
> 0 -
> > > 12 VTY - - - - - 0 0
> 0 -
> > > 13 VTY - - - - - 0 0
> 0 -
> > > 14 VTY - - - - - 0 0
> 0 -
> > >
> > > Then I did this
> > >
> > > TermServer#clear line 1
> > > [confirm]
> > > [OK]
> > > TermServer#clear line 2
> > > [confirm]
> > > [OK]
> > > TermServer#clear line 8
> > > [confirm]
> > > [OK]
> > > TermServer#sh line
> > > Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
> Int
> > > * 0 CTY - - - - - 15 0
> 0 -
> > > 1 TTY 9600/9600 - - - - - 7 90
> /26 -
> > > 2 TTY 9600/9600 - - - - - 7 0
> 0 -
> > > 3 TTY 9600/9600 - - - - - 1 0
> 0 -
> > > 4 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 5 TTY 9600/9600 - - - - - 0 323
> 9/539 -
> > > 6 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 7 TTY 9600/9600 - - - - - 0 15
> 9/356 -
> > > * 8 TTY 9600/9600 - - - - - 0 22
> /63 -
> > > 9 AUX 9600/9600 - - - - - 0 0
> 0 -
> > > 10 VTY - - - - - 0 0
> 0 -
> > > 11 VTY - - - - - 0 0
> 0 -
> > > 12 VTY - - - - - 0 0
> 0 -
> > > 13 VTY - - - - - 0 0
> 0 -
> > > 14 VTY - - - - - 0 0
> 0 -
> > >
> > > Now it shows this:
> > >
> > > TermServer#sh line
> > > Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
> Int
> > > * 0 CTY - - - - - 15 0
> 0 -
> > > 1 TTY 9600/9600 - - - - - 7 90
> /26 -
> > > 2 TTY 9600/9600 - - - - - 7 0
> 0 -
> > > 3 TTY 9600/9600 - - - - - 1 0
> 0 -
> > > 4 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 5 TTY 9600/9600 - - - - - 0 323
> 9/539 -
> > > 6 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 7 TTY 9600/9600 - - - - - 0 15
> 9/356 -
> > > * 8 TTY 9600/9600 - - - - - 0 22
> /63 -
> > > 9 AUX 9600/9600 - - - - - 0 0
> 0 -
> > > 10 VTY - - - - - 0 0
> 0 -
> > > 11 VTY - - - - - 0 0
> 0 -
> > > 12 VTY - - - - - 0 0
> 0 -
> > > 13 VTY - - - - - 0 0
> 0 -
> > > 14 VTY - - - - - 0 0
> 0 -
> > >
> > > At this point, I am confused because line 8 was not cleared.
> > >
> > > Now I typed "r1" This is what it looks like:
> > >
> > > TermServer#r1
> > > Trying r1 (1.1.1.1, 2001)... Open
> > > And I get stuck forever.
> > > I had to go (ctrl+shift+6)+X to go back to TermServer prompt.
> > > At TermServer prompt, I did "sh line" again.
> > >
> > > TermServer#sh line
> > > Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
> Int
> > > * 0 CTY - - - - - 16 0
> 0 -
> > > * 1 TTY 9600/9600 - - - - - 8 90
> /26 -
> > > 2 TTY 9600/9600 - - - - - 7 0
> 0 -
> > > 3 TTY 9600/9600 - - - - - 1 0
> 0 -
> > > 4 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 5 TTY 9600/9600 - - - - - 0 323
> 9/539 -
> > > 6 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 7 TTY 9600/9600 - - - - - 0 15
> 9/356 -
> > > * 8 TTY 9600/9600 - - - - - 0 22
> /63 -
> > > 9 AUX 9600/9600 - - - - - 0 0
> 0 -
> > > 10 VTY - - - - - 0 0
> 0 -
> > > 11 VTY - - - - - 0 0
> 0 -
> > > 12 VTY - - - - - 0 0
> 0 -
> > > 13 VTY - - - - - 0 0
> 0 -
> > > 14 VTY - - - - - 0 0
> 0 -
> > >
> > > So I cleared line 1 by doing this "clear line 1"
> > > And typed r1. It still showed this shit.
> > > TermServer#r1
> > > Trying r1 (1.1.1.1, 2001)... Open
> > >
> > > I just made longer message than I intended to. But since I am struggling
> to
> > > get this to work, I want to try every possible way.
> > > I hope I showed you better.
> > > Any input would be appreciated
> > > Thanks.
> > >
> > > Jeongwoo
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: Yongchul Yang [mailto:whycwhy@socal.rr.com]
> > > Sent: Sunday, May 20, 2001 12:09 AM
> > > To: Jeongwoo Park
> > > Subject: RE: Terminal Server for the first time !!! [7:5119]
> > >
> > >
> > > Jeongwoo,
> > >
> > > Don't let other sample configuration confuse you, your configuration is
> > > absolutely correct. It just takes a few practice sessions to get
> > > comfortable using the terminal server. A lot of people make simple
> mistakes
> > > on how to use it. Just simply press 2nd 'enter' key after typing r1 &
> > > enter. If the session is refused by any reason, just check the line
> status
> > > with either 'show session' or 'show line' command. If you are using
> 2509
> > > with rj45 asynch interface make sure you are using the rolled cable, if
> you
> > > are using the octal cable, they are already rolled. Another scenario is
> > > using the rj45 patch panel, if you have octal or rolled rj45 cable
> connected
> > > to the patch panel, make sure you are using the straight cable between
> your
> > > routers' console ports.
> > >
> > > Once you have the physical set up of using the terminal server, keep
> > > practice using it on all you lab exam practice, then you will start
> > > developing some short cuts of your own. I don't particularly like using
> the
> > > terminal server because I can only monitor one router at a time, but
> that's
> > > what you are going to have at your lab exam.
> > >
> > > Good luck,
> > >
> > > Yongchul Yang
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > > Jeongwoo Park
> > > Sent: Saturday, May 19, 2001 7:34 AM
> > > To: cisco@groupstudy.com
> > > Subject: Terminal Server for the first time !!! [7:5119]
> > >
> > > Hi all
> > > How can I get my 2509 terminal server to work?
> > > Here is my config
> > >
> > > TermServer#sh r
> > > 05:47:29: %SYS-5-CONFIG_I: Configured from console by consoleun
> > > Building configuration...
> > >
> > > Current configuration:
> > > !
> > > version 12.0
> > > service timestamps debug uptime
> > > service timestamps log uptime
> > > no service password-encryption
> > > !
> > > hostname TermServer
> > > !
> > > enable password wams
> > > !
> > > ip subnet-zero
> > > no ip domain-lookup
> > > ip host r1 2001 1.1.1.1
> > > ip host r2 2002 1.1.1.1
> > > ip host r3 2003 1.1.1.1
> > > !
> > > !
> > > !
> > > interface Loopback0
> > > ip address 1.1.1.1 255.255.255.255
> > > no ip directed-broadcast
> > > !
> > > interface Ethernet0
> > > no ip address
> > > no ip directed-broadcast
> > > shutdown
> > > !
> > > interface Serial0
> > > ip address 2.2.50.2 255.255.255.252
> > > no ip directed-broadcast
> > > no ip mroute-cache
> > > no fair-queue
> > > clockrate 64000
> > > shutdown
> > >
> > > !
> > > interface Serial1
> > > ip address 3.3.50.1 255.255.255.252
> > > no ip directed-broadcast
> > > clockrate 1300000
> > > shutdown
> > > !
> > > ip classless
> > > !
> > > !
> > > line con 0
> > > line 1 8
> > > no exec
> > > transport input all
> > > line aux 0
> > > line vty 0 4
> > > login
> > > !
> > > end
> > >
> > > I have three other router that are r1, r2, and r3 respectively.
> > > How can I get to r1, r2, or r3?
> > > Isn't it this one? for example,
> > > TermServer#r1
> > > TermServer#r2
> > > TermServer#r3
> > > It did not work
> > > I am using termserver for the first time.
> > > Can someone guide me through how to use it?
> > >
> > > In addition, here is output of "sh line"
> > >
> > > TermServer#sh line
> > > Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
> Int
> > > * 0 CTY - - - - - 6 1
> 0 -
> > > * 1 TTY 9600/9600 - - - - - 3 2
> 0 -
> > > * 2 TTY 9600/9600 - - - - - 2 0
> 0 -
> > > 3 TTY 9600/9600 - - - - - 1 0
> 0 -
> > > 4 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 5 TTY 9600/9600 - - - - - 0 104
> 0 -
> > > 6 TTY 9600/9600 - - - - - 0 0
> 0 -
> > > 7 TTY 9600/9600 - - - - - 1 0
> 1/243 -
> > > 8 TTY 9600/9600 - - - - - 0 6
> 8/622 -
> > > 9 AUX 9600/9600 - - - - - 0 0
> 0 -
> > > 10 VTY - - - - - 1 0
> 0 -
> > > 11 VTY - - - - - 0 0
> 0 -
> > > 12 VTY - - - - - 0 0
> 0 -
> > > 13 VTY - - - - - 0 0
> 0 -
> > > 14 VTY - - - - - 0 0
> 0 -
> > > Thanks
> > >
> > > jp
> > > FAQ, list archives, and subscription info:
> > > http://www.groupstudy.com/list/cisco.html
> > > Report misconduct and Nondisclosure violations to abuse@groupstudy.com
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:48 GMT-3