BGP Route Selection

From: zhutong (zhutong@xxxxxxxxxxxxxx)
Date: Tue May 22 2001 - 01:04:18 GMT-3


   
I have three routers, R1 is in AS 1, R2 & R3 in AS100, following are there conf
iguratons,
and "show ip bgp" for R2 and R3, it seems not using the best path, why?

R1
========================================
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
interface Serial1/0
 ip address 192.168.20.17 255.255.255.240
interface Serial1/1
 ip address 192.168.20.49 255.255.255.240
router bgp 1
 network 1.0.0.0
 neighbor 192.168.20.18 remote-as 100
 neighbor 192.168.20.50 remote-as 100

R2
========================================
interface FastEthernet0/0
 ip address 192.168.20.65 255.255.255.240
interface Serial1/0
 ip address 192.168.20.18 255.255.255.240
router bgp 100
 bgp default local-preference 200
 neighbor 192.168.20.17 remote-as 1
 neighbor 192.168.20.17 weight 1000
 neighbor 192.168.20.66 remote-as 100
 neighbor 192.168.20.66 weight 3000

R3
========================================
interface FastEthernet0/0
 ip address 192.168.20.66 255.255.255.240
interface Serial1/0
 ip address 192.168.20.50 255.255.255.240
router bgp 100
 bgp default local-preference 300
 neighbor 192.168.20.49 remote-as 1
 neighbor 192.168.20.65 remote-as 100

here are "show ip bgp" output
R1
-----------------------------------------------------------------
   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768 i

R2
-----------------------------------------------------------------
   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 192.168.20.17 0 1000 1 i
* i 192.168.20.49 0 300 3000 1 i

R3
-----------------------------------------------------------------
   Network Next Hop Metric LocPrf Weight Path
* i1.0.0.0 192.168.20.17 0 200 0 1 i
*> 192.168.20.49 0 0 1 i
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:48 GMT-3