Re: DDR With Back To Back AUX

From: Don Dettmore (don@xxxxxxxxxxxxx)
Date: Mon May 21 2001 - 21:16:04 GMT-3


   
Jason,

Here is the deal on my setup:

RouterB (Async port 8) <--> USRSportster <--> PSTN <--> USRSportster <-->
Orlando0 (AUX Port)

Here are the configs (ignore all the extraneous crap):

RouterB#sh run
Building configuration...

Current configuration:
!
version 11.2
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
no service udp-small-servers
service tcp-small-servers
!
hostname RouterB
!
enable secret 5 $1$G/la$kSFNx127Ah9HBsx74Qh5T1
!
username Orlando0 password 7 1048000A000504
ip subnet-zero
no ip domain-lookup
ip host R4500 2002 192.168.255.2
ip host RD 2007 192.168.255.2
ip host CAT 2001 192.168.255.2
ip host R4 2002 192.168.255.2
ip host ROUTERA 2005 192.168.255.2
ip host RA 2005 192.168.255.2
ip host RC 2006 192.168.255.2
ip host ROUTERC 2006 192.168.255.2
ip host LANROUTER 2004 192.168.255.2
ip host LR 2004 192.168.255.2
ip host FRAMERELAY 2003 192.168.255.2
ip host FR 2003 192.168.255.2
ip host ROUTERD 2007 192.168.255.2
ip host CAT5000 2001 192.168.255.2
ipx routing 0000.30b1.fc6e
ipx ping-default novell
chat-script dialout "" "atdt\T" TIMEOUT 600 CONNECT \c
clock timezone est -5
!
interface Loopback0
 ip address 192.168.255.2 255.255.255.255
!
interface Serial0
 ip address 2.2.2.1 255.255.255.252
 ipx network 222
 clockrate 4000000
!
interface Serial1
 ip address 2.2.2.5 255.255.255.252
!
interface TokenRing0
 ip address 1.0.0.1 255.255.255.0
 ipx network 116
 ring-speed 16
!
interface Async8
 no ip address
 encapsulation ppp
 async mode dedicated
 dialer in-band
 dialer rotary-group 1
!
interface Dialer1
 ip address 172.16.253.1 255.255.255.252
 encapsulation ppp
 ipx network 172253
 dialer in-band
 dialer idle-timeout 1200
 dialer map snapshot 2 name Orlando0 modem-script dialout broadcast
4075551212
 dialer map ip 172.16.253.2 name Orlando0 modem-script dialout broadcast
5551212
 dialer-group 1
 snapshot client 5 480 dialer
 ppp authentication chap
!
router igrp 100
 network 192.168.255.0
 network 1.0.0.0
 network 172.16.0.0
!
router bgp 65222
 neighbor 2.2.2.2 remote-as 17231
 neighbor 2.2.2.6 remote-as 17231
!
no ip classless
logging buffered 32768 debugging
!
!
dialer-list 1 protocol ip permit
!
line con 0
line 1 7
 modem Host
 transport input all
line 8
 password 7 044A1C031D3555
 login
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 stopbits 1
 rxspeed 57600
 txspeed 57600
 flowcontrol hardware
line aux 0
 transport input all
line vty 0 4
 exec-timeout 0 0
 password 7 08305B4B1B0D1C
 login
!
ntp clock-period 17179876
ntp server 172.16.255.1
end

Orlando0#sh run
Building configuration...

Current configuration : 2272 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname Orlando0
!
boot system flash c2600-d-mz.122-1.bin
logging rate-limit console 10 except errors
enable secret 5 $1$aN2b$1FCUxyZFmTCEkdN.RLkVK1
!
username RouterB password 7 1048000A000504
clock timezone est -5
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
ipx routing 0005.3247.1980
chat-script dialout "" "atdt\T" TIMEOUT 600 CONNECT \c
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 ip address 192.168.41.242 255.255.255.252
 ipx network 19241240
 no fair-queue
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/1.1 point-to-point
 ip address 192.168.41.249 255.255.255.252
 ipx network 19241248
 frame-relay interface-dlci 100
!
interface Serial0/1.2 point-to-point
 ip address 172.54.249.246 255.255.255.252
 ipx network 172244
 frame-relay interface-dlci 102
!
interface Async65
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 async mode dedicated
!
interface Dialer1
 ip address 172.16.253.2 255.255.255.252
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 1200
 dialer map snapshot 2 name RouterB modem-script dialout broadcast
94075551313
 dialer map ip 172.16.253.1 name RouterB modem-script dialout broadcast
5551313
 dialer-group 1
 ipx network 172253
 snapshot server 5 dialer
 ppp authentication chap
!
router eigrp 25
 redistribute eigrp 27
 redistribute igrp 100
 network 192.168.41.0
 auto-summary
 no eigrp log-neighbor-changes
!
router eigrp 27
 redistribute eigrp 25
 network 172.54.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router igrp 100
 redistribute eigrp 25
 redistribute eigrp 27
 network 172.16.0.0
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
!
!
!
line con 0
 transport input none
line aux 0
 password 7 06000632495C1F
 login
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 password 7 14111B1809163C
 login
line vty 5 15
 login
!
no scheduler allocate
end

Let me know if that works for you.

----- Original Message -----
From: "Jason Gardiner" <gardiner@sprint.net>
To: "Don Dettmore" <don@donshouse.com>
Sent: Monday, May 21, 2001 7:35 AM
Subject: Re: DDR With Back To Back AUX

> I'm not running any dynamic routing protocols on the two routers. I'd
> really appreciate the configs; I've been scratching my head over this
> one ;)
>
>
> Don Dettmore wrote:
> >
> > I have the exact setup between my home lab and work lab. Its perfect
for
> > simulating DDR without having to buy an ISDN simulator.
> >
> > What routing protocol are you using? I have a similar problem when
using
> > ospf demand circuits - the connection comes up more often than it should
> > (though not as often as yours). I haven't debugged this yet.
> >
> > Primarily, though, I use IGRP and snapshot routing - for both IP and
IPX.
> > It works like a charm - just like the books say. I'll send you the
configs
> > if you like.
> >
> > Don Dettmore
> >
> > ----- Original Message -----
> > From: "Jason Gardiner" <gardiner@sprint.net>
> > To: "CCIE" <ccielab@groupstudy.com>
> > Sent: Monday, May 21, 2001 9:53 AM
> > Subject: DDR With Back To Back AUX
> >
> > > Hello,
> > >
> > > Has anyone been able to simulate DDR using back to back AUX
> > > connections? I've been able to establish a permanent connection via
PPP
> > > and have almost got the DIALER part working. The connection drops
after
> > > the dialer idle-timeout limit, but then it brings the connection right
> > > back up.
> > >
> > > I've got the interesting traffic set to icmp only, and according to
> > > debug, no interesting traffic passes or initiates the link. I don't
> > > have the configs with me, but any pointers would be appreciated.
> > >
> > > --
> > > Thanks,
> > >
> > > Jason Gardiner
> > > Engineering Services
> > > Sprint E|Solutions
> > >
> > > "The only thing to prevent what's past is to put a stop to it before
it
> > > happens."
> > > - Sir Boyle Roche
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
> --
> Thanks,
>
> Jason Gardiner
> Engineering Services
> Sprint E|Solutions
>
> "The only thing to prevent what's past is to put a stop to it before it
> happens."
> - Sir Boyle Roche
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:48 GMT-3