RE: ISDN comm problems

From: Chris Mott (cmott@xxxxxxxx)
Date: Mon May 14 2001 - 23:45:41 GMT-3


   
Sorry to mention this, if it is obvious, but a dialer string is not required
on both routers in order for a connection to be made ... the debugs
mentioned are from R5, which has a dialer string ... all in all, this is a
simple configuration ... have you tried to shut off and restart your
simulator? I have a Black Box ISDN simulator that needs a good reboot every
month or so - maybe a memory leak in it's core logic, dunno ... this should
work fine, except the extra dialer map statement on R5 pointing to itself
... remove that and try it again

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Jaiswal, Roby
Sent: Monday, May 14, 2001 7:01 PM
To: 'johnnygwiz'; ccie
Subject: RE: ISDN comm problems

Add dialer string to the command
 dialer map ip 170.100.6.5 name r5 broadcast

         Roby Jaiswal
         CCIE # 6680, CCNP, MCSE
            Franklin Templeton
            Direct: (650) 312 4718
            Pager: (650) 371 1799
            Email: rjaiswa@frk.com <mailto:rjaiswa@frk.com>

-----Original Message-----
From: johnnygwiz [mailto:johnnygwiz@yahoo.com]
Sent: Saturday, May 12, 2001 2:58 PM
To: ccie
Subject: ISDN comm problems

I am having problems connecting 2 routers via ISDN. Here are my configs, my
debugs, and ISDN STAT. I can not ping either interface. Any ideas?

Router 3 configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
enable password cisco
!
username r5 password 0 cisco
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
interface FastEthernet0/0
 ip address 170.100.7.3 255.255.255.0
 no ip directed-broadcast
!
interface BRI0/0
 ip address 170.100.6.3 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 30
 dialer map ip 170.100.6.5 name r5 broadcast
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 ip address 170.100.2.3 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay map ip 170.100.2.2 103
 frame-relay map ip 170.100.2.3 103
 frame-relay map ip 170.100.2.5 103
 frame-relay interface-dlci 103
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 ip address 170.100.8.3 255.255.255.0
 no ip directed-broadcast
!
interface Serial1/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
alias exec br sh ip int brief
alias exec ip sh ip route
alias exec ospf sh ip ospf neigh
alias exec bgp sh ip bgp neigh
alias exec cl clear ip bgp *
alias exec dbgp debug ip bgp ev
alias exec con conf t
alias exec sr sh run
!
line con 0
 exec-timeout 0 0
 password cisco
 transport input none
line aux 0
 password cisco
 login
line vty 0 4
 password cisco
 login

Router 5 configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
enable password cisco
!
username r3 password 0 cisco
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
interface FastEthernet0/0
 ip address 170.100.42.241 255.255.255.240
 no ip directed-broadcast
!
interface BRI0/0
 ip address 170.100.6.5 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 30
 dialer map ip 170.100.6.3 name r3 broadcast 8358663
 dialer map ip 170.100.6.5 name r3 broadcast 8358663
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication chap
 ppp multilink
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/0.1 multipoint
 ip address 170.100.2.5 255.255.255.0
 no ip directed-broadcast
 frame-relay map ip 170.100.2.2 202 broadcast
 frame-relay map ip 170.100.2.3 203 broadcast
 frame-relay map ip 170.100.2.5 203 broadcast
 frame-relay interface-dlci 202
 frame-relay interface-dlci 203
 no frame-relay inverse-arp
!
interface Serial0/0.2 point-to-point
 ip address 170.100.51.5 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 204
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
alias exec br sh ip int brief
alias exec ip sh ip route
alias exec ospf sh ip ospf neigh
alias exec bgp sh ip bgp neigh
alias exec cl clear ip bgp *
alias exec dbgp debug ip bgp ev
alias exec con conf t
alias exec sr sh run
!
line con 0
 exec-timeout 0 0
 password cisco
 transport input none
line aux 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
no scheduler allocate
end
\\

debug information

r5#ping 170.100.6.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 170.100.6.3, timeout is 2 seconds:

00:51:22: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
sending
00:51:22: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
encapsulat
ion failed
00:51:96656425556: ISDN BR0/0: TX -> INFOc sapi = 0 tei = 123 ns = 6 nr
= 6
 i = 0x08010705040288901801832C0738333538363633
00:51:94489280512: SETUP pd = 8 callref = 0x07
00:51:96656425756: Bearer Capability i = 0x8890
00:51:94489280512: Channel ID i = 0x83
00:51:94489280512: Keypad Facility i = '8358663'
00:51:22: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 123 ns = 6 nr = 7 i =
0x08
018702180189952A1B809402603D8307383335383636338E0B2054656C746F6E65203320
00:51:22: CALL_PROC pd = 8 callref = 0x87
00:51:22: Channel ID i = 0x89
00:51:22: Locking Shift to Codeset 5
00:51:22: Codeset 5 IE 0x2A i = 0x809402, '`=', 0x8307, '8358663',
0x8E
0B, ' Teltone 3 '
00:51:96656425372: ISDN BR0/0: TX -> RRr sapi = 0 tei = 123 nr = 7
00:51:22: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 123 ns = 7 nr = 7 i =
0x0.
8018703080282911E028288340104
00:51:22: PROGRESS pd = 8 callref = 0x87
00:51:22: Cause i = 0x8291 - User busy
00:51:22: Progress Ind i = 0x8288 - In-band info or appropriate now
avai
lable
00:51:22: Signal i = 0x04 - Busy tone on
00:51:94489280512: ISDN BR0/0: TX -> RRr sapi = 0 tei = 123 nr = 8
00:51:96636764159: ISDN BR0/0: HOST_PROGRESS: VOICE ERROR 0x3A: bchan 0,
call id
 0x8007
00:51:24: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
sending
00:51:24: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
encapsulat
ion failed.
00:51:111669149696: ISDN BR0/0: TX -> RRp sapi = 0 tei = 124 nr = 0
00:51:26: ISDN BR0/0: RX <- RRf sapi = 0 tei = 124 nr = 0
00:51:26: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
sending
00:51:26: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
encapsulat
ion failed.
00:51:28: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
sending
00:51:28: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
encapsulat
ion failed.
00:51:30: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
sending
00:51:30: IP: s=170.100.6.5 (local), d=170.100.6.3 (BRI0/0), len 100,
encapsulat
ion failed.
Success rate is 0 percent (0/5)

ISDN status

r5#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
        dsl 0, interface ISDN Switchtype = basic-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 123, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
        TEI = 124, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Spid Status:
        TEI 123, ces = 1, state = 8(established)
            spid1 configured, spid1 sent, spid1 valid
            Endpoint ID Info: epsf = 0, usid = 2, tid = 1
        TEI 124, ces = 2, state = 8(established)
            spid2 configured, spid2 sent, spid2 valid
            Endpoint ID Info: epsf = 0, usid = 4, tid = 1
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    Total Allocated ISDN CCBs = 0



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:41 GMT-3