From: Mas Kato (tealp729@xxxxxxxx)
Date: Fri May 11 2001 - 05:48:28 GMT-3
Mohamed,
Does this help?
-R2 and R5 are in confederation AS 2500
-R2 is sourcing the network connecting R2 and R5 together
-R5 is sourcing two loopbacks
-R1 is in AS 100 and dual-homed to R2 and R5
I took one of R5's loopback routes and ran it through a route-map to
modify its attributes as it left the confederation. Every time I did it
on one peer and cleared BGP, R1 would only install one route. As soon as
I did the same thing on the other peer (and cleared BGP), bam--two
routes would install in R1's RT.
Here's how the view ended up from R1:
C 192.168.12.0/24 is directly connected, Serial0/0
C 192.168.15.0/24 is directly connected, Serial0/3
172.16.0.0/24 is subnetted, 2 subnets
B 172.16.25.0 [20/0] via 192.168.15.5, 00:01:40
[20/0] via 192.168.12.2, 00:01:40
B 172.16.5.0 [20/0] via 192.168.15.5, 00:01:40
[20/0] via 192.168.12.2, 00:01:40
10.0.0.0/16 is subnetted, 1 subnets
B 10.5.0.0 [20/555] via 192.168.15.5, 00:01:40
[20/555] via 192.168.12.2, 00:01:40
R1#
R1#sh ip bgp
BGP table version is 75, local router ID is 192.168.41.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.5.0.0/16 192.168.15.5 555 0 2500 5000 i
* 192.168.12.2 555 0 2500 5000 i
*> 172.16.5.0/24 192.168.15.5 0 0 2500 i
* 192.168.12.2 0 2500 i
*> 172.16.25.0/24 192.168.15.5 0 2500 i
* 192.168.12.2 0 0 2500 i
R1#
R1#sh ip bgp 10.5.0.0
BGP routing table entry for 10.5.0.0/16, version 74
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
192.168.12.2
2500 5000
192.168.15.5 from 192.168.15.5 (172.16.5.1)
Origin IGP, metric 555, localpref 100, valid, external, best,
multipath
2500 5000
192.168.12.2 from 192.168.12.2 (192.168.12.2)
Origin IGP, metric 555, localpref 100, valid, external, multipath
R1#
Relevant configs:
hostname R2
!
interface Ethernet0
ip address 172.16.25.2 255.255.255.0
!
interface Serial0
ip address 192.168.12.2 255.255.255.0
!
router bgp 65200
bgp confederation identifier 2500
bgp confederation peers 65200 65500
network 172.16.25.0 mask 255.255.255.0
neighbor 172.16.25.5 remote-as 65500
neighbor 192.168.12.1 remote-as 100
neighbor 192.168.12.1 route-map AS_SPOOF out
no auto-summary
!
access-list 1 permit 10.5.0.0 0.0.255.255
route-map AS_SPOOF permit 10
match ip address 1
set metric 555
set as-path prepend 5000
!
route-map AS_SPOOF permit 20
!
!!!!!!!!!!
hostname R5
!
interface Loopback0
ip address 172.16.5.1 255.255.255.0
!
interface Loopback1
ip address 10.5.5.5 255.255.0.0
!
interface Ethernet0
ip address 172.16.25.5 255.255.255.0
!
interface Serial0
ip address 192.168.15.5 255.255.255.0
!
router bgp 65500
bgp confederation identifier 2500
bgp confederation peers 65200 65500
network 10.5.0.0 mask 255.255.0.0
network 172.16.5.0 mask 255.255.255.0
neighbor 172.16.25.2 remote-as 65200
neighbor 192.168.15.1 remote-as 100
neighbor 192.168.15.1 route-map AS_SPOOF out
no auto-summary
!
access-list 1 permit 10.5.0.0 0.0.255.255
route-map AS_SPOOF permit 10
match ip address 1
set metric 555
set as-path prepend 5000
!
route-map AS_SPOOF permit 20
!
!!!!!!!!!!
hostname R1
!
interface Serial0/0
ip address 192.168.12.1 255.255.255.0
!
interface Serial0/3
ip address 192.168.15.1 255.255.255.0
!
router bgp 100
neighbor 192.168.12.2 remote-as 2500
neighbor 192.168.15.5 remote-as 2500
maximum-paths 2
!
!!!!!!!!!!
Regards,
Mas
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Mohamed Heeba
Sent: Wednesday, May 09, 2001 1:13 PM
To: 'Padhu (LFG)'
Cc: 'ccielab@groupstudy.com'
Subject: RE: BGP maximum paths
guys ;
i already shutdown the prefered interface and the routes showed in the
routing table through the other one .
also i changed the router id to let the non prefered link having lower
IP
address ,and again the router takes lower ip address (this router really
understand BGP :)))
but still it cannot recognize that there is max path defined and BOTH of
the
routes should appear in its routing table ?????
i ll try to clear the route cache ...
> -----Original Message-----
> From: Padhu (LFG) [SMTP:padhu@steinroe.com]
> Sent: Wednesday, May 09, 2001 11:54 AM
> To: 'Mohamed Heeba'
> Subject: RE: BGP maximum paths
>
> did it work ?
>
> -----Original Message-----
> From: Mohamed Heeba [mailto:MAHeeba@itqan.co.ae]
> Sent: Wednesday, May 09, 2001 9:05 AM
> To: 'ccielab@groupstudy.com'
> Subject: BGP maximum paths
>
>
> guys ,
> i have a router R1 in AS 300 ,connecting to another AS 200 thourgh two
> serial connection ,each one going to different routers R2 and R5 (they
are
> in confederation in As 200)
> the requirement is to load balance the traffic across both of the
links.
> i have enabled the maximum paths 2 command on the BGP .
> but still the routes didnt appear in the routing table .
> they are on the bgp table ,showing two paths ,the prefered one is even
the
> one with the lowest ip address .
>
> R1 is running 11.1 , do i need to enable anything else to get the
routes
> in
> the ip route table ???
> here is R1 configs
>
>
> ------------------------------
> interface Loopback0
> ip address 206.11.5.1 255.255.255.0 secondary
> ip address 206.11.6.1 255.255.255.0 secondary
> ip address 206.11.7.1 255.255.255.0 secondary
> ip address 206.11.4.1 255.255.255.0
> no ip mroute-cache
> no ip route-cache
> !
> interface Serial0
> ip address 206.11.20.18 255.255.255.248
> no ip mroute-cache
> no ip route-cache
> bandwidth 64
> !
> interface Serial1
> ip address 206.11.20.66 255.255.255.248
> no ip mroute-cache
> no ip route-cache
> bandwidth 64
> !
> router bgp 300
> network 206.11.4.0
> network 206.11.5.0
> network 206.11.6.0
> network 206.11.7.0
> neighbor 206.11.20.17 remote-as 200
> neighbor 206.11.20.65 remote-as 200
> maximum-paths 2
> no auto-summary
> !
>
>
> r2501#sh ip bgp
> BGP table version is 19, local router ID is 206.11.4.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> * 10.0.0.2/32 206.11.20.65 0 200 i
> *> 206.11.20.17 0 0 200 i
> * 10.0.0.4/32 206.11.20.65 0 200 i
> *> 206.11.20.17 0 200 i
> * 10.0.0.5/32 206.11.20.65 0 0 200 i
> *> 206.11.20.17 0 200 i
> * 10.1.1.0/24 206.11.20.65 0 200 100 i
> *> 206.11.20.17 0 200 100 i
> * 20.1.1.0/24 206.11.20.65 0 200 100 i
> *> 206.11.20.17 0 200 100 i
> * 22.1.1.0/24 206.11.20.65 0 200 100 i
> *> 206.11.20.17 0 200 100 i
> * 24.1.1.0/24 206.11.20.65 0 200 100 i
> *> 206.11.20.17 0 200 100 i
> *> 206.11.4.0 0.0.0.0 0 32768 i
> *> 206.11.5.0 0.0.0.0 0 32768 i
> *> 206.11.6.0 0.0.0.0 0 32768 i
> *> 206.11.7.0 0.0.0.0 0 32768 i
> r2501#
>
>
> r2501#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
candidate
> default
> U - per-user static route
>
> Gateway of last resort is not set
>
> 10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
> B 10.0.0.2/32 [20/0] via 206.11.20.17, 00:14:16
> B 10.1.1.0/24 [20/0] via 206.11.20.17, 00:14:16
> B 10.0.0.4/32 [20/0] via 206.11.20.17, 00:14:17
> B 10.0.0.5/32 [20/0] via 206.11.20.17, 00:14:17
> 20.0.0.0/24 is subnetted, 1 subnets
> B 20.1.1.0 [20/0] via 206.11.20.17, 00:14:17
> 22.0.0.0/24 is subnetted, 1 subnets
> B 22.1.1.0 [20/0] via 206.11.20.17, 00:14:17
> 24.0.0.0/24 is subnetted, 1 subnets
> B 24.1.1.0 [20/0] via 206.11.20.17, 00:14:17
> C 206.11.5.0/24 is directly connected, Loopback0
> C 206.11.4.0/24 is directly connected, Loopback0
> C 206.11.7.0/24 is directly connected, Loopback0
> C 206.11.6.0/24 is directly connected, Loopback0
> 206.11.20.0/29 is subnetted, 2 subnets
> C 206.11.20.64 is directly connected, Serial1
> C 206.11.20.16 is directly connected, Serial0
> r2501#
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:38 GMT-3