authentication cia ripV2 with key-chains

From: Martin, Chris (chris@xxxxxxxxxxxx)
Date: Thu May 10 2001 - 16:22:58 GMT-3


   
Hi Gang:
               Here is a simple one im sure someone out there has been able to
figure out, except me. Configs are posted below for router B and router C i
have key-chains setup on both routers with the SAME password for both using
md5 authentication, yet on debug for router B its telling me that its
receiving invalid authentication type. Anyone have an idea? pelase let me
know, thanks in advance!

Router B

version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ROUTERB
!
!
ip subnet-zero
no ip domain-lookup
ip host A 192.1.1.1
ip host C 10.2.2.1
!
key chain TEST1
 key 1
  key-string chris
  accept-lifetime 12:00:00 May 10 2001 infinite
  send-lifetime 12:00:00 May 10 2001 infinite
!
!
!
interface Ethernet0
 ip address 192.1.1.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 10.2.2.2 255.255.255.0
 no ip directed-broadcast
 ip rip authentication mode md5
 ip rip authentication key-chain TEST1
 clockrate 64000
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router rip
 version 2
 network 10.0.0.0
 network 192.1.1.0
 no auto-summary
!
ip classless
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

ROUTER C

version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ROUTERC
!
enable secret 5 $1$sdZB$DX6HPktjQdbtIONtR61W51
!
!
!
!
!
ip subnet-zero
!
!
key chain TEST
 key 1
  key-string chris
  accept-lifetime 12:00:00 May 10 2001 infinite
  send-lifetime 12:00:00 May 10 2001 infinite
!
!
!
interface Ethernet0
 ip address 192.168.3.1 255.255.255.0
 no keepalive
!
interface Ethernet1
 ip address 192.168.4.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.2.2.1 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain TEST
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.3.0
 network 192.168.4.0
 no auto-summary
!
ip classless
no ip http server
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:38 GMT-3