dialer profiles with callback and ppp pap authentication - working configs

From: Connary, Julie Ann (jconnary@xxxxxxxxx)
Date: Sun May 06 2001 - 11:51:03 GMT-3


   
Hi All,

I know there was some discussion in the last weeks about this - well I got
it to work and here are my configs. The main thing to remember with
dialer profiles is the following:

"When dialer profiles are used to configure DDR, a physical interface has
no configuration settings except encapsulation and the dialer pools the
interface belongs to.

Note The preceding paragraph has one exception: commands that apply before
authentication is complete must be configured on the physical (or BRI or PRI)
interface and not on the dialer profile. Dialer profiles do not copy PPP
authentication commands (or LCP commands) to the physical interface. "

that being said - here are my configs:

urrent configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
username r6 password 0 julie6
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!interface Ethernet0
  ip address 10.2.1.1 255.255.255.0
  no keepalive
!
interface Serial0
  no ip address
  shutdown
!
interface Serial1
  no ip address
  shutdown
!
interface BRI0
  no ip address
  encapsulation ppp
  dialer pool-member 1
  isdn switch-type basic-ni
  ppp callback accept
  ppp authentication pap
  ppp pap sent-username r2 password 7 15181E000D2F79
!interface Dialer1
  ip address 10.62.1.1 255.255.255.0
  encapsulation ppp
  ip ospf demand-circuit
  dialer remote-name r6
  dialer pool 1
  dialer callback-secure
  dialer string 1002 class test
  dialer max-call 4096
  dialer-group 1
  ppp callback accept
  ppp authentication pap
!
router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!
ip classless
no ip http server
!
!
map-class dialer test
  dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
  exec-timeout 0 0
  transport input none
line aux 0
line vty 0 4
!
end

r2#

Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname r6
!
!
username r2 password 7 10441C150C1240
no ip domain-lookup
isdn switch-type basic-ni1
!
interface Ethernet0
  ip address 10.6.1.1 255.255.255.0
  no keepalive
!
interface Serial0
  no ip address
  no ip mroute-cache
  shutdown
!interface Serial1
  no ip address
  shutdown
!
interface BRI0
  no ip address
  encapsulation ppp
  dialer pool-member 1
  ppp callback request
  ppp authentication pap
  ppp pap sent-username r6 password 7 04511E0A06241A
!
interface Dialer1
  ip address 10.62.1.6 255.255.255.0
  encapsulation ppp
  dialer remote-name r2
  dialer string 1001
  dialer pool 1
  dialer-group 1
  no cdp enable
  ppp callback request
  ppp authentication pap
!
  --More--
router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!
no ip classless
no logging console
dialer-list 1 protocol ip permit
!
line con 0
  exec-timeout 0 0
line aux 0
line vty 0

line vty 1 4
!
end

Julie Ann
------------------------------------------------------------------------
                                         Julie Ann Connary
           | | Network Consulting Engineer
          ||| ||| Federal Support Program
        .|||||. .|||||. 13635 Dulles Technology Drive,
Herndon VA 20171
      .:|||||||||:.:|||||||||:. Pager: 1-888-642-0551
     c i s c o S y s t e m s Email: jconnary@cisco.com

------------------------------------------------------------------------
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:35 GMT-3