From: Chia Kim Seng, Consultant, SCSNW-Sales (chiaks@xxxxxxxxxxxxxxxxxxxxxx)
Date: Mon Apr 23 2001 - 23:29:38 GMT-3
RIP works different from IGRP for host routes.
For IGRP, you might need to create a secondary address
for segment between R1(s1)---to----R2(s1) that uses the same major network
and with 32-bit masking.
Regards
Chia Kim Seng
SCS Networks Pte Ltd
7 Bedok South Road
Singapore 469272
Tel : 065-2403164
Fax: 065-2403110
-----Original Message-----
From: Andrzej Kowalczyk [mailto:Andrzej.Kowalczyk@ccs.pl]
Sent: Monday, April 23, 2001 9:45 PM
To: ccielab@groupstudy.com
Subject: RIP and IGRP host routes (/32) problem
Hi All,
I'm working on RIP and IGRP protocols and I got a problem which I can't
solve. I noticed that RIP can send updates for host routes (with mask /32).
I can't force IGRP to do the same. Is it possible to do this in IGRP?
Look at the following situation:
(172.16.101.1/32 - Lo0)R1(S1 - 172.16.12.1/24)<=>(172.16.12.2/24 -
S0)R2(Lo0 - 172.16.102.2/32)
Using RIP:
R1:
interface Loopback0
ip address 172.20.101.1 255.255.255.255
!
interface Serial1
ip address 172.20.12.1 255.255.255.0
clockrate 56000
!
router rip
network 172.20.0.0
!
R1's routing table:
172.20.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.20.12.0/24 is directly connected, Serial1
R 172.20.102.2/32 [120/1] via 172.20.12.2, 00:00:19, Serial1
C 172.20.101.1/32 is directly connected, Loopback0
R2:
interface Loopback0
ip address 172.20.102.2 255.255.255.255
!
interface Serial1
ip address 172.20.12.2 255.255.255.0
clockrate 56000
!
router rip
network 172.20.0.0
!
R2's routing table:
172.20.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.20.12.0/24 is directly connected, Serial0
R 172.20.101.1/32 [120/1] via 172.20.12.1, 00:00:13, Serial0
C 172.20.102.2/32 is directly connected, Loopback0
Using IGRP:
R1:
interface Loopback0
ip address 172.20.101.1 255.255.255.255
!
interface Serial1
ip address 172.20.12.1 255.255.255.0
clockrate 56000
!
router igrp 25
network 172.20.0.0
!
R1's routing table:
172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.20.12.0/24 is directly connected, Serial1
C 172.20.101.1/32 is directly connected, Loopback0
R2:
interface Loopback0
ip address 172.20.102.2 255.255.255.255
!
interface Serial1
ip address 172.20.12.2 255.255.255.0
clockrate 56000
!
router igrp 25
network 172.20.0.0
!
R2's routing table:
172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.20.12.0/24 is directly connected, Serial0
C 172.20.102.2/32 is directly connected, Loopback0
Regards,
Andrzej Kowalczyk
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:54 GMT-3