RE: BGP trick scenario "Not working" Posted Configs

From: Corey M. Ellis (coreye@xxxxxxxxx)
Date: Sun Apr 15 2001 - 12:20:24 GMT-3


   
Hi I am posting the relevant portion of the configs for further information.

### R2 ### AS2 router

interface Serial0
 ip address 172.16.26.2 255.255.255.0
 no fair-queue
 clockrate 2000000
!
interface Serial1
 ip address 11.11.11.2 255.255.255.0
 clockrate 2000000
!
router bgp 2
 neighbor 11.11.11.1 remote-as 1
 neighbor 172.16.26.6 remote-as 1
 no auto-summary

r2#sh ip bgp sum
BGP table version is 4, main routing table version 4

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
11.11.11.1 4 1 693 693 4 0 0 11:30:25 0
172.16.26.6 4 1 699 699 4 0 0 00:44:02 0

### R6 #### AS1 and connects to R2 via EBGP on serial0 (confed 6000)

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
username r5 password 0 ciscoip
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 140.10.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.161.1 255.255.255.252
!
interface Loopback2
 ip address 172.16.161.5 255.255.255.252
!
interface Loopback3
 ip address 172.16.161.9 255.255.255.252
!
interface Loopback4
 ip address 6.6.6.6 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
!
interface Serial0.1 point-to-point
 ip address 172.16.1.6 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 605
!
interface Serial1
 ip address 172.16.26.6 255.255.255.0
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 shutdown
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 3840000001 384000
 isdn spid2 3840000002 384010
 no peer neighbor-route
 ppp authentication chap
!
interface Dialer0
 ip address 172.16.15.6 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name nuthin0
 dialer pool 1
 dialer idle-timeout 30
 dialer watch-disable 10
 dialer string 384020
 dialer string 384030
 dialer max-call 4096
 dialer watch-group 1
 dialer-group 2
 ppp authentication chap
 ppp chap hostname r6ip
 ppp chap password 7 02050D4808090631
!
router ospf 1
 area 2 range 172.16.161.0 255.255.255.224
 network 6.6.6.0 0.0.0.255 area 0
 network 140.10.1.0 0.0.0.255 area 10
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.15.0 0.0.0.255 area 15
 network 172.16.26.0 0.0.0.255 area 26
 network 172.16.161.0 0.0.0.255 area 2
!
router bgp 6000
 bgp confederation identifier 1
 bgp confederation peers 6001
 neighbor 5.5.5.5 remote-as 6000
 neighbor 5.5.5.5 update-source Loopback4
 neighbor 172.16.26.2 remote-as 2
 no auto-summary
!
ip classless
no ip http server
!
access-list 101 deny ospf any any
access-list 101 permit ip any any
dialer watch-list 1 ip 172.16.1.0 255.255.255.0
dialer-list 1 protocol ip list 101
dialer-list 2 protocol ip permit
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
!
end

r6#sh ip bgp summ
BGP router identifier 172.16.161.9, local AS number 6000
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
5.5.5.5 4 6000 47 47 1 0 0 00:44:49 0
172.16.26.2 4 2 48 48 1 0 0 00:45:49 0

#### r5 #### AS1 (confed 6000)

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
username r6ip password 0 ciscoip
username all
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 172.16.1.5 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay map ip 172.16.1.4 504 broadcast
 frame-relay map ip 172.16.1.6 506 broadcast
!
interface Serial0.2 point-to-point
 ip address 172.16.2.5 255.255.255.0
 frame-relay interface-dlci 503
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 shutdown
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 3840200001 384020
 isdn spid2 3840200002 384030
 no peer neighbor-route
 ppp authentication chap
!
interface Dialer0
 ip address 172.16.15.5 255.255.255.0
 encapsulation ppp
 dialer remote-name r6ip
 dialer pool 1
 dialer max-call 4096
 dialer-group 2
 ppp authentication chap
 ppp chap password 7 14141B180F0B
!
router ospf 1
 summary-address 172.16.240.0 255.255.248.0
 redistribute rip subnets
 network 5.5.5.0 0.0.0.255 area 0
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.15.0 0.0.0.255 area 15
!
router rip
 version 1
 redistribute ospf 1 metric 3 match internal external 1 external 2
 passive-interface default
 no passive-interface Serial0.2
 network 172.16.0.0
 default-information originate
 no auto-summary
!
router bgp 6000
 bgp confederation identifier 1
 bgp confederation peers 6001
 neighbor 4.4.4.4 remote-as 6001
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 6.6.6.6 remote-as 6000
 neighbor 6.6.6.6 update-source Loopback0
 no auto-summary
!
ip classless
no ip http server
!
access-list 101 deny ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
dialer-list 2 protocol ip permit
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
!
end

r5#sh ip bgp summ
BGP router identifier 5.5.5.5, local AS number 6000
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
4.4.4.4 4 6001 0 0 0 0 0 never Idle
6.6.6.6 4 6000 49 49 1 0 0 00:46:52 0

#### r4 ###### AS1 (confed 6001)

Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 172.16.144.4 255.255.255.0
!
interface Loopback1
 ip address 172.16.145.4 255.255.255.0
!
interface Loopback2
 ip address 172.16.146.4 255.255.255.0
!
interface Loopback3
 ip address 4.4.4.4 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.1.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 no fair-queue
 frame-relay map ip 172.16.1.5 405 broadcast
 frame-relay map ip 172.16.1.6 405 broadcast
!
interface Serial1
 ip address 172.16.129.4 255.255.252.0
 clockrate 2000000
!
router eigrp 1
 redistribute ospf 1 match internal external 1 external 2
 passive-interface Ethernet0
 passive-interface Serial0
 network 4.4.4.0 0.0.0.255
 network 172.16.0.0
 default-metric 2000 1000 255 1 1500
 no auto-summary
!
router ospf 1
 area 4 range 172.16.144.0 255.255.255.252
 redistribute eigrp 1 metric-type 1 subnets
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.129.4 0.0.0.0 area 3
 network 172.16.144.0 0.0.0.255 area 4
!
router bgp 6001
 bgp confederation identifier 1
 bgp confederation peers 6000
 neighbor 1.1.1.1 remote-as 6001
 neighbor 1.1.1.1 update-source Loopback3
 neighbor 5.5.5.5 remote-as 6000
 neighbor 5.5.5.5 update-source Loopback3
 no auto-summary
!
ip classless
no ip http server
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
!
end

r4#sh ip bgp summ
BGP router identifier 172.16.146.4, local AS number 6001
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
1.1.1.1 4 6001 671 671 1 0 0 11:08:44 0
5.5.5.5 4 6000 0 0 0 0 0 never Idle

##### r1 ##### AS1 connects to AS2 via s1 (confed 6001)

Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
username all
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 172.16.50.26 255.255.255.252
!
interface Loopback1
 ip address 172.16.50.29 255.255.255.252
!
interface Loopback2
 ip address 172.16.50.33 255.255.255.252
!
interface Loopback3
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.129.1 255.255.252.0
 ip summary-address eigrp 1 172.16.50.0 255.255.255.192 5
 no fair-queue
!
interface Serial1
 ip address 11.11.11.1 255.255.255.0
!
router eigrp 1
 network 1.1.1.0 0.0.0.255
 network 172.16.0.0
 no auto-summary
!
router bgp 6001
 bgp confederation identifier 1
 bgp confederation peers 6000
 neighbor 4.4.4.4 remote-as 6001
 neighbor 11.11.11.2 remote-as 2
 no auto-summary
!
ip classless
no ip http server
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
!
end

r1#sh ip bgp summ
BGP router identifier 172.16.50.33, local AS number 6001
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
4.4.4.4 4 6001 673 673 1 0 0 11:10:04 0
11.11.11.2 4 2 699 699 1 0 0 11:36:33 0

##### Here are all the configs, the problem points are r4 and r5 where the
r5 is the hub in a frame cloud of r6<-->r5<-->r4.

Please advise
Corey M. Ellis

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Corey M. Ellis
Sent: Sunday, April 15, 2001 10:48 AM
To: CCIE Mailist
Subject: BGP trick scenario "Not working"

Hi all,

I am trying to do a bgp scenario as follows: I have five routers in the
scenario, four are in AS1 (r6<-->r5<-->r4<-->r1) and AS2 (r2). In AS1 I
have a frame cloud with r5 as a multipoint hub and r6 and r4 as the spokes
all in one network. I also have full routes for all networks via OSPF.

I am trying to configure BGP as follows:
        r6<-->r5 in one confederation 6000
        r4<-->r1 in one confederation 6001

        r6<-->r2 EBGP connection to AS2
        r1<-->r2 EBGP connection to AS2

Problems, all the neighbors are connected except the neighbor connection
between r5<-->r4. This connection should connect the confederations. I
think the reason it won't connect is because r5 is a multipoint interface,
and the fact that all three routers r6,r5,r4 are in the same network. Is
this indeed a problem, or should this connection be working. I had thought
about tunneling this connection, or I am pretty sure point-to-point
interfaces will work, but I did want to change the underlying setup to much.
I am trying to practice confederations, meds, etc. Since r2 has two
connections into AS1. Any ideas as to why my connection between
confederations is not working. I think its due to the multipoint, but I
want to be sure.

Thanks

Corey M. Ellis "(test in 4 days)" Last minute brush ups
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:46 GMT-3