RE: Tunneling ISIS

From: Corey M. Ellis (corey.m.ellis@xxxxxxxx)
Date: Thu Apr 12 2001 - 18:52:44 GMT-3


   
It was a mistake in typing

int lo5 has "ip router isis"

when I do a debug isis adj on r5 I see him sending out to the loopback and
the tunnel interface, but on r1 I only see him sending to the loopback
interface not the tunnel. I am posting configs. Beware they are long.

### R1 ########

Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
ip dvmrp route-limit 20000
clns routing
ipx routing 0001.0001.0001
ipx internal-network 14
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 172.16.50.26 255.255.255.252
!
interface Loopback1
 ip address 172.16.50.29 255.255.255.252
 ipx network 1101
!
interface Loopback2
 ip address 172.16.50.33 255.255.255.252
!
interface Loopback3
 ip address 157.10.1.211 255.255.255.240
!
interface Loopback4
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback5
 ip address 10.2.2.2 255.255.255.0
 ip router isis
!
interface Tunnel1
 ip address 10.0.0.2 255.255.255.0
 ip router isis
 tunnel source 1.1.1.1
 tunnel destination 5.5.5.5
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.65.1 255.255.252.0
 ip pim dense-mode
 ip summary-address eigrp 1 172.16.50.0 255.255.255.0 5
 ipx network 1004
 ipx nlsp enable
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 network 1.1.1.0 0.0.0.255
 network 172.16.50.0 0.0.0.255
 network 172.16.65.0 0.0.0.255
 no auto-summary
!
router isis
 net 49.0001.1111.1111.1111.00
!
router bgp 500
 network 157.10.1.208 mask 255.255.255.240
 neighbor 172.16.65.4 remote-as 100
!
ip classless
no ip http server
!
!
!
!
ipx router nlsp
 area-address 0 0
!
!
no ipx router rip
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
!
end

##### r5 ######

Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
username non-ip password 0 cisco
username backup password 0 cisco
username r6 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
ip dvmrp route-limit 20000
clns routing
ipx routing 0005.0005.0005
isdn switch-type basic-ni
cns event-service server
!
!
!
dlsw local-peer peer-id 5.5.5.5 group 10 border promiscuous
dlsw remote-peer 0 tcp 3.3.3.3
dlsw remote-peer 0 tcp 6.6.6.6
dlsw icanreach netbios-name ALEX
dlsw icanreach netbios-name AVNER
dlsw icanreach netbios-name FRED
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 226.6.6.6
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 ip router isis
!
interface Tunnel0
 no ip address
 ipx network 654
 tunnel source 5.5.5.5
 tunnel destination 6.6.6.6
!
interface Tunnel1
 no ip address
 ipx network 504
 tunnel source 5.5.5.5
 tunnel destination 4.4.4.4
!
interface Tunnel2
 no ip address
 ipx network 5588
 tunnel source 5.5.5.5
 tunnel destination 3.3.3.3
!
interface Tunnel3
 ip address 10.0.0.1 255.255.255.252
 ip router isis
 tunnel source 5.5.5.5
 tunnel destination 1.1.1.1
!
interface Ethernet0
 ip address 172.16.195.5 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.125 multipoint
 ip address 172.16.125.5 255.255.255.0
 ip pim dense-mode
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 frame-relay map clns 103 broadcast
 frame-relay map clns 102 broadcast
 frame-relay map ip 172.16.125.4 103 broadcast
 frame-relay map ip 172.16.125.6 102 broadcast
!
interface Serial0.140 point-to-point
 ip address 172.16.140.5 255.255.255.0
 ip pim dense-mode
 frame-relay interface-dlci 104
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 shutdown
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 3840200001 384020
 isdn spid2 3840200002 384030
 ppp authentication chap
!
interface Dialer0
 description ip dialer interface
 ip address 172.16.15.5 255.255.255.0
 encapsulation ppp
 dialer remote-name backup
 dialer pool 1
 dialer idle-timeout 30
 dialer max-call 4096
 dialer-group 1
 ppp authentication chap
 ppp chap password 7 104D000A0618
!
interface Dialer1
 description ipx dialer interface
 no ip address
 encapsulation ppp
 dialer remote-name non-ip
 dialer pool 1
 dialer idle-timeout 30
 dialer max-call 4096
 dialer-group 2
 ipx network AAA
 snapshot server 5
 ppp authentication chap
 ppp chap password 7 00071A150754
!
router ospf 1
 redistribute rip metric-type 1 subnets
 network 5.5.5.0 0.0.0.255 area 0
 network 172.16.15.0 0.0.0.255 area 0
 network 172.16.125.5 0.0.0.0 area 0
!
router isis
 net 49.0001.5555.5555.5555.00
!
router rip
 version 1
 passive-interface BRI0
 passive-interface Ethernet0
 passive-interface Serial0.125
 network 172.16.0.0
 default-information originate
!
router bgp 100
 no synchronization
 neighbor 172.16.125.6 remote-as 200
 neighbor 172.16.140.8 remote-as 100
 neighbor 172.16.140.8 next-hop-self
!
no ip classless
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ipx permit
!
!
!
!
tftp-server flash:c2500-jos56i-l_121-1.bin
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 login
!
end

Please advise, and sorry about the long post.

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Corey M. Ellis
Sent: Thursday, April 12, 2001 5:24 PM
To: CCIE Mailist
Subject: Tunneling ISIS

Hi,

I am trying to tunnel ISIS through and ospf environment. This is what I have
done. The layout is r1 -- r4 -- r5. r1 -- r4 is EIGRP; r4 -- r5 is OSPF
via frame link. I am doing mutual redistribution, and all routes are seen.
Now I have created a loopback on r1 and a loopback on r5 which are not in
any routing process. I want to create a tunnel between r1 -- r5 and be able
to ping these loopbacks via ISIS.

What I have done

R1

clns routing
router isis
 net 49.0001.1111.1111.1111.00

interface Loopback4
 ip address 1.1.1.1 255.255.255.0

int lo5
 ip addr 10.2.2.2 255.255.255.0

interface Tunnel1
 ip address 10.0.0.2 255.255.255.0
 ip router isis
 tunnel source 1.1.1.1
 tunnel destination 5.5.5.5

R5

clns routing
router isis

interface Loopback0
 ip address 5.5.5.5 255.255.255.0

interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 ip router isis

interface Tunnel3
 ip address 10.0.0.1 255.255.255.252
 ip router isis
 tunnel source 5.5.5.5
 tunnel destination 1.1.1.1

Keep in mind other stuff is in the config, I pulled out the appropriate
info. I expected to see a ISIS route on these routers with the loopback
there. Once I got this working, I was going to try to encrypt the traffic.

Can someone explain the problem, am I missing something.



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:45 GMT-3