From: Darek Kuzma (darekk@xxxxxxxxxxxxx)
Date: Wed Apr 11 2001 - 22:58:24 GMT-3
Horace,
Transform last byte of the RTB's updates to binary:
192.168.20.40 = 192.168.20.00101000
192.168.20.48 = 192.168.20.00110000
then mark /27 mask router RTA will impose:
192.168.20.40 = 192.168.20.001 | 01000
192.168.20.48 = 192.168.20.001 | 10000
And now look at the host portion of the IP address -> its not equal 00000 !
All network updates should have host portion = 0 so RTA will see updates like
host addresses and host mask = /32
That is why you see these entries in the routing table.
Hope it explains,
Darek Kuzma
Horace Chan wrote:
> Hi
>
> In refering to Routing TCP/IP Vol 1 by Jeff,
> I am testing the lab scenario in page 223,
> which consist of two routers.
>
> I originally expect Router B will advertise 2 rip entry:
> 192.168.20.40
> 192.168.20.48
> to Router A. Then, RouterA will imposing 27 bit subnet mask
> as its local interface is configured as 27 bit sbunet mask.
> So, the two route will be truncated to: 192.168.20.32/27
> and will be ignored.
>
> However, the actual lab testing is out of my expectation,
> I find that router A have two rip learned route:
> 192.168.20.0/24 is variably subnetted, 5 subnets, 2 masks
> C 192.168.20.64/27 is directly connected, Loopback30
> R 192.168.20.48/32 [120/1] via 192.168.20.34, 00:00:21, Serial1
> R 192.168.20.40/32 [120/1] via 192.168.20.34, 00:00:21, Serial1
> C 192.168.20.32/27 is directly connected, Serial1
> C 192.168.20.128/27 is directly connected, Loopback20
>
> I really don't understand why RouterA will have the 2 32bit route. Can
> anyone help?
>
> I've tried to open the debug of:
> ip rip
> ip rip database
> and get the following intesting message are as follow.
> My friend also follow the lab config and get the same result. Is there
> anything that we are missing?
>
> =======================================================================
> 00:30:24: RIP: received v1 request from 192.168.20.34 on Serial1
> 0
> 00:30:24: RIP: sending v1 update to 192.168.20.34 via Serial1
> (192.168.20.33) 0
> 00:30:24: RIP: build update entries
> 0
> 00:30:24: subnet 192.168.20.64 metric 1
> 0
> 00:30:24: subnet 192.168.20.128 metric 1
> 0
> 00:30:24: RIP: received v1 update from 192.168.20.34 on Serial1
> 0
> 00:30:24: 192.168.20.40 in 1 hops
> 0
> 00:30:24: RIP-DB: network_update with 192.168.20.40/24 succeeds
> 0
> 00:30:24: RIP-DB: adding 192.168.20.40/0 (metric 1) via 192.168.20.34 on
> Serial1
> to RIP database
> 0
> 00:30:24: RIP-DB: add 192.168.20.40/32 (metric 1) via 192.168.20.34 on
> Serial1 0
> 00:30:24: 192.168.20.48 in 1 hops
> 0
> 00:30:24: RIP-DB: network_update with 192.168.20.48/24 succeeds
> 0
> 00:30:24: RIP-DB: adding 192.168.20.48/0 (metric 1) via 192.168.20.34 on
> Serial1
> to RIP database
> 0
> 00:30:24: RIP-DB: add 192.168.20.48/32 (metric 1) via 192.168.20.34 on
> Serial1 0
> 00:30:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed
> stat
> ============================================================================
> =
>
> Router A config:
> ===========================
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname ra
> !
> boot system flash
> logging buffered 65535 debugging
> !
> !
> !
> !
> !
> memory-size iomem 25
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> process-max-time 200
> !
> interface Loopback20
> ip address 192.168.20.129 255.255.255.224
> no ip directed-broadcast
> !
> interface Loopback30
> ip address 192.168.20.65 255.255.255.224
> no ip directed-broadcast
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> !
> interface Serial1
> ip address 192.168.20.33 255.255.255.224
> no ip directed-broadcast
> !
> interface Serial2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface FastEthernet0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router rip
> passive-interface Loopback20
> passive-interface Loopback30
> network 192.168.20.0
> !
> ip classless
> no ip http server
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> !
> !
> no scheduler allocate
> end
>
> ===================
>
> Router B Cofnig
> =========================
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname rb
> !
> !
> !
> !
> !
> !
> memory-size iomem 15
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> interface Loopback20
> ip address 192.168.20.49 255.255.255.248
> no ip directed-broadcast
> !
> interface Loopback30
> ip address 192.168.20.41 255.255.255.248
> no ip directed-broadcast
> !
> interface Serial0
> description S0 to RouterB
> ip address 192.168.20.34 255.255.255.248
> no ip directed-broadcast
> no ip mroute-cache
> clockrate 64000
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface FastEthernet0
> no ip address
> no ip directed-broadcast
> shutdown
> half-duplex
> !
> router rip
> passive-interface Loopback20
> passive-interface Loopback30
> network 192.168.20.0
> !
> ip classless
> no ip http server
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:44 GMT-3