RE: ISDN Backup link and OSPF neighbor formation

From: Virnoche, Phil (phil.virnoche@xxxxxxxxx)
Date: Sun Mar 04 2001 - 18:38:56 GMT-3


   
OOPS: here are relevant configs....

r1:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
username r2 password 0 itsme
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
isdn switch-type basic-5ess
!
!
!
interface Ethernet0
 ip address 172.17.59.49 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 bandwidth 64
 ip address 172.17.59.17 255.255.255.240
 no ip directed-broadcast
 encapsulation frame-relay IETF
 ip ospf network point-to-multipoint
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no fair-queue
 clockrate 2000000
 frame-relay map ip 172.17.59.18 101 broadcast
 frame-relay map ip 172.17.59.19 102 broadcast
 frame-relay lmi-type cisco
!
interface Serial1
 bandwidth 64
 ip address 172.17.59.66 255.255.255.240
 no ip directed-broadcast
!
interface BRI0
 ip address 172.17.59.34 255.255.255.240
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
router ospf 1
 network 172.17.59.17 0.0.0.0 area 0
 network 172.17.59.34 0.0.0.0 area 0
!
ip classless
!
dialer-list 1 protocol ip permit
alias configure a access-list
alias exec ii sh ip int
alias exec ib sh ip int brief
alias exec ir sh ip route
alias exec xi sh ipx int
alias exec xb sh ipx int brief
alias exec xr sh ipx route
alias exec pr sh ip protocol
alias exec cr clear ip route
alias exec cb clear ip bgp
alias exec b sh ip bgp
alias exec e sh ip eigrp
alias exec o sh ip ospf
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password radar
 login
!
end

r2:

version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
boot system flash c1600-sy-l_121-1.bin
!
username r1 password 0 itsme
!
!
!
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
!
interface Ethernet0
 ip address 172.17.59.129 255.255.255.252
!
interface Serial0
 bandwidth 64
 no ip address
 encapsulation frame-relay IETF
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2000000
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 bandwidth 64
 backup delay 5 10
 backup interface BRI0
 ip address 172.17.59.18 255.255.255.240
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 100
!
interface BRI0
 ip address 172.17.59.33 255.255.255.240
 encapsulation ppp
 ip ospf demand-circuit
 dialer map ip 172.17.59.34 name r1 5551000
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
router ospf 1
 network 172.17.59.18 0.0.0.0 area 0
 network 172.17.59.33 0.0.0.0 area 0
 network 172.17.59.129 0.0.0.0 area 1
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
alias configure a access-list
alias exec ii sh ip int
alias exec ib sh ip int brief
alias exec ir sh ip route
alias exec xi sh ipx int
alias exec xb sh ipx int brief
alias exec xr sh ipx route
alias exec pr sh ip protocol
alias exec cr clear ip route
alias exec cb clear ip bgp
alias exec b sh ip bgp
alias exec e sh ip eigrp
alias exec o sh ip ospf
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 transport input none
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password radar
 login
!
end

-----Original Message-----
From: Virnoche, Phil
Sent: Sunday, March 04, 2001 1:36 PM
To: ccielab@groupstudy.com
Subject: ISDN Backup link and OSPF neighbor formation
Importance: High

Scratching my head on this one,.... (Reference SE Pracrice Lab V1.0GG) the
one with routers named Sleepy, Grumpy....etc.

Here is my dilemna: Sleepy (r2) has parallel links (FR and ISDN DDR) to
Grumpy (r1) ALL interfaces are defined in OSPF area 0. BRI0 on Sleepy is
configured to backup Ser0 in case of link failure. I have that part
functioning.... I shut down the FR intf and the BRI kicks into action.

What is NOT happening is OSPF routing info exchange across the Backup link.
Sh ip ospf nei goes to INIT.... and never gets to full. What am i
missing?????

Thanks in advance!!!

phil



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:20 GMT-3