From: Chuck Larrieu (chuck@xxxxxxxxxxxxx)
Date: Sun Mar 04 2001 - 14:21:58 GMT-3
Unfortunately, there seems to be no "debug route-map" command, so....
Debug access-list xx
Or, depending upon what the route map is supposed to accomplish, check the
results of any number of show commands.
For example, if the route map is used in redistribution, and supplies
metrics, then check the values of the sh ip route command.
If it is used in BGP to change weights, of meds, or AS path, etc, then use
the sh ip bgp command on the particular router, the neighboring router, etc.
If your route-map is used for policy routing then debug ip policy
I usually try to write down a prediction about what I expect to see, and
then use the various commands to verify that prediction. Not that I want to
hand calculate EIGRP metrics, but I try to get a feel for what I should be
seeing, then check what I really do see.
Extended ping, especially with the record route option, is a good tool.
Without it I would have never discovered that ping apparently cannot be
policy routed. Therefore ping is not a good way to test policy routing,
while trace is.
The IOS offers a wealth of tools for checking things. Often one must use a
combination of those tools in a couple of different places to get the whole
picture.
HTH
Chuck
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Steven Weber
Sent: Tuesday, February 27, 2001 12:00 AM
To: CCIELab@groupstudy.com; Elias Hill
Subject: RE: route filterrs
so how do I know if my route map is doing its job?
----- Original Message -----
From: Elias Hill
To: CCIELab@groupstudy.com ;Steven Weber
Sent: 2/27/01 1:00:50 AM
Subject: RE: route filters
Let me know if I am incorrect... the "0 matches" refers to policy
routing
applications, not route-maps applied to distribution/redistribution.
-----Original Message-----
From: Steven Weber [mailto:itweber@earthlink.net ]
Sent: Monday, February 26, 2001 9:32 PM
To: CCIE GROUP
Subject: route filters
I am trying to filter a route from being inserted as well as
changing the metric on the other routes enclosed is a sh run. I'm trying to
filter 2.1.1.1 but not 2.2.1.1 and change its metric along with
200.200.200.1 to
5 but the show route-map comes up with 0 matches, what am I doing
wrong?
Regards,
--- Steven Weber
--- EarthLink: It's your Internet.
hostname r4
!
!
no ip domain-lookup
!
interface
Loopback0
ip address 10.44.1.1 255.255.0.0
no logging event
subif-link-status
!
interface Loopback1
ip address 200.200.200.1
255.255.255.0
no logging event subif-link-status
!
interface
Ethernet0
ip address 10.4.1.1 255.255.0.0
no logging event
subif-link-status
no keepalive
!
interface Serial0
ip
address 10.34.1.2 255.255.0.0
no logging event
subif-link-status
!
interface Serial1
no ip address
no
logging event subif-link-status
shutdown
!
interface
BRI0
no ip address
no logging event
subif-link-status
shutdown
!
router ospf 1
network
10.34.0.0 0.0.255.255 area 3
network 10.4.0.0 0.0.255.255 area
3
network 10.44.0.0 0.0.255.255 area 3
area 3
stub
!
router rip
network 200.200.200.0
!
router bgp
1
no synchronization
network 10.44.1.1 mask
255.255.255.255
redistribute static
redistribute
rip
neighbor 10.33.1.33 remote-as 2
neighbor 10.33.1.33
ebgp-multihop 2
neighbor 10.33.1.33 update-source
Loopback0
neighbor 10.33.1.33 route-map FILTER out
no
auto-summary
!
no ip classless
ip route 2.1.1.0 255.255.255.0
Null0
ip route 2.2.1.0 255.255.255.0 Null0
access-list 1 permit 0.0.0.0
255.255.255.0
route-map FILTER permit 10
match ip address
1
set metric 5
!
route-map FILTER deny
20
!
!
line con
0
exec-timeout 0
0
r4#sh
rout
route-map FILTER, permit, sequence 10
Match
clauses:
ip address (access-lists): 1
Set
clauses:
metric 5
Policy routing matches: 0
packets, 0 bytes
route-map FILTER, deny, sequence 20
Match
clauses:
Set clauses:
Policy routing matches: 0 packets, 0
bytes
r4#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
D - EIGRP, EX - EIGRP
external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF
external type 1, E2 - OSPF external type 2, E -
EGP
i - IS-IS, L1 - IS-IS level-1, L2 -
IS-IS level-2, * - candidate default
U -
per-user static route, o - ODR
Gateway of last resort is 10.34.1.1 to network 0.0.0.0
2.0.0.0/24 is subnetted, 2
subnets
S 2.2.1.0 is directly connected,
Null0
S 2.1.1.0 is directly connected,
Null0
10.0.0.0/16 is subnetted, 3
subnets
C 10.4.0.0 is directly connected,
Ethernet0
C 10.44.0.0 is directly
connected, Loopback0
C 10.34.0.0 is
directly connected, Serial0
B 22.0.0.0/8 [20/0] via
10.33.1.33, 01:28:12
C 200.200.200.0/24 is directly
connected, Loopback1
O*IA 0.0.0.0/0 [110/65] via 10.34.1.1, 01:28:18,
Serial0
r4#
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:19 GMT-3