From: Mitch Tsai (mtcisco@xxxxxxxxx)
Date: Sun Mar 04 2001 - 01:31:24 GMT-3
I think ip opsf authentication is used to authenticate
neighbor on a point to point circuit. Below is a
sample of how simple and md5 authentication is done.
http://www.cisco.com/warp/public/104/2.html#6.0
interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf authentication-key mypassword
router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication
interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf message-digest-key 10 md5 mypassword
router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication message-digest
--- Steven Weber <itweber@earthlink.net> wrote:
>
> what I've come to notice is that their isn't any ip
> ospf authentication
> command only an authentication-key command. they do
> the same thing but when you
> are using md5 you have to enter a key as well but
> for simple authentication you
> just have to enter a password.
>
> Someone please correct me if I'm wrong.
>
> Hope this helps,
>
> Steve
>
>
> ----- Original Message -----
>
> From: tok cok
>
> To: ccielab@groupstudy.com
>
> Sent: 3/3/01 9:46:28 PM
>
> Subject: OSPF authenication
>
>
>
>
>
> Hi guys,
>
>
>
> I was doing a simple OSPF authentication for an
> area.
>
> I came across the an interface command 'ip ospf
> authentication'.
>
> When do we use this command?
>
>
>
> Below is what I had configure for the two router.
>
>
>
> ROUTER A
>
>
>
> interface Ethernet0
>
> ip address 11.1.1.6 255.255.0.0
>
> no ip directed-broadcast
>
> ip ospf authentication-key cisco
>
> !
>
> router ospf 1
>
> area 4 authentication
>
> network 11.1.0.0 0.0.255.255 area 4
>
>
>
> ROUTER B
>
>
>
> interface Ethernet0
>
> ip address 11.1.1.5 255.255.0.0
>
> no ip directed-broadcast
>
> ip ospf authentication-key cisco
>
> !
>
> router ospf 1
>
> area 4 authentication
>
> network 11.1.0.0 0.0.255.255 area 4
>
>
>
> I'm only configuring simple authentication. Do I
> still need to
> configure
>
> 'ip ospf authentication' after I had configure 'ip
> ospf
> authentication-key'?
>
>
>
> Really appriciate if someone could enlighten me!
>
>
>
> Cheers
>
>
>
>
>
>
>
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:19 GMT-3