RE: IP OSPF neigh in INIT/DROTHER state

From: Erick B. (erickbe@xxxxxxxxx)
Date: Mon Feb 26 2001 - 19:36:28 GMT-3


   
On r2 the OSPF traffic is getting NAT'd. This is most
likely causing the problem (I've had it happen to me).
Make the OSPF traffic un-interesting in the NAT ACL
and make the nat pool a different IP if possible.

--- Fabricio Aponte <fabricio@ev1.net> wrote:
> Here is the configs for R2 and R5. Dennis, I am not
> using Vlans. There is
> no switch involved. Thank you. fabricio
>
>
> hostname r5
> !
> enable password removed
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> interface Loopback0
> ip address 172.168.91.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Loopback1
> ip address 172.168.89.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet0
> ip address 216.12.210.81 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> encapsulation frame-relay
> no ip mroute-cache
> logging event subif-link-status
> logging event dlci-status-change
> !
> interface Serial0.1 multipoint
> ip address 172.168.100.5 255.255.255.0
> no ip directed-broadcast
> no ip split-horizon
> ip ospf priority 100
> frame-relay map ip 172.168.100.3 501
> frame-relay map ip 172.168.100.6 506
> !
> interface Serial0.2 multipoint
> ip address 172.168.200.1 255.255.255.0
> no ip directed-broadcast
> frame-relay map ip 172.168.200.2 504 broadcast
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface BRI0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router ospf 99
> area 10 virtual-link 172.168.90.1
> area 10 virtual-link 172.168.30.97
> redistribute igrp 99 subnets
> network 172.168.61.0 0.0.0.255 area 0
> network 172.168.89.0 0.0.0.255 area 0
> network 172.168.100.0 0.0.0.255 area 10
> network 216.12.210.0 0.0.0.255 area 0
> neighbor 172.168.100.3
> neighbor 172.168.100.6
> !
> router igrp 99
> passive-interface Serial0.1
> network 172.168.0.0
> !
> ip classless
> !
> alias exec i show ip route
> alias exec ci clear ip route *
> alias exec r show run
> alias exec ib show ip int brief
> !
> line con 0
> logging synchronous
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
>
>
> hostname r2
> !
> enable secret 5 removed
> !
> username yomama password 0 yomama
> !
> !
> !
> !
> ip subnet-zero
> no ip finger
> ip host r8 2008 100.100.100.1
> ip host r7 2007 100.100.100.1
> ip host r6 2006 100.100.100.1
> ip host r5 2005 100.100.100.1
> ip host r4 2004 100.100.100.1
> ip host r3 2003 100.100.100.1
> ip host r2 2002 100.100.100.1
> ip host r1 2001 100.100.100.1
> ip name-server 216.88.76.6
> !
> !
> !
> process-max-time 200
> !
> interface Loopback100
> ip address 100.100.100.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet0
> ip address 216.12.210.82 255.255.255.0
> no ip directed-broadcast
> ip nat outside
> !
> interface Serial0
> ip address 192.168.21.1 255.255.255.0
> no ip directed-broadcast
> ip nat inside
> clockrate 2000000
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router eigrp 99
> network 192.168.21.0
> !
> router ospf 99
> network 216.12.210.0 0.0.0.255 area 0
> !
> ip nat inside source list 1 interface Ethernet0
> overload
> ip classless
> ip route 0.0.0.0 0.0.0.0 216.12.210.1
> no ip http server
> !
> access-list 1 permit any
> !
> line con 0
> transport input none
> line 1 8
> no exec
> transport input all
> line 9 16
> line aux 0
> line vty 0 4
> password removed
> login local
> !
> end
>
> r2#
>
> -----Original Message-----
> From: Halaska, David
> [mailto:David.Halaska@getronics.com]
> Sent: Monday, February 26, 2001 2:53 PM
> To: 'Fabricio Aponte'; ccielab@groupstudy.com
> Subject: RE: IP OSPF neigh in INIT/DROTHER state
>
>
> hmmmmmm. you could set one to not be the DR by
> changing using the interface
> command
> ip ospf priority x
> 0 means do not become dr or bdr. you could also
> just make one higher than
> the other. Be sure to shut no shut the interfaces
> to start a new election.
> Try bringing the DR up first. I can't tell what the
> specific problem is
> based on the info provided but this workaround
> should help. Maybe you could
> send the configs.
>
> Hope this helps,
> David
>
> -----Original Message-----
> From: Fabricio Aponte [mailto:fabricio@ev1.net]
> Sent: Monday, February 26, 2001 2:30 PM
> To: ccielab@groupstudy.com
> Subject: IP OSPF neigh in INIT/DROTHER state
>
>
> I got two routers connected to each other via an
> ethernet hub. R2 and R5.
> This is the show ip ospf neigh on r 2 and show ip
> ospf int e 0 on both
> routers. Both routers are electing each other as
> the DR and no BDR (they do
> not see each other).
>
> Why are these two guys not electing a DR?
> Why is R5 not even seeing R2 as a neighbor?
>
> r2#show ip ospf neigh
>
> Neighbor ID Pri State Dead Time
> Address Interface
> 172.168.91.1 1 INIT/DROTHER 00:00:30
> 216.12.210.81 Ethernet0
>
>
> r2#show ip ospf int e 0
> Ethernet0 is up, line protocol is up
> Internet Address 216.12.210.82/24, Area 0
> Process ID 99, Router ID 100.100.100.1, Network
> Type BROADCAST, Cost: 10
> Transmit Delay is 1 sec, State DR, Priority 1
> Designated Router (ID) 100.100.100.1, Interface
> address 216.12.210.82
> No backup designated router on this network
> Timer intervals configured, Hello 10, Dead 40,
> Wait 40, Retransmit 5
> Hello due in 00:00:04
> Index 1/1, flood queue length 0
> Next 0x0(0)/0x0(0)
> Last flood scan length is 0, maximum is 0
> Last flood scan time is 0 msec, maximum is 0 msec
> Neighbor Count is 1, Adjacent neighbor count is 0
> Suppress hello for 0 neighbor(s)
> r2#
> [Resuming connection 5 to r5 ... ]
>
> r5#show ip ospf int e 0
> Ethernet0 is up, line protocol is up
> Internet Address 216.12.210.81/24, Area 0
> Process ID 99, Router ID 172.168.91.1, Network
> Type BROADCAST, Cost: 10
> Transmit Delay is 1 sec, State DR, Priority 1
> Designated Router (ID) 172.168.91.1, Interface
> address 216.12.210.81
> No backup designated router on this network
> Timer intervals configured, Hello 10, Dead 40,
> Wait 40, Retransmit 5
> Hello due in 00:00:09
> Neighbor Count is 0, Adjacent neighbor count is 0
> Suppress hello for 0 neighbor(s)
>
> Thank you,
>
>
> fabricio
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:04 GMT-3