RE: 2 Questions 1 BGP, 1 DLSW backups

From: Ali, Shahzad (Shahzad.Ali@xxxxxx)
Date: Thu Feb 01 2001 - 18:19:19 GMT-3


   
Roy,

You can use filter-list and route-map with as-path.
Here is the route-map example.

r1 ----ibgp 100 ---- r2 --------ebgp 200-------r3

r1
!
!
interface Serial0
 ip address 11.1.1.1 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
router bgp 100
 no synchronization
 neighbor 11.1.1.2 remote-as 100
!
r1#sh ip bgp

   Network Next Hop Metric LocPrf Weight Path
*>i1.0.0.0 10.1.1.2 0 100 0 I
!

r2
!
!interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 ip address 11.1.1.2 255.255.255.0
!
interface Serial0/1
 ip address 10.1.1.2 255.255.255.0
!
router bgp 100
 no synchronization
 network 1.0.0.0
 neighbor 10.1.1.3 remote-as 200
 neighbor 11.1.1.1 remote-as 100
 neighbor 11.1.1.1 next-hop-self
 neighbor 11.1.1.1 route-map as200 out
!
ip as-path access-list 1 deny _200$
ip as-path access-list 1 permit .*
!
route-map as200 permit 10
 match as-path 1
!

r2#sh ip bgp

   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768 i
*> 192.168.1.0 10.1.1.3 0 0 200 i
*> 192.168.2.0 10.1.1.3 0 0 200 i

!

r3
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 ip address 11.1.1.3 255.255.255.0
clo 64000
!
router bgp 200
 no synchronization
 network 192.168.1.0
 network 192.168.2.0
 neighbor 10.1.1.2 remote-as 100
!

r3#sh ip bgp

   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.1.2 0 0 100 i
*> 192.168.1.0 0.0.0.0 0 32768 i
*> 192.168.2.0 0.0.0.0 0 32768 i

Regards,

ShahzaD

-----Original Message-----
From: Roy Grego [mailto:ccsi100@yahoo.com]
Sent: Thursday, February 01, 2001 12:10 AM
To: ccielab@groupstudy.com
Subject: 2 Questions 1 BGP, 1 DLSW backups

Hi Guys,

1) DLSW with a linger option on a remote peer. It
always stays up. Even though I have it set for 5
minutes. I've even tried 1 minute.

ex. dlsw remote-peer 0 tcp 161.1.2.2 backup-peer
161.1.6.6 linger 5

Sh dlsw peers
 TCP 161.1.6.6 CONNECT 140 140
conf 0 0 0 01:07:16
 TCP 161.1.2.2 CONNECT 121 121
conf 0 0 0 01:01:00

2) BGP filtering from
 R1 (Network command) -- iBGP-- R2 --- EBGP -- R3

Filter the route you injected in R1 from R3 not by IP.

I was thinking TAG but on R2 it doesn't let you match
OUT based on a tag or Metric. When I tried route-type
internal it did work (well it blocked all the internal
routes).

So I thought trying a community. I am not sure if I
configured the Network command properly to add a
community to that route.

on R1
int loopback, ip addr 10.8.1.1 255.255.255.255

router BGP 10
 neighbor R2 send-community
 network 10.8.1.1 mask 255.255.255.255 route-map TAG2

route-map TAG2 p 10
 set comm 1 no-export <-- Prevents from going to
other AS

Thanks,
ROY



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:28:33 GMT-3