RE: Off Topic - Weird OSPF issue with 4006 platform.

From: Mike Schlenger (mschlenger@xxxxxxxxxxxxxxxx)
Date: Tue Jan 30 2001 - 17:16:14 GMT-3


   
I had a similar issue with EIGRP on a 4006 at a customer site (with the L3
module). To resolve the issue, I had to change the native vlan back to 1.
Try it out if the network is broken. Here is my L3 config.

hostname CAT4K-LISLE-R1
!
enable secret 5 $1$xSW7$7tubGvx4ZubPlB5mEb0zI1
!
clock timezone CDT -6
clock calendar-valid
ip subnet-zero
no ip domain-lookup
!
!
!
interface Port-channel1
 no ip address
 no ip redirects
 ip directed-broadcast
 hold-queue 300 in
!
interface Port-channel1.1
encapsulation dot1Q 1 native
no ip directed-broadcast
!
interface Port-channel1.100
 encapsulation dot1Q 100
 ip address 172.20.1.254 255.255.255.0
 no ip redirects
 ip directed-broadcast
 ip summary-address eigrp 1 172.20.0.0 255.255.252.0
!
interface Port-channel1.200
 encapsulation dot1Q 200
 ip address 172.20.2.254 255.255.255.0
 ip helper-address 172.20.1.22
 no ip redirects
 ip directed-broadcast
!
interface Port-channel1.300
 encapsulation dot1Q 300
 ip address 172.20.3.254 255.255.255.0
 ip helper-address 172.20.1.22
 no ip redirects
 ip directed-broadcast
!
interface FastEthernet1
 no ip address
 no ip directed-broadcast
!
interface GigabitEthernet1
 no ip address
 no ip directed-broadcast
!
interface GigabitEthernet2
 no ip address
 no ip directed-broadcast
!
interface GigabitEthernet3
 no ip address
 no ip directed-broadcast
 no negotiation auto
 channel-group 1
!
interface GigabitEthernet4
 no ip address
 no ip directed-broadcast
 no negotiation auto
 channel-group 1
!
router eigrp 1
 redistribute static
 passive-interface FastEthernet1
 network 172.20.0.0
 default-metric 64 200 255 1 1500
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.1.1
!

Regards
Mike Schlenger

-----Original Message-----
From: Cal Michael [mailto:cmichael@network-data.com]
Sent: Tuesday, January 30, 2001 2:13 PM
To: ccielab@groupstudy.com
Subject: Off Topic - Weird OSPF issue with 4006 platform.

- Yeah, this probably belongs in alt.cisco, but when TAC is being
  slow. . .

- Issue: Have two 4006's each equipped with the SupII, L3 module,
         4604 Access Gateway, 6 port Gig modules, and loaded with
         the latest in IOS technology.

         The SupII is in module 1, the Access Gateway (AG) is in 5,
         the L3 module in 6. The SupII's two GE ports connect as
         a trunk, two VLAN's (including the native VLAN of 64) to
         the other 4006. The 4006's treat the SupII ports as L2
         ports. The L3's two GE ports are connected together like
         the SUPII's. However, since the Catayst portion of this
         switch is ignorant of these ports existence, the L3 module
         treats them like two physical GE ports.

         OSPF works like a champ. No fancy configuration, just
         announcing a network block like it should. Tied to a
         loopback. Adjacencies form without issue for all VLAN's
         (about 12) and in between the 4006 on the L3 segments.
         Since this is with the network core - only Area 0 is
         configured. DR's, BDR's all good. Life is good.

         Now introduce the AG's to the mix. OSPF weirds out.
         The AG has a "GE" port to the backplane. This virtual
         GE port is set up to belong to VLAN 64. Adjacencies
         form between the AG's and the L3's, between the AG's,
         and between the L3's in both 4006's. All except one
         segment. And yes, it's random which one will get
         stuck in 2-way, DROTHER. But always, only one link -
         in native VLAN 64 (the AG actually is ignorant of this,
         but the Cat L2 portion isn't). It could be between an
         AG and the remote L3, it has been between L3 to L3 on
         VLAN 64 only (other VLAN's form adjacencies fine).
         No rhyme, no reason. You can reset a module, and the
         problem goes away until the blade reloads and begins
         to form adjacencies again and a single segment becomes
         affected again. There is full connectivity on the
         segment, the other side pings fine. No filters are
         present. The network still hums along, just one
         segment will not form up. . .

         Pull the AG's, and the issue goes away. . .

         There is little documentation of these AG modules.
         One confidential FAQ mentions that the gateways "only
         support two route paths". This seems interpretable
         in many ways - even has Cisco stumped. . .

- Snipped from show ip ospf neighbor. Vlan 64 is a port channel
  ending in 64, and addresses with 64 as the third octet are the
  IP subnet associated with it.

4006-CC1-L3#show ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface
10.254.254.252 1 FULL/DR 00:00:33 172.20.95.2
GigabitEthernet1
10.254.254.252 1 FULL/DR 00:00:33 172.20.95.6
GigabitEthernet2
172.20.64.6 1 FULL/BDR 00:00:35 172.20.64.6
Port-channel1.64
172.20.64.7 1 FULL/DR 00:00:36 172.20.64.7
Port-channel1.64
10.254.254.252 1 2WAY/DROTHER 00:00:33 172.20.64.3
Port-channel1.64
10.254.254.252 1 FULL/DR 00:00:33 172.20.65.3
Port-channel1.65
172.20.67.5 1 FULL/DR 00:00:33 172.20.67.5
Port-channel1.67
10.254.254.252 1 FULL/BDR 00:00:33 172.20.67.3
Port-channel1.67
10.254.254.252 1 FULL/DR 00:00:33 172.20.68.3
Port-channel1.68
10.254.254.252 1 FULL/DR 00:00:33 172.20.69.3
Port-channel1.69
10.254.254.252 1 FULL/DR 00:00:33 172.20.70.3
Port-channel1.70
10.254.254.252 1 FULL/DR 00:00:32 172.20.72.3
Port-channel1.72
10.254.254.252 1 FULL/DR 00:00:32 172.20.73.3
Port-channel1.73
10.254.254.252 1 FULL/DR 00:00:32 172.20.161.3
Port-channel1.177
4006-CC1-L3#

Neighbor ID Pri State Dead Time Address Interface
10.250.250.253 1 FULL/BDR 00:00:34 172.20.95.1
GigabitEthernet1
10.250.250.253 1 FULL/BDR 00:00:34 172.20.95.5
GigabitEthernet2
172.20.64.6 1 FULL/BDR 00:00:36 172.20.64.6
Port-channel1.64
10.250.250.253 1 2WAY/DROTHER 00:00:34 172.20.64.2
Port-channel1.64
172.20.64.7 1 FULL/DR 00:00:37 172.20.64.7
Port-channel1.64
10.250.250.253 1 FULL/BDR 00:00:34 172.20.65.2
Port-channel1.65
172.20.67.5 1 FULL/DR 00:00:32 172.20.67.5
Port-channel1.67
10.250.250.253 1 FULL/DROTHER 00:00:34 172.20.67.2
Port-channel1.67
10.250.250.253 1 FULL/BDR 00:00:34 172.20.68.2
Port-channel1.68
10.250.250.253 1 FULL/BDR 00:00:34 172.20.69.2
Port-channel1.69
10.250.250.253 1 FULL/BDR 00:00:34 172.20.70.2
Port-channel1.70
10.250.250.253 1 FULL/BDR 00:00:34 172.20.72.2
Port-channel1.72
10.250.250.253 1 FULL/BDR 00:00:34 172.20.73.2
Port-channel1.73
10.250.250.253 1 FULL/BDR 00:00:34 172.20.161.2
Port-channel1.177
4006-CC2-L3#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:49 GMT-3