From: Kevin Baumgartner (kbaumgar@xxxxxxxxx)
Date: Mon Jan 29 2001 - 19:24:45 GMT-3
If you prevent the ISDN network from getting redistributed back into OSPF
from EIGRP the
dial line won't dial. (assuming there is not some non OSPF that now generates
the call)
So something like this
Router ospf 1
network 192.168.0.0 0.0.255.255 area 0
redistribute eigrp 1 route-map deny-ISDN-network
default-metric 1
!
route-map deny-ISDN-network deny 10
match ip address 1 <<<<< Don't
redistribute ISDN Network
route-map deny-ISDN-network permit 20 back into OSPF from
EIGRP
match ip address 2 <<<<< But do allow
everything else
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 2 permit any
!
Router eigrp 1
redistribute ospf 1
passive BRI
!
Interface BRI
ip add 192.168.1.1 255.255.255.0
ip ospf demand-circuit
- Kevin
At 04:10 PM 1/29/01 -0600, Mike S. Lee wrote:
>How would one stop the dial line from coming up if you are redistributing?
>
>
>Mike
>At 05:03 PM 1/29/2001 -0500, Rick Burts wrote:
>>Mike
>>
>>There is a pretty well known behavior of demand circuit activating
>>when the environment includes some other protocol on the router and
>>redistribution of that protocol into OSPF. Briefly the other protocol
>>sees the ISDN going down as a routing change which is redistributed into
>>OSPF which brings the link up to advertise the change. You can look into
>>the archives for more extensive discussions of this.
>>
>>Rick
>>
>>Rick Burts, CCSI CCIE 4615 burts@mentortech.com
>>Mentor Technologies 240-568-6500 ext 6652
>>133 National Business Parkway 240-568-6515 fax
>>Annapolis Junction, Md 20701
>>
>>Chesapeake Network Solutions has now become Mentor Technologies.
>>Mentor Technologies is a certified Cisco Training Partner and also
>>a Cisco Professional Services partner.
>>We offer most of the Cisco training courses.
>>We also offer training in Checkpoint Firewall software and
>>Fore Systems (now Marconi) and MicroMuse.
>>We also provide network consulting services including
>>design, management, and problem solving.
>>We have 22 CCIEs on our staff.
>>We offer the breakthrough VLAB remote access technology for
>>access to pratice configuration on real equipment.
>>
>>On Mon, 29 Jan 2001, Mike S. Lee wrote:
>>
>> > In trying to use the Demand circuit option I still see the dialer dialing.
>> > Debugging Q931 is see that the dial cause is 224.0.0.5 which is all spf
>> > routers. I thought that using an ospf demand circuit should have
>> suppressed
>> > all LSA's from going across this line. Can someone either explain this
>> > behavior or provide a working config that uses demand circuits and only
>> > comes up when the primary link fails? Any debug outputs would be
>> helpful as
>> > well.
>> >
>> > thanks
>> >
>> > mike
>> > At 11:53 AM 1/29/2001 -0800, Kevin Baumgartner wrote:
>> > >I have heard this a few times but I have had no problems using it
>> with OSPF.
>> > >Maybe this was a limitation in earlier 12.0 images.
>> > >
>> > > Kevin
>> > >
>> > >
>> > >At 01:18 PM 1/29/01 -0600, Wade Edwards wrote:
>> > > >As I recall dialer watches work only with IGRP and EIGRP. If you
>> need OSPF
>> > > >then the demand circuit is the best way to go.
>> > > >
>> > > >-----Original Message-----
>> > > >From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
>> > > >Jeremy Gray
>> > > >Sent: Sunday, January 28, 2001 2:34 PM
>> > > >To: ccielab@groupstudy.com
>> > > >Subject: RE: ISDN Backup without the backup interface command?
>> > > >
>> > > >
>> > > >
>> > > >A demand circuit is useful if you really msut run OSPF over an ISDN
>> line.
>> > > >
>> > > >A better answer to this problem is to use a dialer watch-list, a
>> very cool
>> > > >facility used to trigger DDR when a 'watched' route is absent in
>> the routing
>> > > >table.
>> > > >
>> > > >This is great for a number of reasons.
>> > > >
>> > > >1) Packet switched networks are not the best at telling a DTE when
>> there's a
>> > > >problem in the cloud. Examples being ATM and FR
>> > > >Interface may stay up/up even if the remote is down.
>> > > >
>> > > >2) You can place a DDR in a place further into your network rather
>> than on
>> > > >the same router as a critical link and still have DDR work when the
>> link
>> > > >fails if the routes being watches originate beyound the point of
>> failure.
>> > > >
>> > > >Regards,
>> > > >
>> > > >Jeremy.
>> > > >
>> > > >PS: Joined today. Lab date March 8th.
>> > > >-----Original Message-----
>> > > >From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
>> > > >Robert DeVito
>> > > >Sent: 28 January 2001 16:39
>> > > >To: obuba@bellatlantic.net; mac38456@pegasus.cc.ucf.edu;
>> > > >ccielab@groupstudy.com
>> > > >Subject: Re: ISDN Backup without the backup interface command?
>> > > >
>> > > >
>> > > >
>> > > >
>> > > >Another thing to keep in mind is that ospf demand circuit will
>> cause the
>> > > >isdn circuit to come up when there is a topology change.. So don't be
>> > > >shocked when it comes up every once and awhile.
>> > > >
>> > > >Robert
>> > > >
>> > > >----Original Message Follows----
>> > > >From: "Nnanna Obuba" <obuba@bellatlantic.net>
>> > > >Reply-To: "Nnanna Obuba" <obuba@bellatlantic.net>
>> > > >To: "Miguel A. Ciena" <mac38456@pegasus.cc.ucf.edu>,
>> > > ><ccielab@groupstudy.com>
>> > > >Subject: Re: ISDN Backup without the backup interface command?
>> > > >Date: Sun, 28 Jan 2001 10:10:43 -0500
>> > > >
>> > > >That's no trick, use ospf demand circuit
>> > > >
>> > > >
>> > > >Nnanna Obuba, CCIE # 6586
>> > > >www.nantech.com
>> > > >Online lab for CCIE Preparation
>> > > >----- Original Message -----
>> > > >From: "Miguel A. Ciena" <mac38456@pegasus.cc.ucf.edu>
>> > > >To: <ccielab@groupstudy.com>
>> > > >Sent: Sunday, January 28, 2001 9:07 AM
>> > > >Subject: ISDN Backup without the backup interface command?
>> > > >
>> > > >
>> > > > > Between R3 and R5 I got a ISDN link. I want to configure my
>> ISDN to =
>> > > > > back-up my frame relay connection between R3 and R5...Here is
>> the Trick:
>> > > >=
>> > > > > Without using Floating Static and without using the Back-up
>> interface =
>> > > > > command..My Frame and ISDN are in OSPF area 0...
>> > > > >
>> > > > > any ideas..
>> > > > >
>> > > > >
>> > > > >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:48 GMT-3