Re: OSPF-Hub and spoke-partial mesh/ ###my configs!!!###

From: Claude-Vincent (claude_vincent@xxxxxxxxx)
Date: Wed Jan 24 2001 - 23:03:38 GMT-3


   
spoke1#sh run
Building configuration...

Current configuration:
!
! Last configuration change at 10:53:56 UTC Thu Jan 25 2001
!
version 12.0
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
!
hostname spoke1
!
!
ip subnet-zero
no ip domain-lookup
!
frame-relay switching
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 170.10.100.1 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay interface-dlci 104
 frame-relay intf-type dce
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 192.168.10.1 255.255.255.0
 no ip directed-broadcast
 ip policy route-map spoke
 ring-speed 16
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 11.11.11.11 0.0.0.0 area 0
 network 170.10.100.1 0.0.0.0 area 0
 network 192.168.10.1 0.0.0.0 area 1
 distribute-list 1 in
!
ip local policy route-map spoke
no ip http server
ip classless
!
access-list 1 deny 170.10.100.0 0.0.0.255
access-list 1 permit any
access-list 2 permit any
route-map spoke permit 10
 match ip address 2
 set ip next-hop 170.10.100.3
!
alias exec i sh ip route
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

spoke1#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR, P - periodic downloaded static
route
       T - traffic engineered route

Gateway of last resort is not set

     170.10.0.0/29 is subnetted, 1 subnets
C 170.10.100.0 is directly connected, Serial0
C 192.168.10.0/24 is directly connected, TokenRing0
O IA 192.168.20.0/24 [110/74] via 170.10.100.2, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
O IA 10.16.89.0 [110/74] via 170.10.100.3, Serial0
     11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, Loopback0
spoke1#ping 170.10.100.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 170.10.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/62/64 ms

spoke2#sh run
Building configuration...

Current configuration:
!
! Last configuration change at 10:52:16 UTC Thu Jan 25 2001
!
version 11.3
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
!
hostname spoke2
!
!
no ip domain-lookup
frame-relay switching
!
!
 !
 !
 process-max-time 200
 !
 interface Loopback0
 ip address 12.12.12.12 255.255.255.0
!
interface Ethernet0
 ip address 192.168.20.1 255.255.255.0
 ip policy route-map spoke
 no keepalive
!
interface Serial0
 ip address 170.10.100.2 255.255.255.248
 encapsulation frame-relay
 ip split-horizon
 frame-relay interface-dlci 204
 frame-relay intf-type dce
!
interface Serial1
 no ip address
 shutdown
!
router ospf 1
 network 170.10.100.2 0.0.0.0 area 0
 network 192.168.20.1 0.0.0.0 area 3
 neighbor 170.10.100.1
 neighbor 170.10.100.3 priority 10
!
ip local policy route-map spoke
ip classless
!
access-list 2 permit any
route-map spoke permit 10
 match ip address 2
 set ip next-hop 170.10.100.3
!
alias exec i sh ip route
!
line con 0
line aux 0
line vty 0 4
 login
!
end

spoke2#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     170.10.0.0/29 is subnetted, 1 subnets
C 170.10.100.0 is directly connected, Serial0
O IA 192.168.10.0/24 [110/70] via 170.10.100.1, 00:12:48, Serial0
C 192.168.20.0/24 is directly connected, Ethernet0
     10.0.0.0/24 is subnetted, 1 subnets
O IA 10.16.89.0 [110/74] via 170.10.100.3, 00:12:48, Serial0
     11.0.0.0/32 is subnetted, 1 subnets
O 11.11.11.11 [110/65] via 170.10.100.1, 00:12:48, Serial0
     12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Loopback0

AS2509#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS2509
!
enable password #
!
ip subnet-zero
no ip domain-lookup
ip host spoke2 2003 1.1.1.1
ip host spoke1 2002 1.1.1.1
ip host hub 2001 1.1.1.1
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.16.89.19 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 170.10.100.3 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf priority 10
 clockrate 125000
 frame-relay interface-dlci 401
 frame-relay interface-dlci 402
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 10.16.89.19 0.0.0.0 area 3
 network 170.10.100.3 0.0.0.0 area 0
 neighbor 170.10.100.2
 neighbor 170.10.100.1
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.16.89.253
!
alias exec i sh ip route
!
line con 0
 no exec
line 1 8
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password #
 login
!
end

Vincent

----- Original Message -----
From: "Burgstaller, Oliver" <BurgstallerO@messe-duesseldorf.de>
To: <ccielab@groupstudy.com>
Cc: "'Claude-Vincent'" <claude_vincent@yahoo.com>
Sent: Thursday, January 25, 2001 1:21 AM
Subject: AW: OSPF-Hub and spoke-partial mesh

Hello,

Hub and spoke in ospf:
First make the hube to become DR (set ip ospf priority to 0 on the spoke's
frame relay interface) second config on hub ospf neighbor spoke1 and spoke2
on the spoke's the hub as neighbor That's all

Oliver Burgstaller
Vnetworking GbR
http://www.vnetworking.de

-----Ursprüngliche Nachricht-----
Von: Claude-Vincent [mailto:claude_vincent@yahoo.com]
Gesendet am: Mittwoch, 24. Januar 2001 10:00
An: Kevin Baumgartner
Cc: ccielab@groupstudy.com
Betreff: RE: OSPF-Hub and spoke-partial mesh

Kevin,

It has already been done. And it works like a champ. But I am talking about
the spokes. How to make the spokes talk together without making a PVC
between the 2 spokes and using routing policy?

Actually, I have got only one area. Area0, my FR net partial mesh (no pvc to
connect the spokes). The IP address of the FR interfaces are: Spoke1
170.10.100.1/29, spoke2 170.10.100.2/29 and hub 170.10.100.3/29.

Here is the routing tables of the spokes:

spoke2#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     170.10.0.0/29 is subnetted, 1 subnets
C 170.10.100.0 is directly connected, Serial0
O IA 192.168.10.0/24 [110/70] via 170.10.100.1, 01:12:19, Serial0
C 192.168.20.0/24 is directly connected, Ethernet0
     10.0.0.0/24 is subnetted, 1 subnets
O IA 10.16.89.0 [110/74] via 170.10.100.3, 01:12:19, Serial0
     11.0.0.0/32 is subnetted, 1 subnets
O 11.11.11.11 [110/65] via 170.10.100.1, 01:12:19, Serial0
     12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Loopback0

spoke1#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR, P - periodic downloaded static
route
       T - traffic engineered route

Gateway of last resort is not set

     170.10.0.0/29 is subnetted, 1 subnets
C 170.10.100.0 is directly connected, Serial0
C 192.168.10.0/24 is directly connected, TokenRing0
O IA 192.168.20.0/24 [110/74] via 170.10.100.2, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
O IA 10.16.89.0 [110/74] via 170.10.100.3, Serial0
     11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, Loopback0
spoke1#

Vincent

----- Original Message -----
From: "Kevin Baumgartner" <kbaumgar@cisco.com>
To: <claude_vincent@yahoo.com>
Cc: <ccielab@groupstudy.com>
Sent: Wednesday, January 24, 2001 4:58 PM
Subject: Re: your mail

> Actuallly need the neighbor commands only on the hub router.
> I have this setup working with no neighbor commands on the spokes.
>
> Kevin
>
> >
> > Jay,
> >
> > I input the neighbor statement on my spokes router but...
> >
> > spoke1#sh ip ospf nei
> >
> > Neighbor ID Pri State Dead Time Address
Interface
> > N/A 1 ATTEMPT/DROTHER - 170.10.100.2
Serial0
> > 1.1.1.1 10 FULL/DR 00:01:59 170.10.100.3
Serial0
> >
> > spoke2#sh ip ospf nei
> >
> > Neighbor ID Pri State Dead Time Address
Interface
> > N/A 0 ATTEMPT/DROTHER - 170.10.100.1
Serial0
> > 1.1.1.1 10 FULL/DR 00:01:40 170.10.100.3
Serial0
> >
> > I don't see anyway how it can work with that command. Could you shed
some
> > light on it?
> >
> > Vincent
> >
> > ----- Original Message -----
> > From: "Jay Hennigan" <jay@west.net>
> > To: "Claude-Vincent" <claude_vincent@yahoo.com>
> > Cc: "'Ccielab" <ccielab@groupstudy.com>
> > Sent: Wednesday, January 24, 2001 3:53 PM
> > Subject: Re: your mail
> >
> >
> > > On Wed, 24 Jan 2001, Claude-Vincent wrote:
> > >
> > > > Dear all,
> > > >
> > > > I have got a FR netw. topology Hub and spoke. One area (area 0),
> > > > non-broadcat ospf net., no subinterface and dynamic mapping.
> > > >
> > > > To make the spokes talk to each other, I made a policy routing
(local
> > one,
> > > > of course) and it works fine.
> > > >
> > > > My question is: Is there any other way to do it?
> > >
> > > Configure defined neighbor statements?
> > >
> > > --
> > > Jay Hennigan - Network Administration - jay@west.net
> > > NetLojix Communications, Inc. NASDAQ: NETX -
http://www.netlojix.com/
> > > WestNet: Connecting you to the planet. 805 884-6323
> > >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:43 GMT-3