From: Steve Clubb (sclubb@xxxxxxxxxxx)
Date: Sun Jan 21 2001 - 17:21:31 GMT-3
Oops - I meant to say, I changed the rp-add on r1 to r2's loopback.
-----Original Message-----
From: Steve Clubb [mailto:sclubb@cattech.com]
Sent: Sunday, January 21, 2001 11:16 AM
To: ccielab@groupstudy.com
Cc: 'atifawan@hotmail.com'; 'atifawan@hotmail.com';
'tvarriale@telocity.com'; 'swong@nosc.mil'
Subject: RE: ip multicasting and ping
I changed the ip igmp join-group to r1's loopback and changed the rp-address
on r2 to r1's loopback.
I also added global command ip pim rp-address 137.20.2.1 to r1.
Now I can ping the join-group address:
r2#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 137.20.12.1, 80 ms
Reply to request 0 from 137.20.12.1, 128 ms
Reply to request 0 from 137.20.12.1, 92 ms
I later (not shown) added a join-group address (225.4.4.4) to e0 and was
able to ping.
Does this look right to you?
Thanks for all your input.
Steve
*****************************************
Here are the new configs and show outputs:
hostname r2
!
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Loopback0
ip address 137.20.2.1 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
!
interface Serial0
ip address 137.20.12.2 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
frame-relay interface-dlci 202
!
interface TokenRing0
ip address 137.20.22.1 255.255.255.240
ip pim sparse-mode
ip multicast use-functional
!
ip pim rp-address 137.20.2.1
*********************************
hostname r1
!
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Loopback0
ip address 137.20.1.1 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
ip igmp join-group 224.2.2.2
!
interface Ethernet0
ip address 137.20.10.1 255.255.255.0
ip pim sparse-mode
!
interface Serial0.2 point-to-point
ip address 137.20.12.1 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
frame-relay interface-dlci 202
!
ip pim rp-address 137.20.2.1
********************************
r2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
(*, 224.0.1.40), 00:18:21/00:00:00, RP 137.20.2.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.20.12.1, Forward/Sparse, 00:02:33/00:02:57
TokenRing0, Forward/Sparse, 00:18:21/00:02:05
(*, 224.2.2.2), 00:02:34/00:02:59, RP 137.20.2.1, flags: SJ
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.20.12.1, Forward/Sparse, 00:02:34/00:02:25
(137.20.2.1/32, 224.2.2.2), 00:01:43/00:01:16, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.20.12.1, Forward/Sparse, 00:01:43/00:02:25
(137.20.12.2/32, 224.2.2.2), 00:01:43/00:01:17, flags:
Incoming interface: Serial0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.20.12.1, Forward/Sparse, 00:01:44/00:02:23
r2#sh ip pim nei
PIM Neighbor Table
Neighbor Address Interface Uptime Expires Mode
137.20.12.1 Serial0 11:24:25 00:01:27 Sparse
r2#sh ip pim rp
Group: 224.0.1.40, RP: 137.20.2.1, next RP-reachable in 00:00:57
Group: 224.2.2.2, RP: 137.20.2.1, next RP-reachable in 00:00:11
r2#sh ip pim rp mapp
PIM Group-to-RP Mappings
Group(s) 224.0.1.39/32, uptime: 00:18:39, expires: never
RP 137.20.2.1 (?)
Info source: local
Group(s) 224.0.1.40/32, uptime: 00:18:39, expires: never
RP 137.20.2.1 (?)
Info source: local
Group(s): 224.0.0.0/4, Static
RP: 137.20.2.1 (?)
********************************
r1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
(*, 224.0.1.40), 11:26:40/00:00:00, RP 137.20.2.1, flags: SJCL
Incoming interface: Serial0.2, RPF nbr 137.20.12.2
Outgoing interface list:
Ethernet0, Forward/Sparse, 11:26:40/00:02:42
(*, 224.2.2.2), 00:03:06/00:00:00, RP 137.20.2.1, flags: SJCLF
Incoming interface: Serial0.2, RPF nbr 137.20.12.2
Outgoing interface list:
Loopback0, Forward/Dense, 00:03:07/00:00:00
(137.20.2.1/32, 224.2.2.2), 00:02:15/00:00:44, flags: CLJT
Incoming interface: Serial0.2, RPF nbr 137.20.12.2
Outgoing interface list:
Loopback0, Forward/Dense, 00:02:15/00:00:00
(137.20.12.2/32, 224.2.2.2), 00:02:15/00:00:44, flags: CLFT
Incoming interface: Serial0.2, RPF nbr 137.20.12.2, Registering
Outgoing interface list:
Loopback0, Forward/Dense, 00:02:16/00:00:00
r1#sh ip pim nei
PIM Neighbor Table
Neighbor Address Interface Uptime Expires Mode
137.20.12.2 Serial0.2 11:24:18 00:01:24 Sparse
r1#sh ip pim rp
Group: 224.0.1.40, RP: 137.20.2.1, uptime 00:03:31, expires 00:02:21
Group: 224.2.2.2, RP: 137.20.2.1, v1, uptime 00:03:31, expires never
r1#sh ip pim rp mapp
PIM Group-to-RP Mappings
Group(s) 224.0.1.39/32, uptime: 00:04:02, expires: never
RP 137.20.2.1 (?)
Info source: local
Group(s) 224.0.1.40/32, uptime: 00:04:02, expires: never
RP 137.20.2.1 (?)
Info source: local
Group(s): 224.0.0.0/4, Static
RP: 137.20.2.1 (?)
*************************************************
-----Original Message-----
From: Atif Awan [mailto:atifawan@hotmail.com]
Sent: Sunday, January 21, 2001 8:35 AM
To: tvarriale@telocity.com; sclubb@cattech.com
Cc: ccielab@groupstudy.com
Subject: Re: ip multicasting and ping
R2 does not have to join that group explicitly. Send us the output of the
command show ip mroute, show ip pim neighbors, and show ip igmp groups for
both routers.
Regards
Atif
>From: "tv"
>Reply-To: "tv"
>To: "Steve Clubb"
>CC:
>Subject: Re: ip multicasting and ping
>Date: Sun, 21 Jan 2001 10:13:07 -0600
>
>I think you are not telling r2 to join anything. Recommendations:
>
>Try to make a loopback on r1 the rp.
>Have r2 join the multicast address.
>do a show ip mroute on r2 before you ping.
>
>Let us know how it works.
>
>tv
>
>----- Original Message -----
>From: "Steve Clubb"
>To:
>Sent: Sunday, January 21, 2001 2:15 AM
>Subject: ip multicasting and ping
>
>
> > For all you multi-cast wizards out there, I have 2 routers configured as
> > such:
> >
> > r2 cannot ping multicast 224.2.2.2-4 on r1's e0.
> >
> > Any reasons why?
> >
> > Thanks,
> >
> > Steve
> >
> >
> > r1#
> > ip multicast-routing
> > ip dvmrp route-limit 20000
> > !
> > interface Ethernet0
> > ip address 137.20.10.1 255.255.255.0
> > ip pim sparse-mode
> > ip igmp join-group 224.2.2.2
> > !
> > interface Serial0.2 point-to-point
> > ip address 137.20.12.1 255.255.255.0
> > ip pim nbma-mode
> > ip pim sparse-mode
> >
> > r2#
> > ip multicast-routing
> > ip dvmrp route-limit 20000
> > !
> > interface Serial0
> > ip address 137.20.12.2 255.255.255.0
> > ip pim nbma-mode
> > ip pim sparse-mode
> > !
> > interface TokenRing0
> > ip address 137.20.22.1 255.255.255.240
> > ip multicast use-functional
> > ip pim sparse-mode
> > !
> > ip pim rp-address 137.20.12.1
> >
> >
> > r2#ping 224.2.2.2
> >
> > Type escape sequence to abort.
> > Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
> > ..
> > r2#
> >
> >
> >
> >
> >
> >
> >
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:37 GMT-3