RE: IGRP host routes

From: Lykourgiotis Paraskevas (ParaskevasL@xxxxxxxxxxxx)
Date: Mon Jan 08 2001 - 07:05:22 GMT-3


   

-
Ok Chuck. May be I am wrong.
Well:

The network layout is this:
R2(s0/0)-----(s1/1)R1(f0/0)----(e0/0)R3

The router configs are:

r2#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
enable secret 5 $1$T/a2$0JLlEzpJ.0/zlMVqF.q1C.
!
!
!
!
!
ip subnet-zero
!
!
interface Serial0/0
 ip address 172.1.1.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
 clockrate 64000
!
router rip
 network 172.1.0.0
!
ip classless
no ip http server
!
route-map t permit 10
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 password c
 login
!
end

r1# sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable secret 5 $1$pKon$VpLd60AF4n/ws.32wpa7j1
!
ip subnet-zero
!
!
interface FastEthernet0/0
 ip address 172.1.17.10 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/1
 ip address 172.1.1.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 encapsulation ppp
 no ip route-cache
 ip ospf network point-to-multipoint
 ip ospf cost 700
 no ip mroute-cache
 no keepalive
!
interface Serial1/2
 ip address 173.1.1.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
!
router ospf 1
 network 172.1.17.10 0.0.0.0 area 0
!
router rip
 redistribute ospf 1 metric 1
 passive-interface FastEthernet0/0
 network 172.1.0.0
!
ip classless
no ip http server
!
access-list 5 permit any
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password c
 login
!
end

r3#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service hide-telnet-addresses
!
hostname r3
!
enable secret 5 $1$NJMm$iUgxbz5hAfg7hYdauJRgb0
!
!
!
!
!
ip subnet-zero
!
interface Loopback1
 ip address 172.1.18.1 255.255.255.224
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 172.1.17.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 ip route-cache policy
!
router ospf 1
 network 172.1.17.1 0.0.0.0 area 0
 network 172.1.18.1 0.0.0.0 area 1
!
ip classless
no ip http server
!
route-map t permit 10
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 password c
 login
 history size 50
!
end

r3#

NOW THE PROBLEM:
I am supposing 172.1.18.1 should not be advertised by R1. But it does.
Furthermore R2 should not intall it in its routing table. But it does.
Should it?
What I expect is 172.1.18.1 not being advertized by RIP because of it's
mask(/32)
(The supposed differnce between RIP and IGRP is that if I configure IGRP
instead of RIP, 172.1.18.1/32 is not advertized)

Look at the following debugs
r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.1.1.0/24 is directly connected, Serial1/1
C 172.1.17.0/24 is directly connected, FastEthernet0/0
O IA 172.1.18.1/32 [110/2] via 172.1.17.1, 00:04:40, FastEthernet0/0
r1#
r1#deb ip rip
RIP protocol debugging is on
r1#
02:23:30: RIP: sending v1 update to 255.255.255.255 via Serial1/1
(172.1.1.1)
02:23:30: RIP: build update entries
02:23:30: subnet 172.1.17.0 metric 1
02:23:30: subnet 172.1.18.1 metric 1
!!!!My problem is the above line
r1#

r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.1.1.0/24 is directly connected, Serial0/0
C 172.1.1.1/32 is directly connected, Serial0/0
R 172.1.17.0/24 [120/1] via 172.1.1.1, 00:00:27, Serial0/0
R 172.1.18.1/32 [120/1] via 172.1.1.1, 00:00:27, Serial0/0
r2#
r2#deb ip rip
00:42:39: RIP: sending v1 update to 255.255.255.255 via Serial0/0
(172.1.1.2)
00:42:39: RIP: build update entries - suppressing null update
00:42:49: RIP: received v1 update from 172.1.1.1 on Serial0/0
00:42:49: 172.1.17.0 in 1 hops
00:42:49: 172.1.18.1 in 1 hops
#r2

THANKS FOR ALL REPLIES

-----Original Message-----
From: Chuck Larrieu [mailto:chuck@cl.cncdsl.com]
Sent: Friday, December 29, 2000 7:51 PM
To: Lykourgiotis Paraskevas; ccielab@groupstudy.com
Subject: RE: IGRP host routes.

I'm curious as to what it is that you think you are seeing. More
importantly, why you think you are seeing it.

I set up a Q&D with two routers one the same ethernet segment. I tried to
duplicate your configs as closely as I could determine.

I do not see anything that indicates that RIP is behaving differently that I
would expect - classful behaviour.

When you do a show ip route on the particular router you will see routes in
the table that indicate your variable masks, including the host route to the
loopback. That is because the loopback is directly connected, has an admin
distance of 0, and so is preferred in the routing table when compared to the
rip route.

I looked at debug ip rip database outputs from both routers I set up. I am
seeing the placement of the interfaces with different subnet masks into the
routing table with their correct mask ( expected, because of the admin
distance preference ) and moved into RIP with the classful mask ( expected )

Can you post complete configs on both routers - all interfaces - so I can
try to duplicate your setup more precisely.

Thanks.

Chuck



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:23 GMT-3