Re: Frame-relay hub spoke config

From: G F Marsh (gfm@xxxxxxxxx)
Date: Sun Dec 31 2000 - 18:36:06 GMT-3


   
Here is an example of a working config with mainly the relevant bits to keep
the amount of text to a minimum.
Hope this helps but please realise that this is just one way to set up a hub
& spoke frame relay configuration.

Central Hub Router

interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
!
interface Serial0.1 point-to-point
 ip address 172.16.1.112 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 112
!
interface Serial0.2 point-to-point
 ip address 172.16.2.113 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 113
!
interface Serial0.3 point-to-point
 ip address 172.16.3.114 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 114

Spoke 1 router

interface Serial0
 ip address 172.16.1.114 255.255.255.0
 encapsulation frame-relay IETF
 frame-relay interface-dlci 211
 frame-relay lmi-type ansi

Spoke 2 router

interface Serial0
 ip address 172.16.2.115 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay IETF
 frame-relay interface-dlci 311
 frame-relay lmi-type ansi

Spoke 3 router

interface Serial0
 ip address 172.16.3.115 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
 frame-relay interface-dlci 411

Frame Switch (router configured as)

Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname router1
!
!
frame-relay switching
!
!
interface Ethernet0
 no ip address
 shutdown
 media-type 10BaseT
!
interface Ethernet1
 no ip address
 shutdown
 media-type 10BaseT
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 1000000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 112 interface Serial1 211
 frame-relay route 113 interface Serial2 311
 frame-relay route 114 interface Serial3 411
!
interface Serial1
 no ip address
 encapsulation frame-relay IETF
 clockrate 1000000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 211 interface Serial0 112
!
interface Serial2
 no ip address
 encapsulation frame-relay IETF
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 311 interface Serial0 113
!
interface Serial3
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 411 interface Serial0 114
!
!
line con 0
line aux 0
 transport input all
line vty 0 4
 privilege level 15
 no login
!
end

GFM
----- Original Message -----
From: fwells12 <fwells12@hotmail.com>
To: <ccielab@groupstudy.com>
Sent: Sunday, December 31, 2000 9:23 AM
Subject: Frame-relay hub spoke config

> Has anyone got a frame-relay hub and spoke config I can look at please? =
> I specifically need to see one where the Hub is using point-to-point =
> sub-interfaces and the Spokes are using physical interfaces. Preferably =
> one with three spokes. I would like to see the Frame-switch, a Hub =
> sub-interface and one of the spokes serial interface configs if it is =
> not too much to ask... :-)
>
> I cannot find any examples of this setup. Caslow mentions it briefly =
> but doesn't give any configs. I am still searching CCO.
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:26:14 GMT-3