Re: OSPF network statement

From: Curtis Lindsay (clindsay_98@xxxxxxxxx)
Date: Fri Dec 29 2000 - 22:51:41 GMT-3


   
Hi,

One thing you must take into consideration with the
network command in ospf is that it acts as an access
list to determine what links or interfaces (ie network
address) to match and include in the ospf process for
advertisement. It has nothing to do with conserving
address space. You can put the same network statement
in different routers and it will advertise the links
that match the network statement. For example:

router 1

interface Loopback0
 ip address 192.168.20.2 255.255.248.0
!
interface Loopback1
 ip address 192.168.28.2 255.255.248.0
!
interface Loopback2
 ip address 192.168.36.2 255.255.248.0
!
interface Loopback3
 ip address 192.168.44.2 255.255.248.0=20
!
router ospf 100
network 192.168.0.0 0.0.63.255 area 0.0.0.0

router 2
interface Loopback0
 ip address 192.168.25.2 255.255.248.0
!
interface Loopback1
 ip address 192.168.29.2 255.255.248.0
!
interface Loopback2
 ip address 192.168.37.2 255.255.248.0
!
interface Loopback3
 ip address 192.168.45.2 255.255.248.0
!
router ospf 100
net 192.168.0.0 0.0.63.255 area 0.0.0.0
!
Now granted the /32 bit host address will be
advertised. You do not want to use an area range
statement in both routers.

Curtis
--- fwells12 <fwells12@hotmail.com> wrote:
> I have the following IP addresses configured as
> loopback interfaces on =
> an OSPF router. What is the correct command to
> insert these networks =
> into the OSPF process in the most efficient manner?
> By that, I mean =
> conserving the maximum amount of IP addresses.
>
> interface Loopback0
> ip address 192.168.20.2 255.255.248.0
> !
> interface Loopback1
> ip address 192.168.28.2 255.255.248.0
> !
> interface Loopback2
> ip address 192.168.36.2 255.255.248.0
> !
> interface Loopback3
> ip address 192.168.44.2 255.255.248.0=20
>
> Cheers.
>
>
>
>
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:26:13 GMT-3