From: Brian Hescock (bhescock@xxxxxxxxx)
Date: Thu Dec 28 2000 - 18:24:53 GMT-3
The reason the loopbacks aren't being advertised as a /32 in your
example is only because of your area range statement (which I'm glad
you mentioned because that's another way around the problem if they don't
allow you to use "ip ospf network" on the interface). If you take the
default configuration:
int loop0
ip address 10.1.1.1 255.0.0.0
router ospf 1
network 10.1.1.1 0.0.0.0 area 0
the only route to be advertised would be 10.1.1.1 /32 even though it's a
/8 on the interface.
Change it to read:
int loop0
ip add 10.1.1.1 255.0.0.0
ip opsf network point-to-point (ip ospf network loopback is the
default)
and it would then advertise it as a /8
Brian
On Thu, 28 Dec 2000, fwells12 wrote:
> Thanks for your reply Brian,
> I am playing around with different IP add/mask combos to get a good grip on
> the best way to deal with this issue. I am using different size networks
> on the loopbacks to simulate being in a large OSPF environment.
>
> Regarding your statement 'It's going to be advertised as a /32 anyway if
> you don't change the ospf network type to something other than the
> default.', was this directed at external route summarization? I used the
> area range command to change the advertisment and can only see the following
> route in other routers route tables:
>
> O IA 192.168.0.0/18 [110/1563] via 147.1.5.5, 00:00:05, Serial0
>
>
> ----- Original Message -----
> From: Brian Hescock <bhescock@cisco.com>
> To: Earl Aboytes <Earl@dnssystems.com>
> Cc: 'Connary, Julie Ann' <jconnary@cisco.com>; fwells12
> <fwells12@hotmail.com>; <ccielab@groupstudy.com>
> Sent: Thursday, December 28, 2000 12:46 PM
> Subject: RE: OSPF network statement
>
>
> > Earl's answer is probably the one you're looking for if we understand your
> > requirement correctly. But if you aren't told you must only have one
> > network entry, I agree with the other person that said to use the ip
> > address off of the interface and 0.0.0.0 wildcard bits, as in:
> >
> > network 172.168.1.1 0.0.0.0 area 0
> >
> > There's less chance for error and it's obvious if the proctor changes it
> > because the ip address will always be the ip address from the interface
> > and the wildcard bits are always 0.0.0.0. This is also a recommended
> > way to do it in a production network *IF* you don't have a lot of
> > interfaces, it makes troubleshooting far easier.
> >
> > By the way, why such a huge network for the loopback, why not a /24
> > or a /30 or /32? It's going to be advertised as a /32 anyway if you don't
> > change the ospf network type to something other than the default.
> >
> > Brian
> >
> > On Thu, 28 Dec 2000, Earl Aboytes wrote:
> >
> > > I think this is the answer that you are looking for.
> > >
> > > Network 192.168.0.0 0.0.63.255 area 0
> > >
> > > This would put all networks 192.168.0.0 through 192.168.63.0 in area 0
> > >
> > > Watch out that you don't have any other conflicts. To be cautious I
> always
> > > make separate entries and make sure that my masks match my wildcards.
> > >
> > > Earl Aboytes CCIE 6097
> > >
> > > PS. Sam@datastreet, if you read this post I want you to know that I
> think
> > > that it's pretty cool how involved you are in this CCIE thing. My dad
> can't
> > > even remember the meaning of the four letters C-C-I-E.
> > >
> > > -----Original Message-----
> > > From: Connary, Julie Ann [mailto:jconnary@cisco.com]
> > > Sent: Thursday, December 28, 2000 11:51 AM
> > > To: fwells12
> > > Cc: ccielab@groupstudy.com
> > > Subject: Re: OSPF network statement
> > >
> > > Since each loopback interface will be a host route, use 4 network
> > > statements like:
> > >
> > > network 192.168.20.2 0.0.0.0 area X
> > >
> > > Julie Ann
> > >
> > > At 11:17 AM 12/28/2000 -0800, fwells12 wrote:
> > > >I have the following IP addresses configured as loopback interfaces on
> =
> > > >an OSPF router. What is the correct command to insert these networks =
> > > >into the OSPF process in the most efficient manner? By that, I mean =
> > > >conserving the maximum amount of IP addresses.
> > > >
> > > >interface Loopback0
> > > > ip address 192.168.20.2 255.255.248.0
> > > >!
> > > >interface Loopback1
> > > > ip address 192.168.28.2 255.255.248.0
> > > >!
> > > >interface Loopback2
> > > > ip address 192.168.36.2 255.255.248.0
> > > >!
> > > >interface Loopback3
> > > > ip address 192.168.44.2 255.255.248.0=20
> > > >
> > > >Cheers.
> > > >
> > > >
> > > >
> > > >
> > > >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:26:12 GMT-3