From: Philippe Stassin (stassinp@xxxxxxxxx)
Date: Sat Dec 23 2000 - 20:12:15 GMT-3
Hello,
I would say that IGRP will never advertise a /32 route. RIP will advertise
host routes.
IGRP and RIPv1 have no way to advertise a mask along with a route. They will
advertise routes through intefaces that have an ip @ configured with the
same mask as the route to be advertised.
For example:
interface Loopback5
ip address 172.1.3.1 255.255.255.255
!
router igrp 1
network 172.1.0.0
network 10.0.0.0
!
interface Serial0/0
ip address 172.1.1.2 255.255.255.0
!
interface Serial0/1
ip address 172.1.2.2 255.255.255.240
!
interface Serial0/2
ip address 172.1.4.2 255.255.255.240
!
interface Serial0/3
ip address 10.1.1.1 255.255.255.252
In this example, 172.1.2.0/28 will be advertised through serial0/2 only and
172.1.4.0/28 will be advertised through serial0/1 only.
172.1.x.x networks will be automatically summarised to their native class
boundary (172.1.0.0/16) and advertised through serial0/3.
So now, where do you think ip route to 172.1.3.1 255.255.255.255 could be
advertised ? Through another loopback interface ? ...
RIPv1 has the same behaviour but it will advertise the /32 route as a host
route.
RIP v2 is a classless routing protocol and is able to handle VLSM. In the
upper example, every network would be announced through all interfaces but
172.1.x.x would still be summarized at serial0/3.
"Routing TCP/IP" from Jeff Doyle explain all this stuff very well.
Philippe.
-----Original Message-----
From: Lykourgiotis Paraskevas <ParaskevasL@pcsystems.gr>
To: ccielab@groupstudy.com <ccielab@groupstudy.com>
Date: Thursday, December 21, 2000 12:37 AM
Subject: IGRP host routes.
>Hi.
>
>I want to ask something basic.
>Does IGRP advertise host routes (in a non segmented network enviroronment)?
>
>I think, in theory, host routes are advertised by the originator of the
host
>routes, at least.
>In the same environment, if I turn to RIP, I have no problem.
>
>TIA,
>
>Paraskevas
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:26:10 GMT-3