From: James Chen (jr_chen@xxxxxxxxxxxxxxx)
Date: Thu Dec 07 2000 - 14:24:12 GMT-3
Hello, Sir:
I have met some problem aboout IP Multicast !
The scenario is as following .
E0 -R2 <---->R3<----->R4-E0
|
E0
R2, R3, R4 are connected with Frame Relay , the R3 is Hub, R2, R4 are
spokes.
I use point-to-multipoint network type to config ospf.
so that only one frame-relay map in R2 and R4.
The requrement : config R2, R3, R4 PIM SPARSE MODE, and R2 join
224.2.2.2 and R4 join 224.4.4.4
Make R2 is the only one RP in these two group.
Note: I also make R3 join 224.3.3.3 for test reason !
I config R2(E0, S0) R3(E0,S0) R4(E0,S0) with ip pim sparse mode,
and put ip pim nbma-mode in Serial interface of 3 routers.
then I put send-rp-announce in R2, send-rp-discovery in R3, and
rp-accept auto-rp in R4
My config is as following:
--------------------------------
[R2]
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Ethernet0/0
ip address 137.1.62.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
ip igmp join-group 224.2.2.2
ip cgmp
ipx network 62
!
interface Serial0/0
ip address 137.1.254.2 255.255.255.248
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-multipoint
ipx network 254
frame-relay map ip 137.1.254.3 201 broadcast
frame-relay map ipx 254.0003.0003.0003 201 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
ip pim send-rp-announce Serial0/0 scope 5
---------------------------------------------------
[R3]
ip multicast-routing
ip dvmrp route-limit 20000
!
interface FastEthernet0/0
ip address 137.1.63.3 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
ip igmp join-group 224.3.3.3
ip cgmp
duplex auto
speed auto
ipx network 63
!
interface Serial0/0
ip address 137.1.254.3 255.255.255.248
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-multipoint
ipx network 254
no ipx split-horizon eigrp 1
no fair-queue
frame-relay map ip 137.1.254.2 101 broadcast
frame-relay map ip 137.1.254.4 100 broadcast
frame-relay map ipx 254.0002.0002.0002 101 broadcast
frame-relay map ipx 254.0004.0004.0004 100 broadcast
frame-relay lmi-type ansi
!
ip pim send-rp-discovery scope 5
---------------------------------------------
[R4]
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Ethernet0
ip address 150.100.2.1 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
no ip route-cache
ip igmp join-group 224.4.4.4
no ip mroute-cache
media-type 10BaseT
ipx network 99
!
interface Serial0
ip address 137.1.254.4 255.255.255.248
no ip directed-broadcast
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
no ip route-cache
ip ospf network point-to-multipoint
no ip mroute-cache
ipx network 254
frame-relay map ip 137.1.254.3 100 broadcast
frame-relay map ipx 254.0003.0003.0003 100 broadcast
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
ip pim accept-rp auto-rp
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D
After I config , I can use show ip pim rp to show the rp
R2#sh ip pim rp
Group: 224.2.2.2, RP: 137.1.254.2, v2, v1, uptime 00:00:36, expires
00:04:19
R3#sh ip pim rp
Group: 224.3.3.3, RP: 137.1.254.2, v2, v1, uptime 00:04:40, expires
00:04:19
R4#sh ip pim rp
Group: 224.4.4.4, RP: 137.1.254.2, v2, v1, uptime 00:00:29, expires
00:04:19
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D
After I ping 224.3.3.3 224.2.2.2 224.4.4.4
the rp is appear in R2 , R3 and R4 table
R3#sh ip pim rp
Group: 224.3.3.3, RP: 137.1.254.2, v2, v1, uptime 00:03:38, expires
00:03:51
R3#ping 224.3.3.3
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:
Reply to request 0 from 137.1.63.3, 8 ms
R3#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 137.1.254.2, 72 ms
R3#ping 224.4.4.4
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Reply to request 0 from 137.1.254.4, 88 ms
R3#sh ip pim rp
Group: 224.2.2.2, RP: 137.1.254.2, v2, v1, uptime 00:00:36, expires
00:04:19
Group: 224.3.3.3, RP: 137.1.254.2, v2, v1, uptime 00:04:40, expires
00:04:19
Group: 224.4.4.4, RP: 137.1.254.2, v2, v1, uptime 00:00:29, expires
00:04:19
R2#sh ip pim rp
Group: 224.2.2.2, RP: 137.1.254.2, v2, v1, next RP-reachable in 00:00:03
Group: 224.3.3.3, RP: 137.1.254.2, v2, v1, next RP-reachable in 00:01:02
Group: 224.4.4.4, RP: 137.1.254.2, v2, v1, next RP-reachable in 00:00:43
R2#=F5
CCIE_TS#4
[Resuming connection 4 to r4 ... ]
R4#sh ip pim rp
Group: 224.2.2.2, RP: 137.1.254.2, v2, v1, uptime 00:00:58, expires
00:02:24
Group: 224.3.3.3, RP: 137.1.254.2, v2, v1, uptime 00:01:06, expires
00:02:24
Group: 224.4.4.4, RP: 137.1.254.2, v2, v1, uptime 06:00:12, expires
00:02:24
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D
BUT, when I want to ping 224.2.2.2 ( R2 E0 join this group) in R4
the strange thing happened !
=3D=3D=3D=3D
R4#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
=2E
R4#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 137.1.254.2, 84 ms =3D=3D> why
R4#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Reply to request 0 from 137.1.254.2, 80 ms =3D=3D> why
R4#ping 224.2.2.2
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
=2E
I can ping to 224.2.2.2 for just twice ? I have test several times to
get ping ok twice always ! why ?
When I can ping to 224.2.2.2 , I show ip mr that :
=3D=3D
R4#sh ip mr
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
M - MSDP created entry, X - Proxy Join Timer Running
A - Advertised via MSDP
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.0.1.39), 06:08:25/00:02:54, RP 0.0.0.0, flags: DJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 224.0.1.39, Forward/Sparse, 06:08:25/00:02:53
(*, 224.0.1.40), 06:09:11/00:00:00, RP 0.0.0.0, flags: DJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 224.0.1.40, Forward/Sparse, 06:09:11/00:02:53
(137.1.254.3, 224.0.1.40), 06:08:50/00:02:24, flags: PCLT
Incoming interface: Serial0, RPF nbr 137.1.254.3
Outgoing interface list: Null
(*, 224.2.2.2), 00:00:13/00:02:59, RP 137.1.254.2, flags: SPF
Incoming interface: Serial0, RPF nbr 137.1.254.2
Outgoing interface list: Null
(150.100.2.1, 224.2.2.2), 00:00:13/00:03:19, flags: FT
Incoming interface: Ethernet0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.1.254.3, Forward/Sparse, 00:00:13/00:03:16
(*, 224.4.4.4), 06:09:15/00:00:00, RP 137.1.254.2, flags: SJCL
Incoming interface: Serial0, RPF nbr 137.1.254.2
Outgoing interface list:
Ethernet0, Forward/Sparse, 06:09:16/00:02:37
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
When I ping 224.3.3.3
sh ip mr will have :
(*, 224.3.3.3), 00:00:07/00:02:59, RP 137.1.254.2, flags: SPF
Incoming interface: Serial0, RPF nbr 137.1.254.2
Outgoing interface list: Null
(137.1.254.4, 224.3.3.3), 00:00:03/00:03:26, flags: T
Incoming interface: Serial0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0, 137.1.254.3, Forward/Sparse, 00:00:03/00:03:26
(150.100.2.1, 224.3.3.3), 00:00:07/00:02:52, flags: FT
Incoming interface: Ethernet0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial0, 137.1.254.3, Forward/Sparse, 00:00:08/00:03:25
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D
In R2, ping to 224.4.4.4, but always no response !
#show ip pim rp
(*, 224.2.2.2), 00:00:20/00:00:00, RP 137.1.254.2, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/0, Forward/Sparse, 00:00:20/00:02:57
(*, 224.3.3.3), 00:00:08/00:03:21, RP 137.1.254.2, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0/0, 137.1.254.3, Forward/Sparse, 00:00:08/00:03:21
(*, 224.4.4.4), 00:00:12/00:02:59, RP 137.1.254.2, flags: SP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
(137.1.62.2, 224.4.4.4), 00:00:12/00:02:47, flags: PTA
Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null
=3D=3D
The flags is different with ping 224.2.2.2 in R4 ?
where can I find the doc in CCO to know the meaning of flags ?
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
Is there any body can tell me , if I miss something ?
Is my config is correct and enough to the requirment as above ?
why I can't ping from spoke to spoke ?
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:59 GMT-3