[A]OSPf Demand-Circuit over ISDN DDR

From: James Chen (jr_chen@xxxxxxxxxxxxxxx)
Date: Sun Dec 03 2000 - 05:06:15 GMT-3


   
Hello, everybody:

        Finally, I got the config to work perfectly I think.
The scenario is R5 connect to R3 with ISDN, and only R5 will initial the
call to R3.
Configuration is so simple, my friend who is CCIE tell me that make it
simple,
don't think and do it too complex.
Do I decide to do it from isdn bri call setup and then add neighbor
relation and demand
circuit , finally to do the backbone configuartion, instead that config
backbone and then
backup by isdn .

1. I config ip , ppp, auth, dialer map, dialer-group, ping each other,
it's ok.
2. add router ospf , put network, add ip ospf demand-circuit , watch the
neighbor
   relation become " FULL/- ", and the dead time become " -" at last.
   And after the idle-timeout , the isdn disconnectted. Ya ! it's ok.
3.add all configuration of other backbone , it's still work properly.
4.save config and reload all routers, ya ! isdn will be disconnectted
after idle-timeout.
5.check if the backup is ok, shutdown the fa0/0 in R3 or R5, ya ! it
seems to be work.
6.After the idle-timeout, the isdn drop . however, one LSA generate and
trigger the isdn
   up again, after 120s idle-timeout, isdn disconnected and pick up
again and again.

At first, I doublt that maybe I should use dialer interface to try it .
Ya, it work properly, but has the same condition as above.
I read the groupstudy email list , it said that use "no peer
neighbor-route".
But why should the peer neighbor-route be add ?

I use debug ip ospf lsa-generation to watch what LSA is be generatted !
Yeh, there is an OSPF external Type 5 route be generatted when the isdn
grop.
I think this is because the rip will advertise the bri network into
OSPF.
The route entry that RIP inject is exactly the host-route 137.1.35.2/32,

so if I use "no peer neighbor-route" , it will not generate the route "
137.1.35.2/32 "
and will not be the entry of RIP. So that when the isdn drop, the RIP
will not
adverise the entry into OSPF, so that " THE NETWORK TOPOLOGY WILL NOT
BE CHANGED", the isdn will not be trigger up.

If any other method can make the same function of "no peer
neighbor-route",
please let me know, thanks !

I begin to believe that all the solution of CCIE Lab should be nature
and simple.
Don't think too much, right ?

James

The exactly config I have is as following:
-------------------------------------------------------------------------------
---------

Dialer Profile
----------------
[R3]
hostname R3
!
enable password cisco
!
username R5 password 0 cisco
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 137.1.3.3 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 137.1.63.3 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 137.1.254.3 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 no ip mroute-cache
 no fair-queue
 frame-relay map ip 137.1.254.2 101 broadcast
 frame-relay map ip 137.1.254.4 100 broadcast
 frame-relay lmi-type ansi
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-5ess
 ppp authentication pap
 ppp pap sent-username R3 password 7 1414110209
!
interface Dialer1
 ip address 137.1.35.1 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name R5
 dialer pool 1
 dialer-group 1
!
router ospf 1
 network 137.1.3.3 0.0.0.0 area 3
 network 137.1.35.1 0.0.0.0 area 3
 network 137.1.63.3 0.0.0.0 area 3
 network 137.1.254.3 0.0.0.0 area 0
!
ip classless
!
access-list 100 permit ip host 137.1.35.1 any log
dialer-list 1 protocol ip permit
=======================================
[R5]
hostname R5
!
enable password cisco
!
username R3 password 0 ccie
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 137.1.5.5 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 137.1.65.5 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 137.1.15.5 255.255.255.0
 no ip directed-broadcast
 ip rip send version 2
 no ip mroute-cache
 clockrate 2000000
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-5ess
 ppp authentication pap
 ppp pap sent-username R5 password 7 060506324F41
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface Dialer1
 ip address 137.1.35.2 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name R3
 dialer pool 1
 dialer string 8358661
 dialer-group 1
 no peer neighbor-route
!
router ospf 1
 redistribute rip metric 1000 subnets
 network 137.1.5.5 0.0.0.0 area 3
 network 137.1.35.2 0.0.0.0 area 3
 network 137.1.65.5 0.0.0.0 area 3
!
router rip
 redistribute ospf 1
 passive-interface FastEthernet0/0
 passive-interface Dialer1
 network 137.1.0.0
 default-information originate
!
ip classless
!
access-list 100 permit ip host 137.1.35.2 any log
dialer-list 1 protocol ip permit
---------------------------------------------------------------
legacy DDR
--------------
[R3]
hostname R3
!
enable password cisco
!
username R5 password 0 cisco
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 137.1.3.3 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 137.1.63.3 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 137.1.254.3 255.255.255.248
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 no ip mroute-cache
 no fair-queue
 frame-relay map ip 137.1.254.2 101 broadcast
 frame-relay map ip 137.1.254.4 100 broadcast
 frame-relay lmi-type ansi
!
interface BRI0/0
 ip address 137.1.35.1 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 137.1.35.2 name R5 broadcast
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication pap
 ppp pap sent-username R3 password 7 1414110209
!
router ospf 1
 network 137.1.3.3 0.0.0.0 area 3
 network 137.1.35.1 0.0.0.0 area 3
 network 137.1.63.3 0.0.0.0 area 3
 network 137.1.254.3 0.0.0.0 area 0
!
ip classless
!
access-list 100 permit ip host 137.1.35.1 any log
dialer-list 1 protocol ip permit
[R5]
hostname R5
!
logging buffered 40960 debugging
enable password cisco
!
username R3 password 0 ccie
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 137.1.5.5 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 137.1.65.5 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 137.1.15.5 255.255.255.0
 no ip directed-broadcast
 ip rip send version 2
 no ip mroute-cache
 clockrate 2000000
!
interface BRI0/0
 ip address 137.1.35.2 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf demand-circuit
 dialer map ip 137.1.35.1 name R3 broadcast 8358661
 dialer-group 1
 isdn switch-type basic-5ess
 no peer neighbor-route
 ppp authentication pap
 ppp pap sent-username R5 password 7 060506324F41
!
router ospf 1
 redistribute rip subnets
 network 137.1.5.5 0.0.0.0 area 3
 network 137.1.35.2 0.0.0.0 area 3
 network 137.1.65.5 0.0.0.0 area 3
!
router rip
 redistribute ospf 1
 passive-interface FastEthernet0/0
 passive-interface BRI0/0
 network 137.1.0.0
 default-information originate
!
ip classless
!
access-list 100 permit ip host 137.1.35.2 any log
dialer-list 1 protocol ip permit

begin:vcard
n:Chen;James
tel;fax:886-2-27880815
tel;work:886-2-26512340
x-mozilla-html:FALSE
url:http://freebsd.ringline.com.tw
org:RingLine Corp.;Engineering Division
adr:;;B1, 99-1, Nankang Rd., Sec. 2, ;Taipei;Taiwan;115;R.O.C.
version:2.1
email;internet:jr_chen@ringline.com.tw
title:System Engineer
fn:James Chen
end:vcard



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:58 GMT-3