Fatkid lab for Advance OSPF

From: peter brown (pita40@xxxxxxxxxxx)
Date: Sat Dec 02 2000 - 18:11:14 GMT-3


   
I have configured the fatkid lab for ospf. What I find is that the Bri0 on
either router R3 or R2 does not come up when th frame connection on s0
fails. I also find that I cannot ping any of the route that shows up as
directly connected. take a look at the config and debug below. Please
help.Take a look at the sho ip ro on R2 below. Also take a look at the sh
dialer on R2 and R3. It shows connected. But a ping does not work.

What I am missing.

hostname R1
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
!
!
interface TokenRing0/0
no ip address
no ip directed-broadcast
ring-speed 16
shutdown
!
interface Serial1/0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 103 interface Serial1/1 102
frame-relay route 104 interface Serial1/2 102
no shutdown
!
interface Serial1/1
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
clockrate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial1/0 103
frame-relay route 104 interface Serial1/2 103
no shutdown
!
interface Serial1/2
no ip address
no ip directed-broadcast
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial1/0 104
frame-relay route 103 interface Serial1/1 104
no shutdown
!
interface Serial1/3
no ip address
no ip directed-broadcast
shutdown
!
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

! R2 *******************************

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable password cisco
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 200.100.100.1 255.255.255.248
no ip directed-broadcast
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
ip address 212.1.22.1 255.255.255.240
no ip directed-broadcast
encapsulation frame-relay
ip ospf authentication-key cisco
ip ospf network broadcast
ip ospf priority 200
no ip mroute-cache
no fair-queue
cdp enable
frame-relay map ip 212.1.22.2 103 broadcast
frame-relay map ip 212.1.22.3 104 broadcast
no frame-relay inverse-arp
no shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
ip address 212.1.22.19 255.255.255.240
no ip directed-broadcast
encapsulation ppp
ip ospf authentication-key cisco
ip ospf cost 500
ip ospf demand-circuit
dialer map ip 212.1.22.18 broadcast 3014392844
dialer idle-timeout 1 either
dialer-group 1
isdn spid1 30140802680101 4080268
isdn spid2 30140802690101 4080269
ppp multilink
no shutdown
!
router ospf 1
network 200.100.100.0 0.0.0.7 area 2
network 212.1.22.0 0.0.0.15 area 0
network 212.1.22.16 0.0.0.15 area 0
area 0 authentication
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

! R3 *******************************

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
interface Loopback0
ip address 200.100.100.9 255.255.255.248
no ip directed-broadcast
!
interface Serial0
ip address 212.1.22.2 255.255.255.240
no ip directed-broadcast
encapsulation frame-relay
ip ospf authentication-key cisco
ip ospf network broadcast
ip ospf priority 0
no ip mroute-cache
no fair-queue
cdp enable
frame-relay map ip 212.1.22.1 102 broadcast
frame-relay map ip 212.1.22.3 102 broadcast
no frame-relay inverse-arp
frame-relay lmi-type cisco
no shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
ip address 212.1.22.18 255.255.255.240
ip directed-broadcast
encapsulation ppp
ip ospf authentication-key cisco
ip ospf cost 500
ip ospf demand-circuit
dialer map ip 212.1.22.19 broadcast 3014080268
dialer idle-timeout 1 either
dialer-group 1
isdn spid1 30143928440101 4392844
isdn spid2 30143928450101 4392845
ppp multilink
no shutdown
!
router ospf 1
network 200.100.100.8 0.0.0.7 area 3
network 212.1.22.0 0.0.0.15 area 0
network 212.1.22.16 0.0.0.15 area 0
area 0 authentication
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

! R4 *******************************

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
enable password cisco
!
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 200.100.100.17 255.255.255.248
no ip directed-broadcast
!
interface fa0/0
ip address 212.1.22.130 255.255.255.192
no ip directed-broadcast
no shutdown
!
interface Serial0/0
ip address 212.1.22.3 255.255.255.240
no ip directed-broadcast
encapsulation frame-relay
ip ospf authentication-key cisco
ip ospf network broadcast
ip ospf priority 0
no ip mroute-cache
cdp enable
frame-relay map ip 212.1.22.1 102 broadcast
frame-relay map ip 212.1.22.2 102 broadcast
no frame-relay inverse-arp
no shutdown

!
router ospf 1
network 200.100.100.16 0.0.0.15 area 4
network 212.1.22.0 0.0.0.15 area 0
network 212.1.22.128 0.0.0.63 area 1
area 0 authentication
area 1 virtual-link 212.1.22.65 authentication-key cisco
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

! R5 *******************************

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
enable password cisco
!
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 212.1.22.65 255.255.255.224
no ip directed-broadcast
!
interface Loopback1
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback2
ip address 20.1.2.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback3
ip address 20.1.3.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 212.1.22.129 255.255.255.192
no ip directed-broadcast
no shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 20.1.1.0 0.0.0.255 area 5
network 20.1.2.0 0.0.0.255 area 5
network 20.1.3.0 0.0.0.255 area 5
network 212.1.22.64 0.0.0.31 area 5
network 212.1.22.128 0.0.0.63 area 1
area 0 authentication
area 1 virtual-link 200.100.100.17 authentication-key cisco
area 5 range 20.1.0.0 255.255.0.0
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

R2#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
3014392844 21 12 00:07:38 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (1 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: ip (s=212.1.22.19, d=224.0.0.5)
Connected to 3014392844 (R3)

BRI0:2 - dialer type = ISDN
Idle timer (1 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

R3#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
3014080268 8 6 00:09:04 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (1 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0:2 - dialer type = ISDN
Idle timer (1 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Connected to 3014080268 (R2)
R3#

R2#debug dialer packet
Dial on demand packets debugging is on
R2#ping 212.1.22.18

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 212.1.22.18, timeout is 2 seconds:

00:35:32: BRI0 DDR: ip (s=212.1.22.19, d=212.1.22.18), 100 bytes, outgoing
inter
esting (ip PERMIT).
00:35:33: BRI0 DDR: cdp, 270 bytes, outgoing uninteresting (no list matched)
00:35:33: BRI0 DDR: sending broadcast to ip 212.1.22.18 -- failed, not
connected

00:35:34: BRI0 DDR: ip (s=212.1.22.19, d=224.0.0.5), 64 bytes, outgoing
interest
ing (ip PERMIT)
00:35:34: BRI0 DDR: sending broadcast to ip 212.1.22.18 -- failed, not
connected

00:35:34: BRI0 DDR: ip (s=212.1.22.19, d=212.1.22.18), 100 bytes, outgoing
inter
esting (ip PERMIT).
00:35:36: BRI0 DDR: ip (s=212.1.22.19, d=212.1.22.18), 100 bytes, outgoing
inter
esting (ip PERMIT).
00:35:38: BRI0 DDR: ip (s=212.1.22.19, d=212.1.22.18), 100 bytes, outgoing
inter
esting (ip PERMIT).
00:35:40: BRI0 DDR: ip (s=212.1.22.19, d=212.1.22.18), 100 bytes, outgoing
inter
esting (ip PERMIT).
Success rate is 0 percent (0/5)
R2#
00:35:44: BRI0 DDR: ip (s=212.1.22.19, d=224.0.0.5), 64 bytes, outgoing
interest
ing (ip PERMIT)
00:35:44: BRI0 DDR: sending broadcast to ip 212.1.22.18 -- failed, not
connected

00:35:54: BRI0 DDR: ip (s=212.1.22.19, d=224.0.0.5), 64 bytes, outgoing
interest
ing (ip PERMIT)
00:35:54: BRI0 DDR: sending broadcast to ip 212.1.22.18 -- failed, not
connected

00:36:04: BRI0 DDR: ip (s=212.1.22.19, d=224.0.0.5), 64 bytes, outgoing
interest
ing (ip PERMIT)
00:36:04: BRI0 DDR: sending broadcast to ip 212.1.22.18 -- failed, not
connected

R2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     20.0.0.0/16 is subnetted, 1 subnets
O IA 20.1.0.0 [110/66] via 212.1.22.3, 00:00:37, Serial0
     200.100.100.0/24 is variably subnetted, 3 subnets, 2 masks
O IA 200.100.100.9/32 [110/65] via 212.1.22.2, 00:00:37, Serial0
C 200.100.100.0/29 is directly connected, Loopback0
O IA 200.100.100.17/32 [110/65] via 212.1.22.3, 00:00:37, Serial0
     212.1.22.0/24 is variably subnetted, 5 subnets, 3 masks
O IA 212.1.22.128/26 [110/65] via 212.1.22.3, 00:00:38, Serial0
O IA 212.1.22.65/32 [110/66] via 212.1.22.3, 00:00:38, Serial0
C 212.1.22.0/28 is directly connected, Serial0
C 212.1.22.18/32 is directly connected, BRI0
C 212.1.22.16/28 is directly connected, BRI0
R2#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:57 GMT-3