From: Sam Munzani (sam@xxxxxxxxxxx)
Date: Thu Nov 16 2000 - 15:00:50 GMT-3
If I understand your question.
1. You want to filter routes comming from AS 254 so that AS1 only gets
197.65.4.0/24 subnet.
2. Now you want to set local preference to 300 for the 197.65.5.0/24
On R4:
access-list 1 deny 150.200.1.0 0.0.255.255
access-list 1 permit any
route-map deny-150 permit 10
match ip addr 1
router bgp 1
neigh xxx.xxx.xxx.254 route-map deny-150 in
(This will filter 150.200.1.0 comming in )
Now setting up local preference,
access-list 2 permit 197.65.4.0 0.0.0.255
route-map local-300 permit 10
match ip addr 2
set local 300
router bgp 1
neigh xxx.xxx.xxx.254 route-map local-300 in
This will achieve the goals defined above. If your goals are different this
may not work.
Sam
> ExtRouter--------------------------R4-----------------------------R5
> EBGP----------------------------EBGP/IBGP-----------------------IBGP
> AS254-----------------------------AS1----------------------------AS1
> 197.65.5.0 advertised only wants 197
> 150.200.1.0 advertised doesn't want 150
>
> If anyone can understand the diag above, this is what I am trying to
> achieve. An external AS (254) is advertising routes 197.65.5.0/24 &
> 150.200.1.0/24 to my AS#1. I receive these on R4 and pass them through
> to R5 through IBGP, fine.
>
> What I am having trouble doing though is, I want to block the 150
> updates on the interface (eth0) or in the bgp routing process by either
> using a distribute list, route map, ip access-group or whatever. Then
> once the 150 route is filtered out and the 197 route is in the routing
> table of R4 I want to set it's local preference and weight to 300, so
> that when it is shown in R5's table these metrics are seen.
>
> I have tried for the last two days using a combination of the following
> commands and refering to Caslow and Hutnik, but still no joy. If anyone
> can help I would appreciate it.
>
> Thanks in advance.
>
> Eddie.
>
> P.S. Where is there a good reference list for regular expressions?
>
> Some commands tried below (in no particular order)..............
>
> route-map bgp
> set local-preference 300
> set weight 300
> match ip address 100
>
> route-map bgpin permit 1
> match ip address 100
>
> access-list 100 permit tcp 197.65.5.0 0.0.0.255 eq bgp any
>
> ip access-group 100 in
> distribute-list 100 in/out
>
> route-map AS254 permit 10
> match as-path 1
> set local-preference 300
> set weight 300
>
> ip as-path access-list 1 permit _254$
> ip as-path access-list 1 permit 254$
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:45 GMT-3