From: radha rani (radhaccie@xxxxxxxxxxx)
Date: Wed Nov 01 2000 - 15:56:03 GMT-3
Okay, SRB is working now. Here's what I had to do:
1. Disable ip routing on R4. Until I did that, R1 could not get a reply
when it arp'd for R3's mac address. That's because R4 was routing ip and
considered R1 & R3 to be on a common subnet so it did not reply via
proxy-arp. Debug arp showed no reply to the arp request and a debug ip
packets on R1 generated 'encapsulation failed' messages.
2. Add 'multiring ip' on R1 & R3's TR interfaces
3. Add 'multiring all' on both TR ints on R4 (although 'multiring ip' should
also suffice since I only configured ip)
4. Adding 'source-bridge ring-group xxx' globally in NOT necessary as R4 is
only a two-port bridge. (I did try it with this comand and it worked).
Here are my working configs. I'm off to try RSRB next. Thanks for the help
everyone.
R1 (ip host):
r1#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r1
!
!
no ip routing
no ip domain-lookup
!
interface Serial0
no ip address
no ip route-cache
shutdown
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
interface TokenRing0
ip address 10.10.1.1 255.255.255.0
no ip route-cache
ring-speed 16
multiring ip
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
end
R4 (Source-Route-Bridge):
r4#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r4
!
!
no ip routing
!
interface Serial0
no ip address
no ip route-cache
shutdown
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
interface TokenRing0
no ip address
no ip route-cache
ring-speed 16
multiring all
source-bridge 100 1 300
source-bridge spanning
!
interface TokenRing1
no ip address
no ip route-cache
ring-speed 16
multiring all
source-bridge 300 1 100
source-bridge spanning
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
end
R3 (ip host) :
r3#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r3
!
!
no ip routing
!
interface Ethernet0
no ip address
no ip route-cache
shutdown
!
interface Serial0
no ip address
no ip route-cache
shutdown
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
interface TokenRing0
ip address 10.10.1.3 255.255.255.0
no ip route-cache
ring-speed 16
multiring ip
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
end
r3#
>From: "yujianchun" <stiff.yu@datacraft-asia.com>
>Reply-To: "yujianchun" <stiff.yu@datacraft-asia.com>
>To: "radha rani" <radhaccie@hotmail.com>, <ccielab@groupstudy.com>
>Subject: Re:
>Date: Wed, 1 Nov 2000 17:52:38 +0800
>
>can you tell result? I wait for you.
>-----Original Message-----
>From: radha rani <radhaccie@hotmail.com>
>To: ccielab@groupstudy.com <ccielab@groupstudy.com>
>Date: 28 October 2000 06:43
>
>
> >Hello,
> > I have a very simple SRB configuration which is not working. I
> >would be very grateful if someone could shed some light on this.
> >
> >My topology is :
> >
> >r1 --- ring100---r4---ring300---r3
> >
> >r1 and r3 are acting as hosts and have ip addresses 10.10.1.1/24 and
> >10.10.1.3/24 resp. r4 is the source-route-bridge. I am unable to ping
> >r1 and r3 from each other.
> >
> >Thanks for your help.
> >
> >R4's config is as follows:
> >
> >r4#sh run
> >Building configuration...
> >
> >Current configuration:
> >!
> >version 11.2
> >no service password-encrypt
> >no service udp-small-server
> >no service tcp-small-server
> >!
> >hostname r4
> >!
> >!
> >!
> >interface Serial0
> >no ip address
> >shutdown
> >!
> >interface Serial1
> >no ip address
> >shutdown
> >!
> >interface TokenRing0
> >no ip address
> >ring-speed 16
> >source-bridge 100 1 300
> >!
> >interface TokenRing1
> >no ip address
> >ring-speed 16
> >source-bridge 300 1 100
> >!
> >no ip classless
> >!
> >!
> >line con 0
> >line aux 0
> >line vty 0 4
> >login
> >!
> >end
> >
> >r4#
> >
> >-Radha
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:39 GMT-3