RE: lane

From: Johnson, Charles (Charles.Johnson@xxxxxxxxxx)
Date: Sun Oct 01 2000 - 13:59:45 GMT-3


   
Aaron,
Over a month later, I'm sure you have this all worked out, but here's my $.02.

You would use the auto-config-atm-address command in the subinterface if you wa
nted to override the LECS address your 7200 was learning from the switch via IL
MI. If the switch had an old "atm lecs-address-default" statement that didn't
match what you had set up, you might need that subinterface command.

I found an example in the command reference:

The following example causes the LANE server and LANE client on the subinterfac
e to use the automatically assigned ATM address to communicate
with the configuration server:

interface atm 2/0.1
  ip address 172.16.0.4 255.255.255.0
  lane client ethernet
  lane server-bus ethernet eng
  lane auto-config-atm-address

Charles

-----Original Message-----
From: Aaron DuShey [mailto:aaron.dushey@dushey-consulting.com]
Sent: Saturday, August 26, 2000 6:35 PM
To: CCIE (E-mail)
Subject: lane

I'm confused. In all the doc's I have read, you don't need to enter the lane
auto-config-atm-address command in the subinterface, yet, when I don't, my
LEC won't come up? Any hints here?

thanks
Non-working config
r7(config)#int atm4/0.1
r7(config-subif)#no lane auto-config-atm-address
r7(config-subif)#end
00:11:19: %LANE-5-UPDOWN: ATM4/0.1 elan elan1: LE Server/BUS changed state
to do
wn
00:11:19: %LANE-5-UPDOWN: ATM4/0.1 elan elan1: LE Client changed state to
down
00:11:19: %LANE-5-UPDOWN: ATM4/0.1 elan elan1: LE Server/BUS changed state
to up
r7#
00:11:20: %SYS-5-CONFIG_I: Configured from console by console
r7#sh lane default
interface ATM4/0:
LANE Client: 47.00918100000000100745B101.00107967AC70.**
LANE Server: 47.00918100000000100745B101.00107967AC71.**
LANE Bus: 47.00918100000000100745B101.00107967AC72.**
LANE Config Server: 47.00918100000000100745B101.00107967AC73.00
note: ** is the subinterface number byte in hex

r7#

interface ATM4/0
 no ip address
 no ip directed-broadcast
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 no atm ilmi-keepalive
 lane config auto-config-atm-address
 lane config database ccie
 lane auto-config-atm-address
!
interface ATM4/0.1 multipoint
 no ip directed-broadcast
 lane server-bus ethernet elan1
 lane client ethernet elan1

Working config-
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
boot system flash slot0:c7200-js-mz.120-6.bin
!
ip subnet-zero
no ip domain-lookup
!
lane database ccie
  name elan1 server-atm-address 47.00918100000000100745B101.00107967AC71.01
!
!
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/3
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet2/0
 no ip address
 no ip directed-broadcast
!
interface Ethernet2/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 no atm ilmi-keepalive
 lane config auto-config-atm-address
 lane config database ccie
 lane auto-config-atm-address
!
interface ATM4/0.1 multipoint
 no ip directed-broadcast
 lane auto-config-atm-address
 lane server-bus ethernet elan1
 lane client ethernet elan1
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r7#sh lane client
LE Client ATM4/0.1 ELAN name: elan1 Admin: up State: operational
Client ID: 1 LEC up for 22 seconds
ELAN ID: 0
Join Attempt: 12
Last Fail Reason: Config VC being released
HW Address: 0010.7967.ac70 Type: ethernet Max Frame Size: 1516
ATM Address: 47.00918100000000100745B101.00107967AC70.01

 VCD rxFrames txFrames Type ATM Address
   0 0 0 configure
47.00918100000000100745B101.00107967AC73.00
   8 1 2 direct
47.00918100000000100745B101.00107967AC71.01
   9 1 0 distribute
47.00918100000000100745B101.00107967AC71.01
  12 0 4 send
47.00918100000000100745B101.00107967AC72.01
  13 1 0 forward
47.00918100000000100745B101.00107967AC72.01

r7#

Aaron DuShey



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:22 GMT-3