LEC not using LECS (Don't get too excited!)

From: Mark Lewis (markl11@xxxxxxxxxxx)
Date: Fri Sep 29 2000 - 07:12:19 GMT-3


   

Hi,

Here're the config.s of two LECs (small s) not using a LECS. Don't get too
excited, as far as I'm aware, the LES still needs to register with it,but...

Look at the output of 'show lane client' on both boxes - notice the zeros
0000000000000000 where it says TYPE configure (configure direct svc from LEC
to LECS (usually)). The LEC is going straight to the LES.
Note on the second LEC (R14) I didn't specify a BUS (the LES supplies the
address for that).

Now, tantilizingly, in Caslow book (pg.270) he says, 'A LECS is optional.It
is an administrative tool.'

Interaction between the LES & LECS in my scenario is I believe for security
(remember restricted elans!).The LES checks with the LECS to see if the LEC
is allowed to join (could be wrong).

Mark

R13#
R13#
R13#
R13#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R13
!
!
!
!
!
!
ip subnet-zero
!
!
lane database CCIE
  name elan1 server-atm-address 47.00918100000000D0BAF33B01.00107BA3A701.01
cns event-service server
!
!
!
!
!
!
!
!
interface ATM0/0
no ip address
no ip directed-broadcast
atm pvc 1 0 5 qsaal
atm pvc 2 0 16 ilmi
no atm ilmi-keepalive
lane config auto-config-atm-address
lane config database CCIE
!
interface ATM0/0.1 multipoint
ip address 10.1.1.13 255.255.255.0
no ip directed-broadcast
lane client-atm-address 47.00918100000000D0BAF33B01.00107BA3A700.01
lane server-atm-address 47.00918100000000D0BAF33B01.00107BA3A701.01
lane bus-atm-address 47.00918100000000D0BAF33B01.00107BA3A702.01
lane server-bus ethernet elan1
lane client ethernet elan1
!
interface FastEthernet1/0
no ip address
no ip directed-broadcast
shutdown
duplex auto
speed auto
!
interface Ethernet2/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

R13#
R13#
R13#sh lane client
LE Client ATM0/0.1 ELAN name: elan1 Admin: up State: operational
Client ID: 1 LEC up for 5 minutes 48 seconds
ELAN ID: 0
Join Attempt: 11
Known LE Servers: 1
Last Fail Reason: Timeout on join request
HW Address: 0010.7ba3.a700 Type: ethernet Max Frame Size: 1516
ATM Address: 47.00918100000000D0BAF33B01.00107BA3A700.01
VCD rxFrames txFrames Type ATM Address
   0 0 0 configure
00.000000000000000000000000.000000000000.00
273 1 5 direct
47.00918100000000D0BAF33B01.00107BA3A701.01
276 8 0 distribute
47.00918100000000D0BAF33B01.00107BA3A701.01
277 0 11 send
47.00918100000000D0BAF33B01.00107BA3A702.01
280 10 0 forward
47.00918100000000D0BAF33B01.00107BA3A702.01
377 9 7 data
47.00918100000000D0BAF33B01.00107B8FE780.01

R13#
R13#
R13#
R13#ping 10.1.1.14

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R13#
R13#
R13#
R13#
R13#
R13#
R13#

R14>
R14>en
R14#
R14#
R14#
R14#
R14#
R14#
R14#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R14
!
no logging console
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
!
!
!
interface ATM0/0
no ip address
no ip directed-broadcast
atm pvc 1 0 5 qsaal
atm pvc 2 0 16 ilmi
no atm ilmi-keepalive
!
interface ATM0/0.1 multipoint
ip address 10.1.1.14 255.255.255.0
no ip directed-broadcast
lane client-atm-address 47.00918100000000D0BAF33B01.00107B8FE780.01
lane server-atm-address 47.00918100000000D0BAF33B01.00107BA3A701.01
lane client ethernet elan1
!
interface FastEthernet1/0
no ip address
no ip directed-broadcast
shutdown
--More-- Translating "R14"
duplex auto
speed auto
!
interface Serial2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial2/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/3
no ip address
no ip directed-broadcast
shutdown
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

R14#
R14#
R14#
R14#
R14#
R14#sh lane client
LE Client ATM0/0.1 ELAN name: elan1 Admin: up State: operational
Client ID: 2 LEC up for 5 minutes 14 seconds
ELAN ID: 0
Join Attempt: 12
Known LE Servers: 1
Last Fail Reason: Timeout on join request
HW Address: 0010.7b8f.e780 Type: ethernet Max Frame Size: 1516
ATM Address: 47.00918100000000D0BAF33B01.00107B8FE780.01
VCD rxFrames txFrames Type ATM Address
   0 0 0 configure
00.000000000000000000000000.000000000000.00
  26 1 5 direct
47.00918100000000D0BAF33B01.00107BA3A701.01
  27 7 0 distribute
47.00918100000000D0BAF33B01.00107BA3A701.01
  28 0 10 send
47.00918100000000D0BAF33B01.00107BA3A702.01
  29 9 0 forward
47.00918100000000D0BAF33B01.00107BA3A702.01
  30 12 14 data
47.00918100000000D0BAF33B01.00107BA3A700.01

R14#
R14#
R14#
R14#ping 10.1.1.13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R14#
R14#
R14#
R14#
R14#
R14#
R14#
R14#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:09 GMT-3