TA-DAH!!! ATM SVCS WITH NO ILMI!!!!!!

From: Mark Lewis (markl11@xxxxxxxxxxx)
Date: Thu Sep 28 2000 - 18:28:06 GMT-3


   

Hi all,

Well, after a bit of experimentation and a rummage around the ATM docs,here
is the solution to ATM SVCs without ilmi:

(Topology is just: R13----LS----R14)

R13#
R13#
R13#
R13#
R13#
R13#
R13#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R13
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
!
!
!
interface ATM0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
map-group r14map
atm nsap-address 47.00918100000000D0BAF33B01.888888888813.00
atm pvc 1 0 5 qsaal
no atm ilmi-keepalive
!
interface FastEthernet1/0
no ip address
no ip directed-broadcast
shutdown
duplex auto
speed auto
!
interface Ethernet2/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
ip classless
no ip http server
!
!
map-list r14map
ip 10.1.1.2 atm-nsap 47.00918100000000D0BAF33B01.888888888814.00
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

R13#
R13#sh atm ilmi-status

Interface : ATM0/0 Interface Type : Private UNI (User-side)
ILMI VCC : (0, 16) ILMI Keepalive : Disabled
ILMI State: Restarting
R13#
R13#
R13#
R13#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R13#
R13#
R13#
R13#
R13#

R14#
R14#
R14#
R14#
R14#
R14#
R14#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R14
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
!
!
!
interface ATM0/0
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
map-group r13map
atm nsap-address 47.00918100000000D0BAF33B01.888888888814.00
atm pvc 1 0 5 qsaal
no atm ilmi-keepalive
!
interface FastEthernet1/0
no ip address
no ip directed-broadcast
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial2/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/3
no ip address
no ip directed-broadcast
shutdown
!
ip classless
no ip http server
!
!
map-list r13map
ip 10.1.1.1 atm-nsap 47.00918100000000D0BAF33B01.888888888813.00
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

R14#
R14#
R14#
R14#
R14#sh atm ilmi-status

Interface : ATM0/0 Interface Type : Private UNI (User-side)
ILMI VCC : (0, 16) ILMI Keepalive : Disabled
ILMI State: Restarting
R14#
R14#
R14#
R14#
R14#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R14#
R14#
R14#
R14#
R14#
R14#
R14#
R14#
R14#
R14#

ls1010>
ls1010>
ls1010>en
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ls1010
!
!
ip subnet-zero
!
atm lecs-address-default 47.0091.8100.0000.00d0.baf3.3b01.0010.7ba3.a703.00
1
atm lecs-address-default 47.0091.8100.0000.00d0.baf3.3b01.0010.7b8f.e783.00
2
atm address 47.0091.8100.0000.00d0.baf3.3b01.00d0.baf3.3b01.00
atm router pnni
no aesa embedded-number left-justified
node 1 level 56 lowest
  redistribute atm-static
!
!
process-max-time 200
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
no atm auto-configuration
no atm ilmi-keepalive
atm uni version 4.0
atm maxvpi-bits 4
atm maxvci-bits 10
!
interface ATM0/1/1
no ip address
no ip directed-broadcast
no atm auto-configuration
no atm ilmi-keepalive
atm uni version 4.0
atm maxvpi-bits 4
atm maxvci-bits 10
atm pvc 0 50 interface ATM0/1/0 5 255
atm pvc 4 44 interface ATM0/1/0 5 55
!
interface ATM0/1/2
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
atm pvc 0 255 interface ATM0/1/1 0 45
!
interface ATM0/1/3
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/0/0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/0/1
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/0/2
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/0/3
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/1/0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/1/1
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/1/2
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM1/1/3
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM2/0/0
no ip address
no ip directed-broadcast
atm maxvp-number 0
!
interface Ethernet2/0/0
no ip address
no ip directed-broadcast
!
ip classless
!
atm route 47.0091.8100.0000.00d0.baf3.3b01.8888.8888.8814... ATM0/1/0
atm route 47.0091.8100.0000.00d0.baf3.3b01.8888.8888.8813... ATM0/1/1
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

ls1010#sh atm route

Codes: P - installing Protocol (S - Static, P - PNNI, R - Routing control),
       T - Type (I - Internal prefix, E - Exterior prefix, SE -
                 Summary Exterior prefix, SI - Summary Internal prefix,
                 ZE - Suppress Summary Exterior, ZI - Suppress Summary
Internal)

P T Node/Port St Lev Prefix
~ ~~ ~~~~~~~~~~~~~~~~ ~~ ~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
P SI 1 0 UP 0 47.0091.8100.0000.00d0.baf3.3b01/104
R I 1 ATM2/0/0 UP 0
47.0091.8100.0000.00d0.baf3.3b01.00d0.baf3.3b01/152
R I 1 ATM2/0/0 UP 0 47.0091.8100.0000.00d0.baf3.3b01.4000.0c/128
S E 1 ATM0/1/1 UP 0
47.0091.8100.0000.00d0.baf3.3b01.8888.8888.8813/152
S E 1 ATM0/1/0 UP 0
47.0091.8100.0000.00d0.baf3.3b01.8888.8888.8814/152

ls1010#
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#
ls1010#

Sorry about all the config, but you need to see all to believe!!!

By the way, the crucial part of the config apart from the two static routes
is the 'no atm auto-configuration' on the first two int.s.
If you don't have that, then the routes appear int the routing table, but
the status (ST) is down (DN) and nothing works.

The 'no atm auto-configuration' command requires a quick shut/no shut on the
int.s.

Phew, the was well worth the wait, wasn't it ???!!!

Mark Lewis



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:08 GMT-3