From: Kevin Baumgartner (kbaumgar@xxxxxxxxx)
Date: Thu Sep 21 2000 - 16:09:19 GMT-3
The network 172.17.59.0 is not a classful address. Igrp will not use this
as a default route. For IGRP to use a canidate route it must be
a classful route and not subnetted.
Try creating a classful address using a null0 route
and then defining it on igrp.
So for example
ip route 10.0.0.0 255.0.0.0 null0
router igrp 100
network 10.0.0.0
ip default-network 10.0.0.0
Kevin
At 10:20 AM 9/21/00 -0400, you wrote:
>Hi,
>
>Can anyone post configs for the ip default-network method. I cannot seem to fi
gure it out. Thanks.
>
>I re-read Caslow and he gives two options to solve this problem: summarization
with a static to null 0 and using ip defulat-network with ip-classless. I got
the first to work in the lab, no problem. The second however is causing me prob
lems.
>
>I tried to make an ip default-network to 172.17.59.0 on the router a, but what
I got in the config was a static route:
>
>router igrp 100
> redistribute ospf 1 metric 64 10 255 1 1500
> passive-interface Loopback5
> network 172.17.0.0
>!
>ip classless
>ip route 172.17.0.0 255.255.0.0 172.17.59.0
>
>Then I tried to make and ip default-network to 172.17.0.0. now I have a candid
ate default route in my routing table on router a, but
>router b is not getting the default-route and I can still not get to the 172.1
7.59.0 networks in ospf:
>version 11.2
>no service udp-small-servers
>no service tcp-small-servers
>!
>hostname r1
>!
>!
>no ip domain-lookup
>!
>interface Loopback0
> ip address 1.1.1.1 255.255.255.0
>!
>interface Loopback1
> ip address 172.17.59.33 255.255.255.240
>!
>interface Loopback2
> ip address 172.17.59.49 255.255.255.240
>!
>
>interface Loopback3
> ip address 172.17.59.65 255.255.255.192
>
>interface Loopback5
> ip address 172.17.45.1 255.255.255.0
>!
>interface Ethernet0
> no ip address
> shutdown
>!
>interface Serial0
> ip address 172.17.60.2 255.255.255.0
>!
>interface Serial1
> ip address 193.1.1.1 255.255.255.0
>!
>interface BRI0
> no ip address
> shutdown
>!
>router ospf 1
> redistribute igrp 100 metric 64 subnets
> network 172.17.59.32 0.0.0.15 area 0
> network 172.17.59.48 0.0.0.15 area 2
> network 172.17.59.64 0.0.0.63 area 3
>!
>router igrp 100
> redistribute ospf 1 metric 64 10 255 1 1500
> network 172.17.0.0
>!
>ip classless
>ip default-network 172.17.0.0
>!
>line con 0
>line aux 0
>
>line vty 0
>
>line vty 1 4
>!
>end
>
>
>routing table on router a:
>Gateway of last resort is not set
>
> 1.0.0.0/24 is subnetted, 1 subnets
>C 1.1.1.0 is directly connected, Loopback0
> * 172.17.0.0/16 is variably subnetted, 5 subnets, 3 masks
>C 172.17.60.0/24 is directly connected, Serial0
>C 172.17.45.0/24 is directly connected, Loopback5
>C 172.17.59.32/28 is directly connected, Loopback1
>C 172.17.59.48/28 is directly connected, Loopback2
>C 172.17.59.64/26 is directly connected, Loopback3
>C 193.1.1.0/24 is directly connected, Serial1
>
>routing table on router b:
>
>
>Gateway of last resort is not set
>
> 172.17.0.0/24 is subnetted, 2 subnets
>C 172.17.60.0 is directly connected, Serial0
>I 172.17.45.0 [100/8976] via 172.17.60.2, 00:00:12, Serial0
>
>I put the 172.17.45.0 loopback interface on router a, just to make sure I was
getting routes distributed via IGRP.
>
>Can anyone post configs that work for the ip default-network method.
>
>Thanks Julie Ann
>
>
>At 04:52 PM 9/20/2000 -0700, mark salmon wrote:
>>I still disagree with the blanket statement about static routes. If you
>>want to summarize OSPF you have to use static routes (null 0). I still
>>believe that you can do so as long as you are using summarization.
>>
>>One method that is recommended by Caslow is to use a static route to
>>null 0 with the same mask as the IGRP net.
>>
>>For example, suppose the masks on the IGRP networks is /24, but it
>>varies on the OSPF net.
>>
>>On the ASBR, you can do 172.17.x.0 255.255.255.0 null 0 (be careful
>>here, if you have a dynamic route for x you will pass packets into a
>>black hole, the key is to have good network design to prevent this). If
>>you already have a 172.17.x.0/24 network, then I would create a class c
>>subnet (e.g. 198.135.244.1/24) on a loopback interface, either
>>redistribute it into IGRP or advertise it in IGRP. Then make it the
>>default network for IGRP.
>>
>>Comments group (Flame jacket on for this).
>>Mary Weidner wrote:
>> >
>> > All,
>> >
>> > I am working on a practice lab on one of the midwest channels racks and am
having a problem with redistribution. Here's a sample config:
>> >
>> > Router A
>> > !
>> > router ospf 100
>> > network 172.17.59.32 0.0.0.15 area 0
>> > network 172.17.59.48 0.0.0.15 area 2
>> > network 172.17.59.64 0.0.0.63 area 3
>> > redistribute igrp 100 metric 64 subnets
>> > !
>> > router igrp 100
>> > network 172.17.0.0
>> > redistribute ospf 100 metric 64 10 255 1 1500
>> >
>> > Router B
>> > !
>> > router igrp 100
>> > network 172.17.0.0
>> > !
>> >
>> > Here's the deal, IGRP does not understand VLSM which is what is being used
on router A with OSPF. From all the docs I've read, you would have to put in s
tatic routes on Router B to tell it how to get to those other subnets, except I
'm not allowed to use static routes. The subnets in OSPF on Router A are not re
distributing into IGRP. They come out as 172.17.0.0 instead of whatever the rea
l network number is.
>> >
>> > Here's the other thing I tried; I added these lines:
>> >
>> > Router A
>> > !
>> > router ospf 100
>> > default-information originate always
>> > !
>> > router igrp 100
>> > default-information allowed in 1
>> > default-information allowed out 1
>> > !
>> > access-list 1 permit any
>> >
>> > Router B
>> > !
>> > router igrp 100
>> > default-information allowed in 1
>> > !
>> > access-list 1 permit any
>> >
>> > The thinking here was to originate a default route (0.0.0.0) from Router A
in OSPF and try to redistribute this into IGRP..... it didn't work. Maybe I ju
st configured it wrong or maybe it's just not possible. I don't know. This is t
he second time I've attempted to get this working to no avail. Let me know if y
ou have any ideas.
>> >
>> > Thanks,
>> >
>> > Tony Olzak
>> >
>> > BTW-I've just joined the list. I'm scheduled to take the test on Nov 19-20
in RTP.
>> >
>> >
>> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:00 GMT-3