ISIS summary-address question

From: Ryan Hoffman (ryan.hoffman@xxxxxxxxx)
Date: Tue Sep 12 2000 - 08:51:17 GMT-3


   
Anyone know of a way to have ISIS-summarized routes to override more
specific routes?

     e0 e1 e0 e0
2514 ----- 4000 ----- 2514
 r9 r11 r10

r9
==
ip subnet-zero
ip classless
!
interface Loopback1
 ip address 192.168.0.129 255.255.255.128
 ip router isis
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.128 secondary
 ip address 192.168.1.129 255.255.255.128
 ip router isis
 isis metric 5 level-1
!
router isis
 summary-address 192.168.0.0 255.255.255.0 level-1-2
 default-information originate
 net 00.0900.0000.0000.0900

r10
===
ip subnet-zero
ip classless
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.128
 ip router isis
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.128
 media-type 10BaseT
!
interface Ethernet1
 ip address 192.168.0.2 255.255.255.128
 ip router isis
 no ip split-horizon
 media-type 10BaseT
 isis metric 5 level-1
!
router ospf 1
 redistribute isis level-2 subnets
 network 192.168.2.0 0.0.0.255 area 0
!
router isis
 net 00.0900.0000.0000.1100

r11#sh ip route
     192.168.0.0/24 is variably subnetted, 3 subnets, 2 masks
i L2 192.168.0.0/24 [115/20] via 192.168.0.1, Ethernet1
C 192.168.0.0/25 is directly connected, Ethernet1
i L1 192.168.0.128/25 [115/15] via 192.168.0.1, Ethernet1
     192.168.1.0/25 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, Loopback0
i L1 192.168.1.128 [115/10] via 192.168.0.1, Ethernet1
     192.168.2.0/25 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Ethernet0
i*L2 0.0.0.0/0 [115/10] via 192.168.0.1, Ethernet1

I'd like to see 192.168.0.0/24 but not 192.168.0.128/25 via ISIS. I can
make this work by moving r11 to another area. Anyone know of a way when all
routers in the same area, as above?



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:55 GMT-3