From: Hazel Gachoka (hgachoka@xxxxxxxxx)
Date: Sat Sep 09 2000 - 11:42:34 GMT-3
Aaron,
I believe you need to have that route in your IGP before it can show up in our
routing table. So you can create a static and point it to null 0 and add the ne
twork 0.0.0.0 stmt in your BGP. As for the neighbor x.x.x.x default originate,
that allows a router to advertise a default route to neighbor(s) on a per neigh
bor basis verses the default-information originate that will advertise it to al
l.
"One would think that the "default-information originate" would work the same w
ay that it does in OSPF and other protocols where entering the command would fo
rce the protocol to advertise the default route if it exists. It works a littl
e differently in BGP because you still have to redistribute the default route i
nto the BGP table. The "default-information originate" command allows BGP to a
dvertise the default to its peers. In other words, if you are redistributing a
default route into BGP but do not have "default-information originate" the def
ault route will not be advertised. Once you do have everything configured corr
ectly you can verify that you are installing the route by using "show ip bgp 0.
0.0.0". You can also check to see if you are advertising the route to your nei
ghbor(s) by using "show ip bgp neighbor a.b.c.d advertised-routes". The 0.0.0.
0 route will show up under the Network column for both of these show commands.
Hope that helps,
Hazel
At 09:32 PM 9/8/00 -0700, Aaron DuShey wrote:
>Couple questions here
>1st of all, whats the difference between these 3 BGP related commands
>network 0.0.0.0
>neighbor x.x.x.x default originate
>default-information originate
>2nd-Why isn't the BGP default 0.0.0.0 making it into the routing table?
>
>Here are r2 + R7's configurations
>thanks!
>
>BGP table version is 4, local router ID is 200.200.100.1
>Status codes: s suppressed, d damped, h history, * valid, > best, i -
>internal
>Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
>*> 172.168.0.0 137.20.10.70 170 0 3 i
>r1#i
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
>default
> U - per-user static route, o - ODR
>
>Gateway of last resort is 137.20.25.2 to network 0.0.0.0
>
> 200.200.200.0/32 is subnetted, 1 subnets
>O IA 200.200.200.1 [110/75] via 137.20.25.2, 00:48:26, Ethernet0/0
> 137.20.0.0/16 is variably subnetted, 11 subnets, 5 masks
>O E1 137.20.200.16/28 [110/110] via 137.20.25.2, 00:48:26, Ethernet0/0
>O IA 137.20.224.0/20 [110/1572] via 137.20.25.2, 00:48:26, Ethernet0/0
>O IA 137.20.30.0/24 [110/80] via 137.20.25.2, 00:48:26, Ethernet0/0
>C 137.20.25.0/24 is directly connected, Ethernet0/0
>O IA 137.20.20.0/24 [110/84] via 137.20.25.2, 00:48:26, Ethernet0/0
>C 137.20.10.0/24 is directly connected, FastEthernet1/0
>O IA 137.20.60.1/32 [110/21] via 137.20.25.2, 00:48:26, Ethernet0/0
>O E1 137.20.40.16/28 [110/110] via 137.20.25.2, 00:48:26, Ethernet0/0
>O IA 137.20.33.0/24 [110/75] via 137.20.25.2, 00:48:26, Ethernet0/0
>O IA 137.20.100.32/27 [110/74] via 137.20.25.2, 00:48:26, Ethernet0/0
>O IA 137.20.64.0/20 [110/20] via 137.20.25.2, 00:48:26, Ethernet0/0
>C 200.200.100.0/24 is directly connected, Loopback0
>B 172.168.0.0/16 [20/170] via 137.20.10.70, 00:14:26
>O*E2 0.0.0.0/0 [110/20] via 137.20.25.2, 00:48:27, Ethernet0/0
>r1#r
>Building configuration...
>
>
>hostname r1
>!
>logging buffered 4096 debugging
>!
>
>interface Loopback0
> ip address 200.200.100.1 255.255.255.0
> no ip directed-broadcast
> ip ospf interface-retry 0
>!
>interface Ethernet0/0
> ip address 137.20.25.1 255.255.255.0
> no ip directed-broadcast
> ip ospf interface-retry 0
>!
>
>interface FastEthernet1/0
> ip address 137.20.10.1 255.255.255.0
> no ip directed-broadcast
> speed 10
>!
>router ospf 1
> network 137.20.25.1 0.0.0.0 area 2
> network 200.200.100.1 0.0.0.0 area 2
>!
>router bgp 2
> no synchronization
> neighbor 137.20.10.70 remote-as 3
> neighbor 137.20.10.70 update-source Loopback0
> neighbor 137.20.10.70 default-originate
> neighbor 137.20.64.6 remote-as 2
> neighbor 137.20.64.6 route-reflector-client
> neighbor 137.20.100.33 remote-as 2
> neighbor 137.20.100.33 route-reflector-client
> no auto-summary
>!
>ip classless
>
>end
>
>r1#
>
>
>r7#
>BGP table version is 2, local router ID is 172.168.70.1
>Status codes: s suppressed, d damped, h history, * valid, > best, i -
>internal
>Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
>* 0.0.0.0 200.200.100.1 0 2 i
>*> 172.168.0.0 0.0.0.0 0 32768 i
>r7#i
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
>default
> U - per-user static route, o - ODR
>
>Gateway of last resort is not set
>
> 137.20.0.0/24 is subnetted, 1 subnets
>C 137.20.10.0 is directly connected, Ethernet2/0
> 172.168.0.0/24 is subnetted, 1 subnets
>C 172.168.70.0 is directly connected, Loopback0
>r7#r
>Building configuration...
>
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname r7
>
>!
>interface Loopback0
> ip address 172.168.70.1 255.255.255.0
> no ip directed-broadcast
>!
>
>
>interface Ethernet2/0
> ip address 137.20.10.70 255.255.255.0
> no ip directed-broadcast
>
>!
>router bgp 3
> no synchronization
> network 172.168.0.0
> neighbor 200.200.100.1 remote-as 2
> neighbor 200.200.100.1 ebgp-multihop 2
> neighbor 200.200.100.1 route-map SET_MED out
> default-metric 170
>!
>ip local policy route-map bgp_ebgp
>ip classless
>!
>access-list 100 permit ip any host 200.200.100.1 log
>route-map bgp_ebgp permit 10
> match ip address 100
> set ip next-hop 137.20.10.1
>!
>route-map SET_MED permit 10
> set metric 170
>!
>
>r7#
>
>Aaron DuShey
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:54 GMT-3