X25 on the D-Channel

From: Clifton Stewart (cliftonlstewart@xxxxxxxx)
Date: Wed Aug 30 2000 - 15:59:01 GMT-3


   
Hi Guys,

I wanted to know if anyone has successfully configured the D channel to
be used for x25 traffic. You might ask why? Well if you're using both
b-channels that leaves the d channel available to do some routing also.
I have listed the configs below, if you don't have the necessary
commands on your router you will need to upgrade your software. Thanks.

-Cliff

* I also recommend "Internetworking TCP/IP" author: Richard Stevens

http://www.amazon.com/exec/obidos/ASIN/0201633469/o/qid=967661893/sr=2-1/102-51
35787-6778568

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2504a
!
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-5ess
x25 routing
!
!
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 192.168.168.1 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
!
interface BRI0
 ip address 192.168.1.1 255.255.255.252
 no ip directed-broadcast
 encapsulation x25
 no ip mroute-cache
 dialer-group 1
 x25 address 2231146
 x25 htc 2
 x25 idle 1
 x25 map ip 192.168.1.1 12503372501
 isdn switch-type basic-5ess
 isdn x25 static-tei 5
 isdn x25 dchannel
!
router eigrp 1
 network 192.168.0.0
 no auto-summary
!
no ip classless
!
dialer-list 1 protocol ip permit
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

R2504a#
<========================================================>

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2504b
!
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-5ess
!
!
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 192.168.168.2 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
!
interface BRI0
 ip address 192.168.1.1 255.255.255.252
 no ip directed-broadcast
 encapsulation x25
 no ip mroute-cache
 dialer-group 1
 x25 address 12503372501
 x25 htc 2
 x25 idle 1
 x25 map ip 192.168.1.2 2231146
 isdn switch-type basic-5ess
 isdn x25 static-tei 4
!
router eigrp 1
 network 192.168.0.0
 no auto-summary
!
ip classless
!
dialer-list 1 protocol ip permit
!
tftp-server flash:
tftp-server flash:c2500-js-l.120-9.bin
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

R2504b#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:32 GMT-3