From: Aaron DuShey (aaron.dushey@xxxxxxxxxxxxxxxxxxxxx)
Date: Wed Aug 23 2000 - 14:31:43 GMT-3
1-sh ip ospf interface at r1-check ospf interface type at r1 vs r3
2-if you use point-to-multipoint, remember there is no DR/BDR, so ospf
priority command is not necessary-unless I am missing something
3-debug ip ospf adj should show you whats happening-
Aaron DuShey
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Harbir Kohli
Sent: Wednesday, August 23, 2000 10:02 AM
To: 'Ccielab
Subject: ospf and NBMA
Hello Group,
I think in my config I have run into some issue with NBMA and OSPF
because I can not exchange any routes even though I have full adjacency
established.
What is wrong?
************R1************
interface Ethernet0
ip address 10.1.1.1 255.255.0.0
!
interface Serial0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
ip address 10.10.1.1 255.255.0.0
frame-relay map ip 10.10.1.3 103 broadcast
frame-relay map ip 10.10.1.5 105 broadcast
!
interface Serial0.2 point-to-point
ip address 10.20.1.1 255.255.0.0
ip ospf priority 200
frame-relay interface-dlci 102
!
interface Serial1
no ip address
shutdown
!
router eigrp 1
passive-interface Ethernet0
passive-interface Serial0.2
network 10.0.0.0
!
router ospf 1
network 10.10.1.1 0.0.0.0 area 0
network 10.1.1.1 0.0.0.0 area 1
!
ip classless
logging buffered 16384 debugging
no logging console
!
alias exec ro show ip route
alias exec ne show ip ospf neighbor
alias exec ip show ip int brief
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
*****************************
RT1#ne
Neighbor ID Pri State Dead Time Address
Interface
11.1.1.5 0 FULL/DROTHER 00:01:43 10.10.1.5
Serial0.1
10.33.2.1 0 FULL/DROTHER 00:01:43 10.10.1.3
Serial0.1
RT1#ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 3 subnets
C 10.10.0.0 is directly connected, Serial0.1
C 10.1.0.0 is directly connected, Ethernet0
C 10.20.0.0 is directly connected, Serial0.2
**********************
sh ip ospf database router
...
Adv Router is not-reachable
LS age: 815
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 10.33.2.1
Advertising Router: 10.33.2.1
LS Seq Number: 80000006
Checksum: 0xD23
Length: 48
Area Border Router
AS Boundary Router
Number of Links: 2
***********************
RT3#sh run
Building configuration...
Current configuration:
!
version 11.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname RT3
!
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 10.33.1.1 255.255.255.0
!
interface Loopback1
ip address 10.33.2.1 255.255.255.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
ip address 10.10.1.3 255.255.0.0
ip ospf network point-to-multipoint
ip ospf priority 0
frame-relay interface-dlci 301
!
interface Serial1
ip address 173.168.40.1 255.255.255.0
!
interface TokenRing0
ip address 10.3.3.1 255.255.0.0
ring-speed 16
!
router ospf 1
redistribute static metric 500 metric-type 1
network 10.10.1.3 0.0.0.0 area 0
network 10.33.0.0 0.0.255.255 area 33
area 33 range 10.33.0.0 255.255.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 173.168.40.2
logging buffered 16384 debugging
no logging console
!
alias exec ro show ip route
alias exec ne show ip ospf neighbor
alias exec ip show ip int brief
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
********************
RT3#ne
Neighbor ID Pri State Dead Time Address
Interface
10.20.1.1 1 FULL/ - 00:01:58 10.10.1.1
Serial0.1
RT3#ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is 173.168.40.2 to network 0.0.0.0
173.168.0.0/24 is subnetted, 1 subnets
C 173.168.40.0 is directly connected, Serial1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.0.0/16 is directly connected, Serial0.1
C 10.3.0.0/16 is directly connected, TokenRing0
C 10.33.2.0/24 is directly connected, Loopback1
C 10.33.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [1/0] via 173.168.40.2
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:29 GMT-3