From: Wojtek Iwanczyk (wiwanczyk@xxxxxxxxxx)
Date: Mon Jul 31 2000 - 15:20:24 GMT-3
I have been able to use PPP callback using Dialer interfaces on both sides of t
he link. I did use dialer strings instead of dialer maps though ...
>>> Shaun Nicholson <Shaun.Nicholson@kp.org> 07/30/00 12:02PM >>>
OK guys and girls
Here is a question for you.
I have checked the archives and its not solved (asked many times but never solv
ed).
Can PPP Callback work with Dialer profiles and if so why does mine fail?
I have been playing around with PPP Callback and I can get it to work with Lega
cy DDR and also Legacy to Dialer profiles if the client is dialer profile.
However I cannot get it work Dialer profile to Dialer profile it seems to be to
do with the map-class statement you need to link the callback accept with the
dialer callback-server username command.
Now I can tie the map-class on the end of the dialer string command like so dia
ler string 3333 class callback but still no joy.
My lab is in 4 days and I want to know if this possible or not I can probable w
ork around using Legacy to Dialer profiles if the lab requests it but I would l
ike to know if it is indeed possible.
Here are my configs anyone got any ideas or is it as I suspect not possible for
a callback server to run Dialer profiles.
Please note I have changed the spids and numbers but the work in both direction
s under normal conditions.
The error message says BRI0:1: No callback configured for user r5.
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r3
!
!
username r5 password 7 cisco
isdn switch-type basic-dms100
!
interface Loopback0
ip address 199.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 30.1.1.1 255.255.255.0
no keepalive
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation ppp
isdn spid1 1111
isdn spid2 2222
dialer pool-member 1
ppp callback accept
ppp authentication chap
hold-queue 75 in
!
interface Dialer1
ip address 196.1.1.1 255.255.255.0
encapsulation ppp
dialer remote-name r5
dialer callback-secure
dialer string 3333 class callback
dialer pool 1
dialer-group 1
ppp callback accept
ppp authentication chap
!
router igrp 33
network 196.1.1.0
network 199.1.1.0
!
no ip classless
!
map-class dialer callback
dialer callback-server username
access-list 101 deny igrp any any
access-list 101 permit ip any any
!
dialer-list 1 protocol ip list 101
!
line con 0
line aux 0
line vty 0 4
login
!
end
r3#
%DIALER-6-BIND: Interface BRI0:1 bound to profile Dialer1
%LINK-3-UPDOWN: Interface BRI0:1, changed state to up
BRI0:1: No callback configured for user r5.
%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up
%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 3333 r5
R5
r5#
r5#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r5
!
!
username r3 password 7 cisco
isdn switch-type basic-dms100
!
interface Loopback0
ip address 201.1.1.1 255.255.255.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation ppp
isdn spid1 3333
isdn spid2 4444
dialer pool-member 1
no fair-queue
ppp callback request
ppp authentication chap
!
interface Dialer1
ip address 196.1.1.2 255.255.255.0
encapsulation ppp
dialer remote-name r3
dialer string 1111
dialer pool 1
dialer-group 1
ppp callback request
ppp authentication chap
!
router igrp 33
network 160.1.0.0
network 196.1.1.0
network 201.1.1.0
!
no ip classless
access-list 101 deny igrp any any
access-list 101 permit ip any any
!
dialer-list 1 protocol ip list 101
!
line con 0
line aux 0
line vty 0 4
login
!
end
r5#ping 196.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 196.1.1.1, timeout is 2 seconds:
BRI0: rotor dialout [priority]
BRI0: Dialing cause ip (s=196.1.1.2, d=196.1.1.1)
BRI0: Attempting to dial 1111
%LINK-3-UPDOWN: Interface BRI0:1, changed state to up
%DIALER-6-BIND: Interface BRI0:1 bound to profile Dialer1.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/38/40 ms
r5#
BRI0:1: Callback negotiated - waiting for server disconnect
%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up
%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 1111 r3
Shaun Nicholson CCNP
Lead Network Engineer
Kaiser Permanente
Silver Spring National Data Center MD
shaun.nicholson@kp.org
Direct line 1 301 680 1462
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:00 GMT-3