From: Brian S turner (brian@xxxxxxxxxxxxxxxxx)
Date: Fri Jul 21 2000 - 10:01:11 GMT-3
You are in your example using the directly connected address of the ISP, so
you wouldn't need ebgp-multihop. You have set your update-source to the
loopback,
so your ISP would have to use EBGP multihop, and talk to the loop ip in
order
to bring up the adjacency. This is a poor design, because you are using 2
Private networks, to talk to the ISP, and from the ISP's point of view that
means that they have 2 less networks to talk to other Customers. It is also
a poor design, because you are using the loopback, as update source, but
since
you are talking directly with the ISP's ip address, You are not getting the
benifit of link independent connectivity. If you only have one link to the
ISP, you should simply use the links IP's. EBGP multihop should only be
used
if you want to implement redundancy, because it breaks some of the rules of
BGP. You might also want to add no auto-summary to your BGP config, so you
won't accidentaly advertise aggregate routes.
Brian
-----Original Message-----
From: jaarons-hotmail [mailto:jaarons@hotmail.com]
Sent: Thursday, July 20, 2000 8:28 PM
To: ccielab@groupstudy.com
Subject: multihomed non-transit AS configuration
I am wanting to connect our two routers (A,B both in AS 16895) to two
different ISPs (ISP-4323, ISP-16895) and had a few questions about
making them talk to each other, and to the ISPs.
They already have loopbacks and am not sure if I need ebgp-multihop or
some other commands.
Router A
interface serial 0
ip addr 192.168.1.1 255.255.255.252
description to ISP-4323
interface loopback 0
ip addr 10.0.0.1
router bgp 16895
network 216.54.167.0 mask 255.255.255.0
network 216.54.168.0 mask 255.255.255.0
network 216.54.169.0 mask 255.255.255.0
network 216.54.170.0 mask 255.255.255.0
no sync
neighbor 192.168.1.2 remote-as 4323
neighbor 192.168.1.2 update-source loopback 0
neighbor 10.0.0.11 remote-as 16895
neighbor 10.0.0.11 update-source loopback0
RouterB
interface serial 0
ip addr 172.16.1.1 255.255.255.252
description to ISP-4323
interface loopback 0
ip addr 10.0.0.11 255.255.255.255
router bgp 16895
network 216.54.167.0 mask 255.255.255.0
network 216.54.168.0 mask 255.255.255.0
network 216.54.169.0 mask 255.255.255.0
network 216.54.170.0 mask 255.255.255.0
neighbor 172.16.1.2 remote-as 3847
neighbor 172.16.1.2 update-source loopback 0
neighbor 10.0.0.1 remote-as 16895
neighbor 10.0.0.1 update-source loopback0
ISPA
ISPB
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:56 GMT-3