ISDN one way calling.....

From: smaljure@xxxxxxxxxxxxxxxxx
Date: Mon Jun 26 2000 - 15:45:11 GMT-3


   
Hi all,
I am trying to get one way ISDN calling to work.
I have the following scenario....

R1-BRI0---TELTONE_ILS_2000-----BRI0-r2

I have a very simple config going...PPP on both sides, no authentication.

I have a dialer string on only one side (R1)
On the other side I have a dialer map with no number.
Layer 1 and Layer 2 are active.. on both sides..
If I do a "sh dialer" on the routers, I see that the call successfully goes
through, however I do not receive the ping replies..
If I do a "debug dialer" on R2, it says, "cannot find dial number, cannot
complete call, go get a life"

HOWEVER,
If I put in dialer strings on both routers, they can talk to one another.
If I put in dialer map on both routers with phone numbers, they can talk to
one another.
I found out that when I can successfully ping, as in the above case, R1
places the call on the first B channel and sends the echoes and R2 puts a
fresh call on its second B channel
to send the echo replies.

But if R1 already has a B channel open, isn't R2 supposed to just reply on
the same????

I have got this working several times with real ISDN lines. This is my first
time with this simultaor. Any gotchchas???

Below are the configs...
Thanks for your time
Sanjay

sh run
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r1
!
enable secret 5 $1$FE6P$1pB46PMhaFivO/C/KaSVj0
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-dms100
!
interface Loopback0
 ip address 14.0.0.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
 --More-- interface Serial0
 ip address 11.0.0.1 255.255.255.0
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
!
interface BRI0
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
 isdn spid1 0835866101 8358661
 --More-- isdn spid2 0835866301 8358663
 dialer map ip 10.0.0.2 8358662
 dialer-group 1
!
no ip classless
ip route 13.0.0.0 255.255.255.0 10.0.0.2
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

r1#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
8358662 1 0 00:16:52 successful
0 incoming call(s) have been screened.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
r1#
r1#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:

%LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
RT: network 10.0.0.0 is now variably masked
RT: add 10.0.0.2/32 via 0.0.0.0, connected metric [0/0]
%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to
up...
%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358662 .
Success rate is 0 percent (0/5)
r1#
r1#
r1#sh run dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
8358662 2 0 00:00:22 successful
0 incoming call(s) have been screened.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.0.1, d=10.0.0.2)
Time until disconnect 105 secs
Connected to 8358662

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
r1#
r1#
r1#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r1#
r1#
r1#sh int bri 0 1
BRI0:1 is up, line protocol is up
  Hardware is BRI
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  LCP Open
  Open: IPCP, CDPCP
  Last input 00:00:05, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations 0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     120 packets input, 1886 bytes, 0 no buffer
     Received 120 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     248 packets output, 15186 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
r1#
r1#

r2#
r2#
r2#sh run
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r2
!
enable secret 5 $1$f0E1$I9HuoTlJpxtucXeO7W.dB0
!
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-dms100
!
interface Loopback0
 ip address 13.0.0.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
 --More-- interface Serial0
 ip address 11.0.0.2 255.255.255.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 10.0.0.2 255.255.255.0
 encapsulation ppp
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 dialer map ip 10.0.0.1 name r1
 dialer-group 1
 no fair-queue
 ppp multilink
!
no ip classless
ip route 14.0.0.0 255.255.255.0 BRI0
!
dialer-list 1 protocol ip permit
!
 --More-- line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

r2#
r2#
r2#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
0 incoming call(s) have been screened.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 64 secs

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
r2#
r2#
r2#
r2#
r2#
r2#sh int bri 0 1
BRI0:1 is up, line protocol is up
  Hardware is BRI
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  LCP Open, multilink Closed
  Open: IPCP, CDPCP
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     757 packets input, 35199 bytes, 0 no buffer
     Received 757 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     292 packets output, 4566 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 output buffer failures, 0 output buffers swapped out
     18 carrier transitions
r2#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:43 GMT-3