From: Kinton Connelly (kinton@xxxxxxxxxxxx)
Date: Wed May 03 2000 - 11:47:05 GMT-3
Jason, here's an example of Mobile IP that I found on the doc cd:
http://127.0.0.1:8080/cc/td/doc/product/software/ios120/120newft/120t/120t1/
mobileip.htm
Kinton
Home Agent Configuration Example
--------------------------------
!
router mobile
!
! Define which hosts are permitted to roam
ip mobile home-agent broadcast roam-access 1
!
! Define a virtual network
ip mobile network 10.0.0.0 255.0.0.0
!
! Define which hosts are on the virtual network, and the care-of access list
ip mobile host 10.0.0.1 10.0.0.10 virtual-network 10.0.0.0 255.0.0.0
care-of-access 2
!
! Define which hosts are on Ethernet 1, with lifetime of one hour
ip mobile host 11.0.0.1 11.0.0.5 interface Ethernet1 lifetime 3600
!
! The next ten lines specify security associations for mobile hosts
! on virtual network 10.0.0.0
!
ip mobile secure host 10.0.0.1 spi 100 key cisco1
ip mobile secure host 10.0.0.2 spi 200 key cisco2
ip mobile secure host 10.0.0.3 spi 300 key cisco3
ip mobile secure host 10.0.0.4 spi 100 key cisco4
ip mobile secure host 10.0.0.5 spi 200 key cisco5
ip mobile secure host 10.0.0.6 spi 300 key cisco6
ip mobile secure host 10.0.0.7 spi 100 key cisco7
ip mobile secure host 10.0.0.8 spi 200 key cisco8
ip mobile secure host 10.0.0.9 spi 300 key cisco9
ip mobile secure host 10.0.0.10 spi 100 key cisco10
!
! The next five lines specify security associations for mobile hosts
! on Ethernet1
!
ip mobile secure host 11.0.0.1 spi a1 key sanfran1
ip mobile secure host 11.0.0.2 spi a1 key sanfran2
ip mobile secure host 11.0.0.3 spi a1 key sanfran3
ip mobile secure host 11.0.0.4 spi a1 key sanfran4
ip mobile secure host 11.0.0.5 spi a1 key sanfran5
!
! Deny access for this host
access-list 1 deny 11.0.0.5
!
! Deny access to anyone on network 13.0.0.0 trying to register
access-list 2 deny 13.0.0.0
Foreign Agent Configuration Example
-----------------------------------
!
interface Ethernet0
ip address 68.0.0.31 255.0.0.0
interface Ethernet1
ip address 67.0.0.31 255.0.0.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip mobile foreign-service
ip mobile registration-lifetime 3600
!
router mobile
!
ip mobile foreign-agent care-of Ethernet0
At 5/3/00, you wrote:
>All:
>
>I apologize. It seems that I have sent an example on LAM (Local
>Area Mobility), not Mobile IP. Thankfully someone at Cisco sent
>me an e-mail expressing that there is a difference. I had sent the
>question to the CCO Open Forum in the past, but it seems they
>lead me down the wrong path. I had originally sent a request to the
>CCO Open Forum for a config that showed the Foreign Agent and
>all of the other features configured. So, now I am still looking for
>some functioning configuration examples of Mobile IP. This is not
>to say LAM should not be know for the CCIE, just that it is not
>Mobile IP.
>
>Sorry if I lead anyone down the wrong path.
>
>Jason
>
>-----Original Message-----
>From: Jason Weinstein EB Networks [SMTP:jasonw@ebnetworks.com]
>Sent: Monday, May 01, 2000 1:06 PM
>To: CCIELAB@groupstudy.com
>Subject: RE: IP MOBILE EXAMPLEs???
>
>Here is a functional example. I hope this helps.
>
>Jason Weinstein
>eB Networks
>
>There is a way to test this in your lab with a PC, but I don't remember
>how I did it. If anyone is interested I can try to set it up again and
>maybe remember.
>
>show run
>Building configuration...
>
>Current configuration:
>!
>version 11.2
>no service password-encryption
>no service udp-small-servers
>no service tcp-small-servers
>!
>hostname 2513_B
>!
>enable password lab
>!
>ip subnet-zero
>no ip domain-lookup
>appletalk routing eigrp 4
>appletalk route-redistribution
>ipx routing 4444.0000.4444
>!
>interface Loopback0
> ip address 10.10.4.4 255.255.255.255
> ipx network 4
>!
>interface Ethernet0
> ip address 10.10.45.74 255.255.255.192
> ip mobile arp access-group 15 Will accept mobile arps from within
> access- list 15
> appletalk cable-range 45-45 45.4
> appletalk zone bet4and5
> ipx network 45
>!
>interface Serial0
> ip address 10.10.34.4 255.255.255.0
> appletalk cable-range 34-34 34.4
> appletalk zone bet3and4
> ipx network 34
>!
>interface TokenRing0
> no ip address
> shutdown
>!
>router eigrp 1
> redistribute ospf 1 metric 10000 4 155 1 1500
> passive-interface Serial0
> passive-interface TokenRing0
> network 10.0.0.0
>!
>router ospf 1
> redistribute mobile metric-type 1 subnets Redistributes the mobile
> IP
> routes, which are 32 bit
> host routes,
> into OSPF, which
> then becomes
> the most specific
> route to
> the host
> redistribute eigrp 1 metric-type 1 subnets
> network 10.10.34.0 0.0.0.255 area 3
> network 10.10.4.0 0.0.0.255 area 3
> network 10.10.45.0 0.0.0.255 area 4
> area 3 virtual-link 10.10.3.3
>!
>ip classless
>access-list 15 permit 10.10.33.0 0.0.0.255 Only for that subnet will
>Mobile IP
>be used
>!
>!
>!
>!
>!
>line con 0
>line aux 0
>line vty 0 4
> password rpm
> login
>!
>end
>
>2513_B#
>
>
>-----Original Message-----
>From: nobody@groupstudy.com [SMTP:nobody@groupstudy.com]
>Sent: Monday, May 01, 2000 10:56 AM
>To: Michael Needham; CCIELAB@groupstudy.com
>Subject: Re: IP MOBILE EXAMPLEs???
>
>
>
>I have yet to see a post on this question and I am curious as well... Did I
>miss it?
>----- Original Message -----
>From: Michael Needham <mineedha@cisco.com>
>To: <CCIELAB@groupstudy.com>
>Sent: Thursday, April 27, 2000 6:47 PM
>Subject: IP MOBILE EXAMPLEs???
>
>
> > I've seen the one configuration example on CCO but it is a bit "slim".
> > Aone have any other examples???
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:27 GMT-3