From: niallr@xxxxxxxxxxxxx
Date: Mon May 01 2000 - 16:17:46 GMT-3
Below are the configs from 3 routers configured with NLSP. There's a lot of
additional junk in the config, but it is functional (was running in my lab).
Niall
r5#sho ru
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r5
!
!
ipx routing 0000.0000.0005
ipx internal-network 550
!
!
interface Ethernet0
no ip address
lat enabled
bridge-group 1
!
interface Serial0
no ip address
encapsulation frame-relay
lat enabled
!
interface Serial0.1 point-to-point
ipx ipxwan 0 535 r5
ipx nlsp 2 enable
frame-relay interface-dlci 402
!
interface Serial1
no ip address
encapsulation ppp
lat enabled
bridge-group 1
!
interface TokenRing0
no ip address
ipx network 552
ring-speed 16
!
no ip classless
!
!
!
ipx router nlsp 2
area-address 500 FFFFFF00
!
!
!
bridge crb
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 route ipx
!
line con 0
exec-timeout 0 0
length 0
line aux 0
line vty 0 4
login
!
end
r5#sho lat serv
Service Name Rating Interface Node (Address)
PIGLET 5 Serial1 R3 (0010.7b3b.dbb3)
r4#sho ru
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r4
!
!
ipx routing 0000.0000.0004
ipx internal-network 340
!
!
interface Ethernet0
no ip address
lat enabled
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ipx ipxwan 0 334 r4
ipx nlsp 1 enable
frame-relay interface-dlci 302
!
interface Serial1
no ip address
shutdown
!
interface TokenRing0
no ip address
ipx network 342
ring-speed 16
!
no ip classless
!
!
!
ipx router nlsp 1
area-address 300 FFFFFF00
!
!
!
!
line con 0
exec-timeout 0 0
length 0
line aux 0
line vty 0 4
login
!
end
r4#sho lat serv
Service Name Rating Interface Node (Address)
PIGLET 5 Ethernet0 R3 (0010.7b3b.dbb3)
r4#lat piglet
Trying PIGLET...Password required
Password: Trying PIGLET...Open
Codes: C - Connected primary network, c - Connected secondary network
S - Static, F - Floating static, L - Local (internal), W - IPXWAN
R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
s - seconds, u - uses
8 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
No default route known.
NA 300 FFFFFF00 via 0.0000.0000.0000, Nu0
NA 500 FFFFFF00 via 0.0000.0000.0000, Nu0
L 330 is the internal network
C 331 (SAP), Et0
W 334 (FRAME-RELAY), Se0.1
W 535 (FRAME-RELAY), Se0.2
N 340 [55][26/01] via 340.0000.0000.0001, 736s, Se0.1
N 342 [55][25/01] via 340.0000.0000.0001, 736s, Se0.1
N 550 [55][18/01] via 550.0000.0000.0001, 753s, Se0.2
N 552 [55][17/01] via 550.0000.0000.0001, 753s, Se0.2
[Connection to piglet closed by foreign host]
r3#sho ru
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r3
!
!
ip subnet-zero
ipx routing 0000.0000.0003
ipx internal-network 330
!
!
interface Ethernet0
no ip address
lat enabled
ipx network 331 encapsulation SAP
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ipx ipxwan 0 334 r3
ipx nlsp 1 enable
frame-relay interface-dlci 203
!
interface Serial0.2 point-to-point
ipx ipxwan 0 535 r3
ipx nlsp 2 enable
frame-relay interface-dlci 204
!
interface Serial1
no ip address
encapsulation ppp
lat enabled
clockrate 56000
!
interface TokenRing0
no ip address
shutdown
!
ip classless
access-list 800 deny 341
access-list 801 deny 551
lat service PIGLET autocommand sho ipx route
lat service PIGLET password PIGLET
lat service PIGLET enabled
!
!
!
ipx router nlsp 2
area-address 400 FFFFFF00
area-address 500 FFFFFF00
route-aggregation
!
!
ipx router nlsp 1
area-address 300 FFFFFF00
route-aggregation
!
!
!
!
line con 0
exec-timeout 0 0
length 0
line aux 0
line vty 0 4
login
!
end
r3#sho lat serv
Service Name Rating Interface Node (Address)
PIGLET 5 Local
Justin van Schaik wrote:
> Did you enter "ipx router nlsp" in global router config? Although NLSP is
> enabled per interface, it has to be globally enabled.
>
> Also, x25 gets a little dodgy at higher clockrates; it's supposed to be
> able to go up to E1 speeds, but I usually don't set it higher than 64K.
> Something about LAPB error-checking and higher clockrates not getting
> along too well. If you want to go faster, go frame relay:)
>
> Router 2 s1.1 doesn't have a "no ip address" entry. Just oversight.
>
> As a tip, you might want to specify the node address for IPX when you set
> it up (ie, "ipx routing 2.2.2" for R2); it's a lot easier than typing MAC
> addresses, and it makes troubleshooting and analyzing much much simpler.
> You'll automatically know that anything, in any routing table, that says
> 128.0002.0002.0002 comes from R2.
>
> - Justin
>
> --- Jeff <a@a.a> wrote:
> > Adjacencies are not working between 2 routers I have connected via x25
> > link. I also tried ipxwan, but this didn't work either. The show
> > interfaces say nlsp is running, but debug ipx all and debug ipx nlsp adj
> > shows no packets for NLSP are even being generated. I found a post in
> > the archive related to this, but it did not help me. Can someone point
> > me in the right direction?
> > Thanks.
> >
> >
> > Router1:
> > interface Serial0
> > ip address 141.11.11.129 255.255.255.248
> > no ip mroute-cache
> > encapsulation x25
> > x25 address 26
> > x25 map ip 141.11.11.130 25 broadcast
> > !
> > interface Serial0.1 point-to-point
> > no ip address
> > ipx network 128
> > ipx nlsp enable
> > x25 map ipx 128.0000.0c5a.dc18 25 broadcast
> >
> >
> > Router2
> >
> > interface Serial1
> > ip address 141.11.11.130 255.255.255.248
> > encapsulation x25 dce
> > no ip mroute-cache
> > x25 address 25
> > x25 map ip 141.11.11.129 26 broadcast
> > clockrate 800000
> > !
> > interface Serial1.1 point-to-point
> > x25 map ipx 128.0060.837c.faa0 26 broadcast
> > ipx network 128
> > ipx nlsp enable
> >
> >
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:26 GMT-3