From: Richard Wagner (rfwagner@xxxxxxxxxxx)
Date: Thu Apr 06 2000 - 23:15:54 GMT-3
I might have the answer to why you can't AT ping. Even if I miss the problem
completely, I do see a potential trouble spot with your frame-relay
configurations. Look at your frame relay maps.
Since the hub can see both sides, inverse-ARP will resolve the addresses for
you. Don't change a thing.
You are partially right to add the "other hub" map statement at the spokes.
You need to go a step further.
Let's look at your frame maps:
>Serial0/0 (up): appletalk 101.1 dlci
>100(0x64,0x1840), dynamic,
> broadcast,, status defined, active
>Serial0/0 (up): appletalk 101.2 dlci
>100(0x64,0x1840), static,
> broadcast,
> CISCO, status defined, active
Note that the spoke is STATIC and the hub is DYNAMIC. This will work right
up until you reboot the router. When you issue the frame-relay map command
for particular protocol and DLCI, inverse-ARP is disabled for that protocol
on that DLCI. Bounce them (if you haven't already) and take a look at your
frame relay maps... the dynamic entries should not return (and only your
static maps will be there).
That means that you won't dynamically learn the HUB router when you reboot
because your static statement will disable inverse-ARP. To fix this, put in
a frame-relay map command for the hub router too.
While you're at it, put in one for your own IP and point it to the DLCI
coming in... that will allow you to ping your own interface (saves confusion
sometimes).
Even if this is not the problem, you should be aware of how inverse-ARP is
affected by frame relay map commands.
I recommend that you use the "no frame-relay inverse-arp" command on ALL
THREE routers and statically map all connectivity. FYI, you might have a
full mesh on your network and some odd/difficult test you may take someday
will require that you DON'T use it. Inverse-ARP will use the full-mesh and
you will fail to meet the requirements of forcing a hub/spoke configuration.
In the end, have SIX mappings on each spoke router. All six point to the
DLCI... three appletalk addresses and three IP addresses (R1, R2 and R3,
even though you're mapping the IP of the interface!). Pick one of the two
DLCIs on the hub when mapping the hub's own address to a DLCI.
Finally, do a "debug appletalk packets" (or something like that)... run the
appletalk ping and check what each of the three routers do with the AT ping.
I expect that you will get some kind of "encapsulation failed" message on
some interface... and that can happen on the way there or on the way back.
Find the OUTBOUND port it should be going out of and check out the mappings
on it. If you fatfingered R2's map statements, you will send it down a
non-existent DLCI or you mapped the wrong address. Do a "show appletalk
interface Serial0" to verify the configuration... make sure the node address
is perfectly right!
show us the frame maps from all routers and also show us a "show frame-relay
pvc" command to see what's coming from the switch.
Good luck!
>From: Eric Lemmons <ericlemmons@yahoo.com>
>Reply-To: Eric Lemmons <ericlemmons@yahoo.com>
>To: ccielab@groupstudy.com
>Subject: appletalk eigrp over frame
>Date: Thu, 6 Apr 2000 15:46:00 -0700 (PDT)
>
>I'm trying to get appletalk routing with
>appletlak eigrp working over a frame-relay hub
>and spoke config.
>I'm using all physical interfaces on the frame.
>OSPF is working on the frame, utilizing
>inverse-arp on the hub, and maps from the two
>spokes to each other.
>I've enabled appletalk on the serial/frame
>interfaces, and they all come up fine, with no
>errors.
>I've disabled eigrp-splithorizon, and I've
>manually mapped the spoke addresses in the same
>manner as the IP mappings for OSPF.
>I can ping the appletalk spokes from the hub, and
>I can ping the hub from each of the spokes. But
>no spoke to spoke pinging, even with the manual
>maps.
>Here are the configs:
>
>The HUB - hostname R1
>!
>interface Serial0
> ip address 130.20.100.1 255.255.255.0
> encapsulation frame-relay
> ip ospf network broadcast
> ip ospf priority 200
> appletalk cable-range 100-120 101.1
> appletalk zone FrameZone
> appletalk protocol eigrp
> no appletalk protocol rtmp
> no appletalk eigrp-splithorizon
> frame-relay lmi-type cisco
>
>SPOKE R2
>!
>interface Serial0/0
> ip address 130.20.100.2 255.255.255.0
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf network broadcast
> ip ospf priority 0
> no ip mroute-cache
> appletalk cable-range 100-120 101.2
> appletalk zone FrameZone
> appletalk protocol eigrp
> no appletalk protocol rtmp
> no appletalk eigrp-splithorizon
> frame-relay map appletalk 101.3 100 broadcast
> frame-relay map ip 130.20.100.3 100 broadcast
> frame-relay lmi-type cisco
>
>SPOKE R3
>
>interface Serial0/0
> ip address 130.20.100.3 255.255.255.0
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf network broadcast
> ip ospf priority 0
> no ip mroute-cache
> appletalk cable-range 100-120 101.3
> appletalk zone FrameZone
> appletalk protocol eigrp
> no appletalk protocol rtmp
> no appletalk eigrp-splithorizon
> frame-relay map appletalk 101.2 100 broadcast
> frame-relay map ip 130.20.100.2 100 broadcast
> frame-relay lmi-type cisco
>
>Here is "Show apple route" on R3:
>
>r3#show apple route
>Codes: R - RTMP derived, E - EIGRP derived, C -
>connected, A - AURP
> S - static P - proxy
>2 routes in internet
>
>The first zone listed for each entry is its
>default (primary) zone.
>
>C Net 100-120 directly connected, Serial0/0, zone
>FrameZone
>E Net 200-210 [2/G] via 101.1, 1239 sec,
>Serial0/0, zone EnetZone
>
>Here is the show frame map command on R3:
>
>r3#show frame map
>Serial0/0 (up): appletalk 101.1 dlci
>100(0x64,0x1840), dynamic,
> broadcast,, status defined, active
>Serial0/0 (up): appletalk 101.2 dlci
>100(0x64,0x1840), static,
> broadcast,
> CISCO, status defined, active
>Serial0/0 (up): ip 130.20.100.1 dlci
>100(0x64,0x1840), dynamic,
> broadcast,, status defined, active
>Serial0/0 (up): ip 130.20.100.2 dlci
>100(0x64,0x1840), static,
> broadcast,
> CISCO, status defined, active
>
>The commands show similar output on R2.
>
>Any help will be appreciated.
>Eric
>
>
>=====
>(James) Eric Lemmons
>615-834-9952 CELL 615-364-5818
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:13 GMT-3