From: Reyna, Alberto (alberto.reyna@xxxxxxx)
Date: Mon Mar 27 2000 - 16:59:30 GMT-3
Hello Guys,
I have a dilemma with route-aggregation/summarization between two nlsp areas
and RIP. Follow is my diagram:
[101a]
|----------|
|(Fe0)
R9
|(S0)
. |
<-----AREA2 ----> . | [101C]
. |
-- . |(S1)
|(Fe0) (s0) (s1). (e0) (e0)
[201B]|--- R8 --------------.R2 ------------ R5
| [201A] / . [101D]
----- / .
/ .
[401a] / .<----AREA1------>
/ .
/
R7
|(e0)
|--------------|
[401b]|(e0)
|
R6
R2 is running IPX RIP with R7 via ptp FR circuit in s0.
I'm trying two redistribute IPX RIP and NLSP routes among the two areas. I
can see the routes
coming from area1 and RIP been summarized at R8, however I also see networks
401a and 101d as been
learned from NLSP (like internal NLSP routes in area2). Something similar
happen in R9. I can see
the routes coming from rip and area2 been summarized, and have the networks
401a and 201a been advertised
as internal routes within area 1.
Can anybody explain me why the routes that don't belong to an specific area
are being advertised as internal
routes?
Follow are the configs and ipx route tables of the routers:
hostname r2
!
!
ipx routing 0000.0000.0002
ipx internal-network 1022
!
controller T1 0
clock source line primary
!
controller T1 1
clock source line secondary
!
!
interface Ethernet0
ip address 10.0.1.1 255.255.255.0
no lat enabled
ipx network 101D encapsulation ARPA
ipx nlsp area1 enable
!
interface Serial0
no ip address
encapsulation frame-relay IETF
no ip mroute-cache
ipx network 401A
frame-relay lmi-type ansi
!
interface Serial1
no ip address
encapsulation ppp
ipx ipxwan 1022 201A r2
ipx nlsp area2 enable
ipx nlsp area2 rip off
clockrate 4000000
!
router rip
network 10.0.0.0
!
ip classless
!
no logging console
access-list 1200 deny 4000 FFFFFF00
access-list 1200 permit -1
access-list 1201 deny 3000 FFFFFF00
access-list 1201 permit -1
access-list 1202 deny 2000 FFFFFF00
access-list 1202 permit -1
access-list 1203 deny 1000 FFFFFF00
access-list 1203 permit -1
!
!
!
ipx router nlsp area2
area-address 2000 FFFFFF00
route-aggregation
redistribute rip access-list 1200
redistribute nlsp area1 access-list 1203
!
!
ipx router nlsp area1
area-address 1000 FFFFFF00
route-aggregation
redistribute rip access-list 1200
redistribute nlsp area2 access-list 1202
!
r2#sho ipx route
Codes: C - Connected primary network, c - Connected secondary network
S - Static, F - Floating static, L - Local (internal), W - IPXWAN
R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
s - seconds, u - uses, U - Per-user static
11 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
No default route known.
NA 1000 FFFFFF00 via 0.0000.0000.0000, Nu0
NA 2000 FFFFFF00 via 0.0000.0000.0000, Nu0
NA 4000 FFFFFF00 via 0.0000.0000.0000, Nu0
L 1022 is the internal network
C 101D (ARPA), Et0
W 201A (PPP), Se1
C 401A (FRAME-RELAY), Se0
N 101A [45][02/02] via 101D.00e0.1e3e.b20a, 1966s, Et0
N 1055 [20][02/01] via 101D.00e0.1e3e.b20a, 1966s, Et0
N 1099 [45][03/02] via 101D.00e0.1e3e.b20a, 1966s, Et0
N 201B [26][01/01] via 2055.0000.0000.0001, 1954s, Se1
N 2055 [26][02/01] via 2055.0000.0000.0001, 1954s, Se1
R 401B [07/01] via 401A.0000.0000.0007, 31s, Se0
hostname r8
!
no logging console
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
!
ipx routing 0000.0000.0008
ipx internal-network 2055
isdn voice-call-failure 0
!
!
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
ipx ipxwan 2055 201A r8
ipx nlsp area2 enable
no fair-queue
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
isdn guard-timer 0 on-expiry accept
!
interface FastEthernet0
no ip address
no ip directed-broadcast
half-duplex
ipx network 201B encapsulation ARPA
ipx nlsp area2 enable
!
ip classless
no ip http server
!
!
!
ipx router nlsp area2
area-address 2000 FFFFFF00
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
r8#sho ipx route
Codes: C - Connected primary network, c - Connected secondary network
S - Static, F - Floating static, L - Local (internal), W - IPXWAN
R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
s - seconds, u - uses, U - Per-user static
6 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
No default route known.
NA 1000 FFFFFF00 [26][02/06] via 1022.0000.0000.0001, 4s, Se0
NA 4000 FFFFFF00 [26][02/06] via 1022.0000.0000.0001, 4s, Se0
L 2055 is the internal network
W 201A (PPP), Se0
C 201B (ARPA), Fa0
N 101D [26][01/01] via 1022.0000.0000.0001, 4s, Se0
<- This network belongs to area1
N 1022 [26][02/01] via 1022.0000.0000.0001, 4s, Se0
<- This network belongs to area1 (int net r2)
N 401A [26][01/01] via 1022.0000.0000.0001, 4s, Se0
<- This network came from RIP
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r9
!
no logging console
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
!
ipx routing 0000.0000.0009
ipx internal-network 1099
isdn voice-call-failure 0
!
!
!
interface Serial0
ip address 10.0.2.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
ipx ipxwan 900 101C r9
ipx nlsp area1 enable
no fair-queue
clockrate 4000000
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
isdn guard-timer 0 on-expiry accept
!
interface FastEthernet0
no ip address
no ip directed-broadcast
half-duplex
ipx network 101A encapsulation ARPA
ipx nlsp area1 enable
!
router rip
network 10.0.0.0
!
ip classless
no ip http server
!
!
!
ipx router nlsp area1
area-address 1000 FFFFFF00
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
r9#sho ipx route
Codes: C - Connected primary network, c - Connected secondary network
S - Static, F - Floating static, L - Local (internal), W - IPXWAN
R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
s - seconds, u - uses, U - Per-user static
8 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
No default route known.
NA 2000 FFFFFF00 [45][03/06] via 1055.0000.0000.0001, 88s, Se0
NA 4000 FFFFFF00 [45][03/06] via 1055.0000.0000.0001, 88s, Se0
L 1099 is the internal network
C 101A (ARPA), Fa0
W 101C (PPP), Se0
N 101D [25][01/01] via 1055.0000.0000.0001, 88s, Se0
N 1022 [45][03/02] via 1055.0000.0000.0001, 88s, Se0
N 1055 [25][02/01] via 1055.0000.0000.0001, 88s, Se0
N 201A [45][02/02] via 1055.0000.0000.0001, 88s, Se0
<- This network belogs to area2
N 401A [45][02/02] via 1055.0000.0000.0001, 88s, Se0
<- This network came from RIP
Thanks!
Alberto Reyna
EDS Transmission Engineering
(972) 604 1309
(972) 796 7992 Fax
e-mail:alberto.reyna@eds.com
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:07 GMT-3