Re: IRB

From: Ben_J_Durand@xxxxxxxxxx
Date: Fri Mar 17 2000 - 10:41:44 GMT-3


   

Actually, I don't believe you need a BVI on every router. Looking at Ronald's
config, he does have a BVI interface in there. If I'm not mistaken, whenever
the interfaces are put in a bridge group, they will stop responding to their IP
addresses since they are in bridges mode. This is where the BVI comes into
play. It responds to IP on behalf of the interfaces that are part og the bridg
e
group. As such, any IGRP advertisements would be sourced by the BVI, not the
interfaces. If you look at the "router igrp" section, you do not have an entry
covering the ip subnet of the BVI (99...), so the BVI will not be particitaping
in IGRP.

You may want to try not putting your serial interface into bridge-group 1 and
put in a "frame-relay map bridge 401 broadcast" instead.

- Ben

"Ronald Johnson" <ronbob@ibm.net> on 03/16/2000 10:37:24 PM

Please respond to "Ronald Johnson" <ronbob@ibm.net>

To: cisco@groupstudy.com
cc: ccielab@groupstudy.com (bcc: Ben J Durand/Tivoli Systems)
Subject: IRB

Question.. I have two routers running IGRP over a frame link. When I turn on
IRB on router A (Bridging and Routing IPX, Decnet, Appletalk, IP), router B
stops receiving IGRP updates from router A. When I do a "debug ip igrp
events" on Router A it shows I am still receiving updates from router B and
sending updates out Serial 0. However, issuing the debug igrp command on
router B shows router B is sending updates, but is not receiving IGRP
updates from anyone. Even more strange is the fact that I cannot ping either
serial interface from either side when IRB is turned on!

RouterA-S0: <----IGRP----> :S0.1-RouterB

Seems like a simple scenario. However, as soon as I type "bridge irb" on
router A, router B no longer receives IGRP updates from
router A... Am I missing something obvious here? I am hoping for one of
those obvious gotcha answers since I am too tired to figure this out
tonight.. :D (config below)

Thanks.

-Ron

Router A:
!
interface Ethernet0
 ip address 5.5.5.5 255.255.255.0
 no keepalive
 ipx network 4A
 bridge-group 1
!
interface Serial0
 ip address 192.168.3.66 255.255.255.248
 encapsulation frame-relay
 decnet cost 1
 ipx network 40
 cdp enable
 frame-relay map ip 192.168.3.65 401 broadcast
 no frame-relay inverse-arp
 bridge-group 1
!
interface Serial1
 ip address 208.158.193.129 255.255.255.248
 clockrate 2000000
 bridge-group 1
!
interface TokenRing0
 ip address 10.1.1.1 255.255.255.0
 decnet cost 5
 ipx network 4B
 ring-speed 4
!
interface BVI1
 ip address 99.99.99.99 255.255.255.248
 ipx network C30
!
router igrp 50
 redistribute bgp 200 metric 1544 10 255 100 1400
 passive-interface Ethernet0
 passive-interface TokenRing0
 network 10.0.0.0
 network 192.168.3.0
 network 5.0.0.0
 network 208.158.193.0
 network 99.0.0.0
 distribute-list 1 out
!
router bgp 200
 no synchronization
 redistribute connected
 neighbor 192.168.3.106 remote-as 200
 neighbor 192.168.3.106 next-hop-self
 neighbor 208.158.193.130 remote-as 100
!
ip classless
ip as-path access-list 10 deny _300
ip as-path access-list 10 permit .*
logging buffered 8000 debugging
access-list 1 permit 5.0.0.0
access-list 1 permit 7.0.0.0
access-list 1 permit 8.0.0.0
access-list 1 permit 9.0.0.0
access-list 1 permit 10.0.0.0
access-list 1 permit 192.168.3.20 0.0.0.3
access-list 1 permit 192.168.3.64 0.0.0.7
access-list 1 permit 192.1.24.0 0.0.0.7
access-list 1 permit 208.158.193.0 0.0.0.255
access-list 1 permit 99.0.0.0 0.255.255.255
access-list 2 deny 192.168.3.0 0.0.0.255
access-list 2 permit any
!
!
bridge irb
bridge 1 protocol ieee
 bridge 1 route decnet
 bridge 1 route ip
 bridge 1 route ipx

=============================================

Router B:
interface Ethernet0
 ip address 192.168.5.1 255.255.255.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 cisco
 ip ospf interface-retry 0
 ipx network 5
!
interface Serial0.1 point-to-point << to router A
 ip address 192.168.3.65 255.255.255.248
 no ip directed-broadcast
 no ip split-horizon
 ip ospf network point-to-multipoint
 ip ospf interface-retry 0
 ip ospf priority 100
 decnet cost 1
 ipx network 40
 no arp frame-relay
 frame-relay interface-dlci 104
 bridge-group 1
!
interface Serial0.2 multipoint
 ip address 192.168.3.105 255.255.255.248
 no ip directed-broadcast
 no ip split-horizon
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ip ospf interface-retry 0
 ip ospf priority 100
 appletalk cable-range 500-500 500.1
 appletalk zone WAN2
 decnet cost 4
 ipx network 20
 frame-relay map bridge 102 broadcast
 frame-relay map ipx 20.0000.0c47.5eb7 103 broadcast
 frame-relay map decnet 2.3 102 broadcast
 frame-relay map ip 192.168.3.106 102 broadcast
 frame-relay map ip 192.168.3.107 103 broadcast
 frame-relay map ipx 20.0000.0c47.b92b 102 broadcast
 frame-relay map appletalk 500.2 102 broadcast
 frame-relay map appletalk 500.3 103 broadcast
 frame-relay interface-dlci 102
 frame-relay interface-dlci 103
 no frame-relay inverse-arp
 bridge-group 1

router ospf 200
 area 0 authentication message-digest
 redistribute igrp 50 subnets
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.5.0 0.0.0.255 area 0
!
router igrp 50
 redistribute connected metric 10 255 255 120 1400
 redistribute ospf 200 metric 1544 30 255 20 1400
 network 192.168.3.0
 network 192.168.5.0
!
bridge 1 protocol ieee



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:05 GMT-3