RE: SVC Without ILMI: What Am I Missing?

From: Freeland, Erik (Erik.Freeland@xxxxxxxxxxxxxxx)
Date: Thu Dec 30 1999 - 19:51:19 GMT-3


   
You probably have looked at this.

http://www.cisco.com/warp/public/121/13.html

The only thing I see is that they do not have the atm pvc 16 0 16 ilmi
statement.

PLus from the configs you sent, ilmi is running and it seems to be sending
prefix info to the router.

-----Original Message-----
From: Mike McSpedon [mailto:Mike@ccci.com]
Sent: Thursday, December 30, 1999 12:23 PM
To: ccielab@groupstudy.com
Subject: SVC Without ILMI: What Am I Missing?

Folks,

I have been practicing configuring ATM in preparation for my CCIE lab test
on 2/1-2/2. The one thing I'm still having some trouble with is
configuring an SVC with no ILMI (with ILMI is no problem). The network is
very simple, two 3640s each with an OC3 card and an LS1010 between them.

r13 Atm0/0<===>ATM0/1/1LS1010ATM0/1/1<===>ATM0/0 r14

In a nutshell I found that no matter what I did, I needed to turn on ILMI
to make it work. The configs are below. Note that the ILMI PVC is
configured. Was I supposed to manually register the router ATM addresses
with the switch? If so how? Any help will be appreciated.

TIA!
-Mike
==================

hostname r13
!
interface Loopback0
 ip address 140.10.255.13 255.255.255.255
!
interface ATM0/0
 ip address 140.10.100.13 255.255.255.0
 map-group SVC
 atm nsap-address AA.000000000000000000000000.000100010001.00
 atm uni-version 4.0
 atm pvc 5 0 5 qsaal
 atm pvc 16 0 16 ilmi
 no atm ilmi-keepalive
 atm arp-server self
!
interface FastEthernet1/0
 ip address 140.10.13.1 255.255.255.0
!
router ospf 13
 redistribute connected subnets
 network 140.10.13.0 0.0.0.255 area 9
 network 140.10.100.0 0.0.0.255 area 0
 neighbor 140.10.100.14 priority 1
!
map-list SVC
 ip 140.10.100.14 atm-nsap BB.000000000000000000000000.000200020002.00
broadcast
!
end

r13#sh ip ro

Gateway of last resort is not set

     140.10.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 140.10.255.13/32 is directly connected, Loopback0
O E2 140.10.255.14/32 [110/20] via 140.10.100.14, ATM0/0
O IA 140.10.14.0/24 [110/2] via 140.10.100.14, ATM0/0
C 140.10.13.0/24 is directly connected, FastEthernet1/0
C 140.10.100.0/24 is directly connected, ATM0/0

r13#sh atm ilmi-stat

Interface : ATM0/0 Interface Type : Private UNI (User-side)
ILMI VCC : (0, 16) ILMI Keepalive : Disabled
ILMI State: UpAndNormal
Peer IP Addr: 0.0.0.0 Peer IF Name: ATM0/1/1
Peer MaxVPIbits: 8 Peer MaxVCIbits: 14
Active Prefix(s) :
47.0091.8100.0000.00d0.baf3.3b01

hostname r14
!
interface Loopback0
 ip address 140.10.255.14 255.255.255.255
!
interface ATM0/0
 ip address 140.10.100.14 255.255.255.0
 map-group SVC
 atm nsap-address BB.000000000000000000000000.000200020002.00
 atm pvc 5 0 5 qsaal
 atm pvc 16 0 16 ilmi
 no atm ilmi-keepalive
 atm arp-server self
!
interface FastEthernet1/0
 ip address 140.10.14.1 255.255.255.0
!
router ospf 14
 redistribute connected subnets
 network 140.10.14.0 0.0.0.255 area 5
 network 140.10.100.0 0.0.0.255 area 0
 neighbor 140.10.100.13 priority 1
!
map-list SVC
 ip 140.10.100.13 atm-nsap AA.000000000000000000000000.000100010001.00
broadcast
!
end

r14#sh ip ro

Gateway of last resort is not set

     140.10.0.0/16 is variably subnetted, 5 subnets, 2 masks
O E2 140.10.255.13/32 [110/20] via 140.10.100.13, ATM0/0
C 140.10.255.14/32 is directly connected, Loopback0
C 140.10.14.0/24 is directly connected, FastEthernet1/0
O IA 140.10.13.0/24 [110/2] via 140.10.100.13, ATM0/0
C 140.10.100.0/24 is directly connected, ATM0/0
r14#sh atm ilmi-stat

Interface : ATM0/0 Interface Type : Private UNI (User-side)
ILMI VCC : (0, 16) ILMI Keepalive : Disabled
ILMI State: UpAndNormal
Peer IP Addr: 0.0.0.0 Peer IF Name: ATM0/1/0
Peer MaxVPIbits: 8 Peer MaxVCIbits: 14
Active Prefix(s) :
47.0091.8100.0000.00d0.baf3.3b01

ls1010#sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ls1010
!
ip subnet-zero
!
atm address 47.0091.8100.0000.00d0.baf3.3b01.00d0.baf3.3b01.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
process-max-time 200
!
interface ATM0/1/0
 desc ***connection to R14
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/1/1
 desc ***connection to R13
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/1/2
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM0/1/3
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM2/0/0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
!
interface Ethernet2/0/0
 no ip address
 no ip directed-broadcast
!
ip classless
!
atm route aa.0000... ATM0/1/1
atm route bb.0000... ATM0/1/0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:22:00 GMT-3