Re: NSSA and Redistribution

From: Bill Wade (wwade@xxxxxxxxx)
Date: Tue Sep 14 1999 - 08:12:59 GMT-3


   
Not sure why you have Area 0 on all your boxes.

I've got the following running. Hope it helps.

Bill

R5 ---------------------------- R4 -------------------------------- R1

Area 5 Area 4 (Virtual Area 0
NSSA Link)

Configs -

version 11.3
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r5
!
enable password lab
!
no ip domain-lookup
!
!
interface Loopback0
 ip address 155.100.5.5 255.255.255.0
!
interface Loopback1
 ip address 155.155.5.5 255.255.255.0
!
interface Ethernet0
 ip address 150.100.5.5 255.255.255.0
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 5
 redistribute connected metric 10 metric-type 1 subnets route-map loop
 network 150.100.5.0 0.0.0.255 area 5
 area 5 nssa
!
ip classless
!
access-list 10 permit 155.100.5.0 0.0.0.255
access-list 10 deny any
route-map loop permit 10
 match ip address 10
!
!
line con 0
 exec-timeout 0 0
line 1 16
line aux 0
line vty 0 4
 password lab
 login
!

version 11.3
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r4
!
enable password lab
!
no ip domain-lookup
!
!
interface Ethernet0
 ip address 150.100.5.4 255.255.255.0
!
interface Serial0
 ip address 150.100.4.4 255.255.255.0
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router ospf 4
 network 150.100.4.0 0.0.0.255 area 4
 network 150.100.5.0 0.0.0.255 area 5
 area 4 virtual-link 150.100.33.1
 area 5 nssa default-information-originate
 area 5 default-cost 10
!
ip classless
!
!
line con 0
 exec-timeout 0 0
 password lab
 login
line 1 16
line aux 0
line vty 0 4
 password lab
 login
!
end

version 11.3
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r1
!
enable password lab
!
no ip domain-lookup
!
!
interface Loopback0
 ip address 151.100.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 no ip mroute-cache
 no fair-queue
 clockrate 64000
 frame-relay lmi-type ansi
!
interface Serial0.2 point-to-point
 ip address 150.100.33.1 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 100
!
interface Serial1
 ip address 150.100.4.1 255.255.255.0
 clockrate 64000
!
router ospf 1
 network 150.100.4.0 0.0.0.255 area 4
 network 150.100.33.0 0.0.0.255 area 0
 network 151.100.1.0 0.0.0.255 area 0
 area 4 virtual-link 150.100.5.4
!
ip classless
!
!
line con 0
 exec-timeout 0 0
 password lab
 login
line 1 16
line aux 0
line vty 0 4
 password lab
 login
!
end

r1# sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     153.100.0.0/32 is subnetted, 1 subnets
O 153.100.3.3 [110/129] via 150.100.33.2, 00:07:03, Serial0.2
     152.100.0.0/32 is subnetted, 1 subnets
O 152.100.2.2 [110/65] via 150.100.33.2, 00:07:03, Serial0.2
     155.100.0.0/24 is subnetted, 1 subnets
O E1 155.100.5.0 [110/84] via 150.100.4.4, 00:07:03, Serial1
     151.100.0.0/24 is subnetted, 1 subnets
C 151.100.1.0 is directly connected, Loopback0
     150.100.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 150.100.33.3/32 [110/128] via 150.100.33.2, 00:07:03, Serial0.2
O 150.100.33.2/32 [110/64] via 150.100.33.2, 00:07:03, Serial0.2
C 150.100.33.0/24 is directly connected, Serial0.2
O 150.100.26.0/24 [110/74] via 150.100.33.2, 00:07:04, Serial0.2
C 150.100.4.0/24 is directly connected, Serial1
O IA 150.100.5.0/24 [110/74] via 150.100.4.4, 00:07:05, Serial1
O E2 206.25.0.0/16 [110/20] via 150.100.33.2, 00:07:05, Serial0.2
r1#

At 10:59 PM 9/12/99 , GRIZZUTI Javier wrote:
>
>I have this scenario
>
>R3----NSSA(HDLC)----R6----Area0(Frame Relay)---R5
>
>From R3 I have EIGRP routes (30.0.0.0) which are being redistributed in the
>NSSA area . I'm summarazing in R6 . I see the routes as N1 in R6 but I can't
>see these routes in R5 . I really don't know why .
>Did I make any mistake in the configs ? Here they are :
>
>
>R3
>......
>!
>router eigrp 1
> network 30.0.0.0
> no auto-summary
>!
>router ospf 1
> redistribute eigrp 1 subnets route-map EIGRP-OSPF
> network 10.10.0.0 0.0.255.255 area 0
> network 20.20.0.0 0.0.255.255 area 4
> area 4 nssa
>!
>ip classless
>!
>access-list 5 permit 30.0.0.0 0.255.255.255
>route-map EIGRP-OSPF permit 10
> match ip address 5
> set metric 50
> set metric-type type-1
>!
>
>......
>
>
>R6
>
>.....
>!
>interface Serial1
> ip address 20.20.6.6 255.255.0.0
> ip ospf cost 20
>!
>router ospf 1
> summary-address 30.0.0.0 255.240.0.0
> network 10.10.0.0 0.0.255.255 area 0
> network 10.60.0.0 0.0.255.255 area 4
> network 20.20.0.0 0.0.255.255 area 4
> area 4 nssa default-information-originate
> area 4 default-cost 20
>
>
>......
>
>R5
>
>....
>
>router ospf 1
> network 10.1.5.5 0.0.0.0 area 1
> network 10.10.0.0 0.0.255.255 area 0
> network 10.20.0.0 0.0.255.255 area 5
> network 10.50.0.0 0.0.255.255 area 5
> default-information originate always
> area 5 virtual-link 10.70.2.7
>!
>
>.....
>
>
>
>
>R6
>
>sh ip route
>...
>
> 30.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
>O N1 30.10.0.0/16 [110/70] via 20.20.3.3, 00:05:14, Serial1
>O N1 30.5.3.0/24 [110/70] via 20.20.3.3, 00:05:14, Serial1
>O N1 30.4.3.0/24 [110/70] via 20.20.3.3, 00:05:14, Serial1
>O N1 30.2.2.2/32 [110/70] via 20.20.3.3, 00:05:15, Serial1
>O N1 30.3.3.3/32 [110/70] via 20.20.3.3, 00:05:15, Serial1
>O N1 30.2.2.3/32 [110/70] via 20.20.3.3, 00:05:15, Serial1
>O N1 30.2.2.1/32 [110/70] via 20.20.3.3, 00:05:15, Serial1
>O*E2 0.0.0.0/0 [110/1] via 10.10.5.5, 00:00:45, Serial0
>
>
>R5
>
>sh ip route
>
>.....
>
>
>Gateway of last resort is not set
>
> 20.0.0.0/16 is subnetted, 1 subnets
>O IA 20.20.0.0 [110/84] via 10.10.6.6, 00:02:00, Serial0.1
> 10.0.0.0/8 is variably subnetted, 12 subnets, 4 masks
>C 10.10.0.0/16 is directly connected, Serial0.1
>C 10.1.0.0/17 is directly connected, Ethernet0
>C 10.20.0.0/16 is directly connected, Serial0.2
>O IA 10.60.0.6/32 [110/65] via 10.10.6.6, 00:02:00, Serial0.1
>O IA 10.60.1.6/32 [110/65] via 10.10.6.6, 00:02:00, Serial0.1
>O IA 10.60.2.6/32 [110/65] via 10.10.6.6, 00:02:00, Serial0.1
>C 10.50.0.0/24 is directly connected, Loopback0
>C 10.50.1.0/24 is directly connected, Loopback1
>C 10.50.2.0/24 is directly connected, Loopback2
>O IA 10.70.2.7/32 [110/65] via 10.20.7.7, 00:02:01, Serial0.2
>O IA 10.70.1.7/32 [110/65] via 10.20.7.7, 00:02:01, Serial0.2
>O IA 10.70.0.7/32 [110/65] via 10.20.7.7, 00:02:02, Serial0.2
> 11.0.0.0/16 is subnetted, 1 subnets
>O IA 11.1.0.0 [110/128] via 10.10.1.1, 00:02:02, Serial0.1
> 132.20.0.0/24 is subnetted, 1 subnets
>O IA 132.20.20.0 [110/74] via 10.20.7.7, 00:02:02, Serial0.2
>R5#
>
>
>
>
>
>
>
>> Ing. Javier Grizzuti
>> Systems Engineer
>> Servicios de Ingenieria de Soporte
>> SoftNet S.A. - Perú 327 1 Piso A (1067)
>> Tel: (5411)4343-4990 Ext. 254
>> Fax: (5411) 4343-9132
>> Buenos Aires - Argentina
>> E-mail: jgrizzut@softnet.com.ar
>> http://www.softnet.com.ar
>>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:50 GMT-3